aboutsummaryrefslogtreecommitdiffstats
path: root/audio/musescore
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-08-02 06:05:35 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-08-02 06:05:35 +0800
commit7f73d844cf7635e25a7f76a728b49ac1fba06d1e (patch)
tree109f53a6894ef1e002bf7ea41c60550f28992e1c /audio/musescore
parent3df2a46bb527d368ccedb12b4f81303c7065c0c4 (diff)
downloadfreebsd-ports-graphics-7f73d844cf7635e25a7f76a728b49ac1fba06d1e.tar.gz
freebsd-ports-graphics-7f73d844cf7635e25a7f76a728b49ac1fba06d1e.tar.zst
freebsd-ports-graphics-7f73d844cf7635e25a7f76a728b49ac1fba06d1e.zip
MuseScore is a free cross-platform WYSIWYG music notation program
that offers a cost-effective alternative to commercial programs such as Sibelius and Finale. You can print beautifully engraved sheet music or save it as PDF or MIDI file. Some highlights: * WYSIWYG, notes are entered on a "virtual note sheet" * Unlimited number of staves * Up to four voices per staff * Easy and fast note entry with your keyboard, mouse, or MIDI keyboard * Integrated sequencer and FluidSynth software synthesizer * Import and export of MusicXML and Standard MIDI Files * Available for Windows, Mac and Linux * Translated in 43 languages * GNU GPL licensed WWW: http://musescore.org/
Diffstat (limited to 'audio/musescore')
-rw-r--r--audio/musescore/Makefile67
-rw-r--r--audio/musescore/distinfo2
-rw-r--r--audio/musescore/files/extra-patch-log222
-rw-r--r--audio/musescore/files/patch-mscore-CMakeLists.txt22
-rw-r--r--audio/musescore/files/patch-mscore-mscore-CMakeLists.txt21
-rw-r--r--audio/musescore/pkg-descr19
-rw-r--r--audio/musescore/pkg-message9
-rw-r--r--audio/musescore/pkg-plist197
8 files changed, 359 insertions, 0 deletions
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
new file mode 100644
index 00000000000..65ad9ef11de
--- /dev/null
+++ b/audio/musescore/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: musescore
+# Date created: 28 Jul 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= musescore
+PORTVERSION= 1.1
+CATEGORIES= audio
+MASTER_SITES= SF/mscore/mscore/MuseScore-${PORTVERSION}
+DISTNAME= mscore-${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Free music composition & notation software
+
+LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib \
+ sndfile.1:${PORTSDIR}/audio/libsndfile
+
+CONFLICTS= qtscriptgenerator-[0-9]*
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui network svg xml script scripttools designer webkit \
+ qmake_build moc_build uic_build linguist_build rcc_build
+MAKE_JOBS_SAFE= yes
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/mscore
+CMAKE_OUTSOURCE= yes
+
+ALL_TARGET= lrelease all
+
+OPTIONS= JACK "Jack support" on \
+ PORTAUDIO "Portaudio support" on
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 802502 || ( ${OSVERSION} >= 900000 && ${OSVERSION} < 900027 )
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-log2
+.endif
+
+.if !defined(WITHOUT_JACK)
+CMAKE_ARGS+= -DBUILD_JACK:BOOL=ON
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+.else
+CMAKE_ARGS+= -DBUILD_JACK:BOOL=OFF
+.endif
+
+.if !defined(WITHOUT_PORTAUDIO)
+LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/include/freetype2|${LOCALBASE}/include/freetype2|; \
+ s|-lfreetype|${LOCALBASE}/lib/libfreetype.so|' \
+ ${WRKSRC}/mscore/mscore/CMakeLists.txt
+ @${FIND} ${WRKSRC} -name CMakeLists.txt -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e \
+ '/set(CMAKE_CXX_FLAGS/ { s|-g||; /$${CMAKE_CXX_FLAGS}/ ! s|"|&$${CMAKE_CXX_FLAGS} |; }'
+.if defined(WITHOUT_PORTAUDIO)
+ @${REINPLACE_CMD} -e '/PKGCONFIG.*portaudio/ d' ${WRKSRC}/mscore/CMakeLists.txt
+.endif
+
+post-install:
+ @${ECHO}; ${CAT} ${PKGMESSAGE}; ${ECHO}
+
+.include <bsd.port.mk>
diff --git a/audio/musescore/distinfo b/audio/musescore/distinfo
new file mode 100644
index 00000000000..9c1f4fcebd5
--- /dev/null
+++ b/audio/musescore/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mscore-1.1.tar.bz2) = d160b4dabbee5bbe7c0ba6e653e90fd36fae07ab7fffed2c6991b65123fee10c
+SIZE (mscore-1.1.tar.bz2) = 82410619
diff --git a/audio/musescore/files/extra-patch-log2 b/audio/musescore/files/extra-patch-log2
new file mode 100644
index 00000000000..8ff535c5747
--- /dev/null
+++ b/audio/musescore/files/extra-patch-log2
@@ -0,0 +1,22 @@
+--- mscore/awl/denomspinbox.cpp.orig 2011-07-27 17:32:23.000000000 +0400
++++ mscore/awl/denomspinbox.cpp 2011-07-28 23:50:11.000000000 +0400
+@@ -20,6 +20,8 @@
+
+ #include "denomspinbox.h"
+
++#define log2(x) (log(x)/log(2.0))
++
+ namespace Awl {
+
+ //---------------------------------------------------------
+--- mscore/mscore/measure.cpp.orig 2011-07-27 17:32:43.000000000 +0400
++++ mscore/mscore/measure.cpp 2011-07-29 04:44:58.000000000 +0400
+@@ -77,6 +77,8 @@
+ #include "spacer.h"
+ #include "duration.h"
+
++#define log2(x) (log(x)/log(2.0))
++
+ //---------------------------------------------------------
+ // MStaff
+ //---------------------------------------------------------
diff --git a/audio/musescore/files/patch-mscore-CMakeLists.txt b/audio/musescore/files/patch-mscore-CMakeLists.txt
new file mode 100644
index 00000000000..dee503db22e
--- /dev/null
+++ b/audio/musescore/files/patch-mscore-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- mscore/CMakeLists.txt.orig 2011-07-27 17:33:18.000000000 +0400
++++ mscore/CMakeLists.txt 2011-07-29 21:06:37.000000000 +0400
+@@ -255,9 +255,9 @@
+ ${PROJECT_SOURCE_DIR}/mscore
+ ${PROJECT_BINARY_DIR}
+ ${PROJECT_BINARY_DIR}/mscore
++ ${PORTAUDIO_INCDIR}
+ ${ALSA_INCDIR}
+ ${JACK_INCDIR}
+- ${PORTAUDIO_INCDIR}
+ )
+
+ ##
+@@ -352,7 +352,7 @@
+
+ add_custom_target(lrelease
+ COMMAND ${PROJECT_SOURCE_DIR}/gen-qt-projectfile ${PROJECT_SOURCE_DIR} > mscore.pro
+- COMMAND lrelease ${PROJECT_SOURCE_DIR}/share/locale/*.ts
++ COMMAND lrelease-qt4 ${PROJECT_SOURCE_DIR}/share/locale/*.ts
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+
diff --git a/audio/musescore/files/patch-mscore-mscore-CMakeLists.txt b/audio/musescore/files/patch-mscore-mscore-CMakeLists.txt
new file mode 100644
index 00000000000..2d84e0cf8cc
--- /dev/null
+++ b/audio/musescore/files/patch-mscore-mscore-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- mscore/mscore/CMakeLists.txt.orig 2011-07-27 17:32:44.000000000 +0400
++++ mscore/mscore/CMakeLists.txt 2011-07-29 05:31:28.000000000 +0400
+@@ -61,7 +61,7 @@
+ PROPERTIES generated true
+ )
+
+-include_directories(
++include_directories(BEFORE
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${PROJECT_SOURCE_DIR}
+ ${PROJECT_SOURCE_DIR}/scriptdebug
+@@ -281,8 +281,8 @@
+ ${QT_LIBRARIES}
+ ${QT_QTSCRIPT_LIBRARY_RELEASE}
+ ${QT_QTSCRIPT_TOOLS_LIBRARY_RELEASE}
+- ${ALSA_LIB}
+ ${PORTAUDIO_LIB}
++ ${ALSA_LIB}
+ al
+ awl
+ bww
diff --git a/audio/musescore/pkg-descr b/audio/musescore/pkg-descr
new file mode 100644
index 00000000000..3efd8def06e
--- /dev/null
+++ b/audio/musescore/pkg-descr
@@ -0,0 +1,19 @@
+MuseScore is a free cross-platform WYSIWYG music notation program
+that offers a cost-effective alternative to commercial programs
+such as Sibelius and Finale.
+You can print beautifully engraved sheet music or save it as PDF
+or MIDI file.
+
+Some highlights:
+
+ * WYSIWYG, notes are entered on a "virtual note sheet"
+ * Unlimited number of staves
+ * Up to four voices per staff
+ * Easy and fast note entry with your keyboard, mouse, or MIDI keyboard
+ * Integrated sequencer and FluidSynth software synthesizer
+ * Import and export of MusicXML and Standard MIDI Files
+ * Available for Windows, Mac and Linux
+ * Translated in 43 languages
+ * GNU GPL licensed
+
+WWW: http://musescore.org/
diff --git a/audio/musescore/pkg-message b/audio/musescore/pkg-message
new file mode 100644
index 00000000000..87f601bcfa8
--- /dev/null
+++ b/audio/musescore/pkg-message
@@ -0,0 +1,9 @@
+The only supported sound output is currently JACK. You should make
+sure jackd is running (jackd -r -d oss), then enable it in MuseScore
+preferences:
+
+Edit -> Preferences -> I/O -> [X] Use internal synthesizer ->
+ -> [X] JACK Audio Server
+
+Restart MuseScore, and the sound should work. You may still need to
+select different JACK ports for left/right channel in preferences.
diff --git a/audio/musescore/pkg-plist b/audio/musescore/pkg-plist
new file mode 100644
index 00000000000..83e4a95b679
--- /dev/null
+++ b/audio/musescore/pkg-plist
@@ -0,0 +1,197 @@
+bin/mscore
+share/applications/mscore.desktop
+share/mscore-1.1/demos/All_Dudes.mscz
+share/mscore-1.1/demos/Estudio-No1-Tarrega.mscx
+share/mscore-1.1/demos/PlanxtyCarolan.mscx
+share/mscore-1.1/demos/Triumph.mscz
+share/mscore-1.1/demos/adeste.mscx
+share/mscore-1.1/demos/bach-bc2.mscx
+share/mscore-1.1/demos/golliwogg.mscx
+share/mscore-1.1/demos/inv1.mscx
+share/mscore-1.1/demos/inv10.mscx
+share/mscore-1.1/demos/inv13.mscx
+share/mscore-1.1/demos/inv4.mscx
+share/mscore-1.1/demos/inv6.mscx
+share/mscore-1.1/demos/italian-1.mscz
+share/mscore-1.1/demos/praeludium1.mscx
+share/mscore-1.1/demos/prelude.mscx
+share/mscore-1.1/demos/promenade.mscx
+share/mscore-1.1/demos/sarabande-gfh.mscz
+share/mscore-1.1/demos/sarabande.xml
+share/mscore-1.1/demos/scales.mscx
+share/mscore-1.1/demos/schnee.mscz
+share/mscore-1.1/demos/sonata16.mscx
+share/mscore-1.1/demos/wtc1fuga5.mscz
+share/mscore-1.1/locale/languages.xml
+share/mscore-1.1/locale/mscore_af.qm
+share/mscore-1.1/locale/mscore_ar.qm
+share/mscore-1.1/locale/mscore_ast.qm
+share/mscore-1.1/locale/mscore_bg.qm
+share/mscore-1.1/locale/mscore_ca.qm
+share/mscore-1.1/locale/mscore_cs.qm
+share/mscore-1.1/locale/mscore_da.qm
+share/mscore-1.1/locale/mscore_de.qm
+share/mscore-1.1/locale/mscore_el.qm
+share/mscore-1.1/locale/mscore_en_GB.qm
+share/mscore-1.1/locale/mscore_en_US.qm
+share/mscore-1.1/locale/mscore_eo.qm
+share/mscore-1.1/locale/mscore_es.qm
+share/mscore-1.1/locale/mscore_eu.qm
+share/mscore-1.1/locale/mscore_fa.qm
+share/mscore-1.1/locale/mscore_fi.qm
+share/mscore-1.1/locale/mscore_fo.qm
+share/mscore-1.1/locale/mscore_fr.qm
+share/mscore-1.1/locale/mscore_gl.qm
+share/mscore-1.1/locale/mscore_he.qm
+share/mscore-1.1/locale/mscore_hi_IN.qm
+share/mscore-1.1/locale/mscore_hr.qm
+share/mscore-1.1/locale/mscore_hu.qm
+share/mscore-1.1/locale/mscore_id.qm
+share/mscore-1.1/locale/mscore_it.qm
+share/mscore-1.1/locale/mscore_ja.qm
+share/mscore-1.1/locale/mscore_ko.qm
+share/mscore-1.1/locale/mscore_lt.qm
+share/mscore-1.1/locale/mscore_nb.qm
+share/mscore-1.1/locale/mscore_nl.qm
+share/mscore-1.1/locale/mscore_pl.qm
+share/mscore-1.1/locale/mscore_pt.qm
+share/mscore-1.1/locale/mscore_pt_BR.qm
+share/mscore-1.1/locale/mscore_ro.qm
+share/mscore-1.1/locale/mscore_ru.qm
+share/mscore-1.1/locale/mscore_sk.qm
+share/mscore-1.1/locale/mscore_sl.qm
+share/mscore-1.1/locale/mscore_sv.qm
+share/mscore-1.1/locale/mscore_th.qm
+share/mscore-1.1/locale/mscore_tr.qm
+share/mscore-1.1/locale/mscore_uk.qm
+share/mscore-1.1/locale/mscore_vi.qm
+share/mscore-1.1/locale/mscore_zh_CN.qm
+share/mscore-1.1/locale/mscore_zh_TW.qm
+share/mscore-1.1/locale/qt_ar.qm
+share/mscore-1.1/locale/qt_ca.qm
+share/mscore-1.1/locale/qt_cs.qm
+share/mscore-1.1/locale/qt_da.qm
+share/mscore-1.1/locale/qt_de.qm
+share/mscore-1.1/locale/qt_el.qm
+share/mscore-1.1/locale/qt_es.qm
+share/mscore-1.1/locale/qt_eu.qm
+share/mscore-1.1/locale/qt_fa.qm
+share/mscore-1.1/locale/qt_fi.qm
+share/mscore-1.1/locale/qt_fr.qm
+share/mscore-1.1/locale/qt_gl.qm
+share/mscore-1.1/locale/qt_he.qm
+share/mscore-1.1/locale/qt_hu.qm
+share/mscore-1.1/locale/qt_id.qm
+share/mscore-1.1/locale/qt_it.qm
+share/mscore-1.1/locale/qt_ja.qm
+share/mscore-1.1/locale/qt_ko.qm
+share/mscore-1.1/locale/qt_lt.qm
+share/mscore-1.1/locale/qt_nl.qm
+share/mscore-1.1/locale/qt_pl.qm
+share/mscore-1.1/locale/qt_pt.qm
+share/mscore-1.1/locale/qt_pt_BR.qm
+share/mscore-1.1/locale/qt_ro.qm
+share/mscore-1.1/locale/qt_ru.qm
+share/mscore-1.1/locale/qt_sk.qm
+share/mscore-1.1/locale/qt_sv.qm
+share/mscore-1.1/locale/qt_tr.qm
+share/mscore-1.1/locale/qt_uk.qm
+share/mscore-1.1/locale/qt_vi.qm
+share/mscore-1.1/locale/qt_zh_CN.qm
+share/mscore-1.1/locale/qt_zh_TW.qm
+share/mscore-1.1/man/MuseScore-da.pdf
+share/mscore-1.1/man/MuseScore-de.pdf
+share/mscore-1.1/man/MuseScore-en.pdf
+share/mscore-1.1/man/MuseScore-es.pdf
+share/mscore-1.1/man/MuseScore-fi.pdf
+share/mscore-1.1/man/MuseScore-fr.pdf
+share/mscore-1.1/man/MuseScore-gl.pdf
+share/mscore-1.1/man/MuseScore-hu.pdf
+share/mscore-1.1/man/MuseScore-it.pdf
+share/mscore-1.1/man/MuseScore-ja.pdf
+share/mscore-1.1/man/MuseScore-nb.pdf
+share/mscore-1.1/man/MuseScore-nl.pdf
+share/mscore-1.1/man/MuseScore-pl.pdf
+share/mscore-1.1/man/MuseScore-pt_BR.pdf
+share/mscore-1.1/man/MuseScore-ro.pdf
+share/mscore-1.1/man/MuseScore-ru.pdf
+share/mscore-1.1/man/MuseScore-zh_CN.pdf
+share/mscore-1.1/plugins/abc_import.js
+share/mscore-1.1/plugins/break/break.js
+share/mscore-1.1/plugins/break/break.ui
+share/mscore-1.1/plugins/chordchart.js
+share/mscore-1.1/plugins/colornotes.js
+share/mscore-1.1/plugins/createscore.js
+share/mscore-1.1/plugins/musescore.com/README.txt
+share/mscore-1.1/plugins/musescore.com/icons/filesaveonline.svg
+share/mscore-1.1/plugins/musescore.com/musescore.com.js
+share/mscore-1.1/plugins/musescore.com/ui/authorize_dialog.ui
+share/mscore-1.1/plugins/musescore.com/ui/musescore_dialog.ui
+share/mscore-1.1/plugins/musescore.com/ui/musescore_progress.ui
+share/mscore-1.1/plugins/musescore.com/ui/start_browser_dialog.ui
+share/mscore-1.1/plugins/notenames.js
+share/mscore-1.1/plugins/removenotes.js
+share/mscore-1.1/plugins/removenotes.ui
+share/mscore-1.1/sound/TimGM6mb.sf2
+share/mscore-1.1/styles/Jazz_Lead_Sheet.mss
+share/mscore-1.1/styles/MuseJazz.mss
+share/mscore-1.1/styles/cchords_muse.xml
+share/mscore-1.1/styles/cchords_nrb.xml
+share/mscore-1.1/styles/cchords_rb.xml
+share/mscore-1.1/styles/cchords_sym.xml
+share/mscore-1.1/styles/chords.xml
+share/mscore-1.1/styles/jazzchords.xml
+share/mscore-1.1/styles/leadsheet.mss
+share/mscore-1.1/styles/stdchords.xml
+share/mscore-1.1/templates/Chamber Orchestra.mscx
+share/mscore-1.1/templates/Choir SATB with Piano.mscx
+share/mscore-1.1/templates/Choir SATB.mscx
+share/mscore-1.1/templates/Concert Band.mscx
+share/mscore-1.1/templates/Hymn.mscz
+share/mscore-1.1/templates/Jazz Lead Sheet.mscz
+share/mscore-1.1/templates/Lead Sheet.mscx
+share/mscore-1.1/templates/Piano.mscx
+share/mscore-1.1/templates/instruments.xml
+share/mscore-1.1/templates/instruments_ca.xml
+share/mscore-1.1/templates/instruments_de.xml
+share/mscore-1.1/templates/instruments_es.xml
+share/mscore-1.1/templates/instruments_fr.xml
+share/mscore-1.1/templates/instruments_gl.xml
+share/mscore-1.1/templates/instruments_it.xml
+share/mscore-1.1/templates/instruments_ja.xml
+share/mscore-1.1/templates/instruments_nb.xml
+share/mscore-1.1/templates/instruments_nl.xml
+share/mscore-1.1/templates/instruments_pt.xml
+share/mscore-1.1/templates/instruments_pt_BR.xml
+share/mscore-1.1/templates/instruments_ru.xml
+share/mscore-1.1/templates/instruments_uk.xml
+share/mscore-1.1/templates/instruments_zh_CN.xml
+share/mscore-1.1/templates/instruments_zh_TW.xml
+share/mscore-1.1/wallpaper/paper1.png
+share/mscore-1.1/wallpaper/paper2.png
+share/mscore-1.1/wallpaper/paper3.png
+share/mscore-1.1/wallpaper/paper4.png
+share/mscore-1.1/wallpaper/paper5.png
+share/pixmaps/mscore.png
+share/pixmaps/mscore.xpm
+%%QT_PLUGINDIR_REL%%/designer/libawlplugin.so
+%%QT_PLUGINDIR_REL%%/script/libqtscript_core.so
+%%QT_PLUGINDIR_REL%%/script/libqtscript_gui.so
+%%QT_PLUGINDIR_REL%%/script/libqtscript_network.so
+%%QT_PLUGINDIR_REL%%/script/libqtscript_uitools.so
+%%QT_PLUGINDIR_REL%%/script/libqtscript_xml.so
+@dirrmtry %%QT_PLUGINDIR_REL%%/script
+@dirrm share/mscore-1.1/wallpaper
+@dirrm share/mscore-1.1/templates
+@dirrm share/mscore-1.1/styles
+@dirrm share/mscore-1.1/sound
+@dirrm share/mscore-1.1/plugins/musescore.com/ui
+@dirrm share/mscore-1.1/plugins/musescore.com/icons
+@dirrm share/mscore-1.1/plugins/musescore.com
+@dirrm share/mscore-1.1/plugins/break
+@dirrm share/mscore-1.1/plugins
+@dirrm share/mscore-1.1/man
+@dirrm share/mscore-1.1/locale
+@dirrm share/mscore-1.1/demos
+@dirrm share/mscore-1.1
+@dirrmtry share/applications