aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rezound
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-10-04 00:39:13 +0800
committerdanfe <danfe@FreeBSD.org>2006-10-04 00:39:13 +0800
commit53d789791f8a2520949508ceabccfeb83781314c (patch)
treeb90f0db763ee1a09aa802e3cec1039cb7b19b101 /audio/rezound
parent1c6bf9edd3383c445d4ce77fd8b3225cc642308f (diff)
downloadfreebsd-ports-graphics-53d789791f8a2520949508ceabccfeb83781314c.tar.gz
freebsd-ports-graphics-53d789791f8a2520949508ceabccfeb83781314c.tar.zst
freebsd-ports-graphics-53d789791f8a2520949508ceabccfeb83781314c.zip
Try to fix the build on 4.X.
Reported by: krismail
Diffstat (limited to 'audio/rezound')
-rw-r--r--audio/rezound/Makefile14
-rw-r--r--audio/rezound/files/extra-patch-fbsd422
2 files changed, 36 insertions, 0 deletions
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 17415e069b3..866a581a49e 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -99,6 +99,16 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if defined(GCCVERSION)
+. if ${GCCVERSION} < 030000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fbsd4
+. endif
+.else
+. if ${OSVERSION} < 500035
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fbsd4
+. endif
+.endif
+
post-patch: .SILENT
.if ${OSVERSION} > 500027
${REINPLACE_CMD} -e '/atoll/d' ${WRKSRC}/config/platform/bsd.h
@@ -109,6 +119,10 @@ post-patch: .SILENT
.if ${OSVERSION} > 502120
${REINPLACE_CMD} -e '/nearbyint/d' ${WRKSRC}/config/platform/bsd.h
.endif
+.if ${OSVERSION} < 500028
+ ${REINPLACE_CMD} -e '22586,$$s/stdint/inttypes/' \
+ -e '21693s/$$srcdir/..\/../' ${WRKSRC}/configure
+.endif
${REINPLACE_CMD} -E 's,(_nl_expand_alias \()\),\1...),' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's,$$(prefix)/doc,$$(datadir)/doc,' \
${WRKSRC}/config/am_include.mk ${WRKSRC}/Makefile.in \
diff --git a/audio/rezound/files/extra-patch-fbsd4 b/audio/rezound/files/extra-patch-fbsd4
new file mode 100644
index 00000000000..88cbb9492b8
--- /dev/null
+++ b/audio/rezound/files/extra-patch-fbsd4
@@ -0,0 +1,22 @@
+--- src/backend/CPortAudioSoundRecorder.cpp.orig Mon Oct 6 13:04:39 2003
++++ src/backend/CPortAudioSoundRecorder.cpp Mon Oct 2 10:35:16 2006
+@@ -18,6 +18,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
++#include <stdio.h>
++
+ #include "CPortAudioSoundRecorder.h"
+
+ #ifdef ENABLE_PORTAUDIO
+--- src/backend/Remaster/CAdaptiveNormalizeAction.cpp.orig Tue Feb 15 08:54:44 2005
++++ src/backend/Remaster/CAdaptiveNormalizeAction.cpp Mon Oct 2 10:35:24 2006
+@@ -18,6 +18,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
++#include <stdio.h>
++
+ #include "CAdaptiveNormalizeAction.h"
+
+ #include <utility>