aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rhythmbox
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 13:29:26 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 13:29:26 +0800
commit52c95ab7ca372b7724218fbc55e465286e453139 (patch)
tree773bce5ee9849b05a3f10a1df09cc14046364a3b /audio/rhythmbox
parentc2ae44394f02aeef7a8b79afc4719e6d3237d467 (diff)
downloadfreebsd-ports-graphics-52c95ab7ca372b7724218fbc55e465286e453139.tar.gz
freebsd-ports-graphics-52c95ab7ca372b7724218fbc55e465286e453139.tar.zst
freebsd-ports-graphics-52c95ab7ca372b7724218fbc55e465286e453139.zip
Update to 0.9.1.
Diffstat (limited to 'audio/rhythmbox')
-rw-r--r--audio/rhythmbox/Makefile59
-rw-r--r--audio/rhythmbox/distinfo4
-rw-r--r--audio/rhythmbox/files/patch-configure47
-rw-r--r--audio/rhythmbox/files/patch-daapsharing_rb-daap-src.c27
-rw-r--r--audio/rhythmbox/files/patch-player_rb-recorder-gst.c12
-rw-r--r--audio/rhythmbox/files/patch-remote_bonobo_Makefile.in (renamed from audio/rhythmbox/files/patch-corba_Makefile.in)4
-rw-r--r--audio/rhythmbox/pkg-plist36
7 files changed, 127 insertions, 62 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index b4345db66e6..86771e3277a 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -3,52 +3,45 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/audio/rhythmbox/Makefile,v 1.40 2005/10/28 08:03:53 jylefort Exp $
#
PORTNAME= rhythmbox
-PORTVERSION= 0.8.8
-PORTREVISION= 6
+PORTVERSION= 0.9.1
+PORTREVISION= 2
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.8
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.9
DIST_SUBDIR= gnome2
MAINTAINER= marcus@FreeBSD.org
COMMENT= Audio player for the Gnome 2 desktop environment
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
- id3tag.0:${PORTSDIR}/audio/libid3tag
+ id3tag.0:${PORTSDIR}/audio/libid3tag \
+ totem-plparser.1:${PORTSDIR}/multimedia/totem-gstreamer \
+ dbus-1.1:${PORTSDIR}/devel/dbus
USE_BZIP2= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
-WANT_GSTREAMER= yes
-USE_LIBTOOL_VER=15
+USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui nautiluscdburner
+USE_GSTREAMER= flac mad gnomevfs gconf jpeg
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-nautilus-menu
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
+CONFIGURE_ENV= LIBS="-lm" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
GCONF_SCHEMAS= rhythmbox.schemas
-OPTIONS= XINE "Use xine backend instead of GStreamer" off \
- MONKEYMEDIA "Use MonkeyMedia metadata reader" off \
- IPOD "Enable iPod support" off
+OPTIONS= IPOD "Enable iPod support" off \
+ DAAP "Enable iTunes music sharing" off \
+ FAAD "Enable FAAD decoder support" off
.include <bsd.port.pre.mk>
-.ifdef (WITH_XINE)
-LIB_DEPENDS+= xine.14:${PORTSDIR}/multimedia/libxine \
- FLAC.7:${PORTSDIR}/audio/flac \
- mad.2:${PORTSDIR}/audio/libmad
-CONFIGURE_ARGS+= --with-player=xine
-WITH_MONKEYMEDIA= yes
-.else
-CONFIGURE_ARGS+= --with-player=gstreamer
-USE_GSTREAMER+= flac mad gnomevfs gconf
-.endif
-
.ifdef (WITH_IPOD)
CONFIGURE_ARGS+= --enable-ipod
.endif
@@ -58,29 +51,31 @@ WITH_VORBIS= yes
.endif
.ifdef (WITH_VORBIS)
-.ifndef (WITH_XINE)
USE_GSTREAMER+= vorbis
.else
-LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
-.endif
-.else
CONFIGURE_ARGS+= --disable-vorbis --disable-vorbistest
.endif
-.if !defined(WITH_XINE) && defined(WITH_FAAD)
+.if defined(WITH_FAAD)
USE_GSTREAMER+= faad
.endif
+.if defined(WITH_DAAP)
+CONFIGURE_ARGS+= --enable-daap --with-mdns=howl
+LIB_DEPENDS+= soup-2.2.8:${PORTSDIR}/devel/libsoup \
+ howl.0:${PORTSDIR}/net/howl
+.else
+.if exists(${LOCALBASE}/lib/libhowl.a)
+LIB_DEPENDS+= howl.0:${PORTSDIR}/net/howl
+.endif
+CONFIGURE_ARGS+= --disable-daap
+.endif
+
pre-everything::
.if !defined(WITH_VORBIS)
@${ECHO_MSG}
@${ECHO_MSG} "Define WITH_VORBIS to enable Vorbis support"
@${ECHO_MSG}
.endif
-.if !defined(WITH_XINE) && !defined(WITH_FAAD)
- @${ECHO_MSG}
- @${ECHO_MSG} "Define WITH_FAAD to enable Faad support"
- @${ECHO_MSG}
-.endif
.include <bsd.port.post.mk>
diff --git a/audio/rhythmbox/distinfo b/audio/rhythmbox/distinfo
index 47e7558cbbb..be35324bbe1 100644
--- a/audio/rhythmbox/distinfo
+++ b/audio/rhythmbox/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/rhythmbox-0.8.8.tar.bz2) = 46cd84b3b67f85009aa48e0e301124fe
-SIZE (gnome2/rhythmbox-0.8.8.tar.bz2) = 2435338
+MD5 (gnome2/rhythmbox-0.9.1.tar.bz2) = 942b204d1227f4d66e26a289ca762df2
+SIZE (gnome2/rhythmbox-0.9.1.tar.bz2) = 2314153
diff --git a/audio/rhythmbox/files/patch-configure b/audio/rhythmbox/files/patch-configure
new file mode 100644
index 00000000000..9c31cedaaf5
--- /dev/null
+++ b/audio/rhythmbox/files/patch-configure
@@ -0,0 +1,47 @@
+--- configure.orig Mon Oct 17 10:21:14 2005
++++ configure Mon Oct 17 10:22:47 2005
+@@ -21603,7 +21603,7 @@
+ enable_hal02=yes
+ fi
+ fi
+- if test x$enable_hal05 == xyes || test x$enable_hal02 == xyes; then
++ if test x$enable_hal05 = xyes || test x$enable_hal02 = xyes; then
+ enable_hal=yes
+ else
+ enable_hal=no
+@@ -21620,7 +21620,7 @@
+ _ACEOF
+
+ enable_ipod=yes
+- if test x$enable_hal05 == xyes; then
++ if test x$enable_hal05 = xyes; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_HAL_0_5 1
+@@ -21887,7 +21887,7 @@
+ RHYTHMBOX_LIBS="$RHYTHMBOX_LIBS $SOUNDSYSTEM_LIBS"
+
+
+- if test "x$GST_INSPECT" == "x"; then
++ if test "x$GST_INSPECT" = "x"; then
+ # Extract the first word of "gst-inspect-0.8", so it can be a program name with args.
+ set dummy gst-inspect-0.8; ac_word=$2
+ echo "$as_me:$LINENO: checking for $ac_word" >&5
+@@ -22640,7 +22640,7 @@
+
+
+ if test x"$x_includes" != x"NONE" && test -n "$x_includes" ; then
+- CFLAGS=$CFLAGS -I`echo $x_includes | sed -e "s/:/ -I/g"`
++ CFLAGS=$CFLAGS\ -I`echo $x_includes | sed -e "s/:/ -I/g"`
+ fi
+ if test x"$x_libraries" != x"NONE" && test -n "$x_libraries" ; then
+ LIBS=-L`echo $x_libraries | sed -e "s/:/ -L/g"`
+@@ -22977,7 +22977,7 @@
+ fi
+ if test "x$enable_audiocd" = "xyes"; then
+
+- if test "x$GST_INSPECT" == "x"; then
++ if test "x$GST_INSPECT" = "x"; then
+ # Extract the first word of "gst-inspect-0.8", so it can be a program name with args.
+ set dummy gst-inspect-0.8; ac_word=$2
+ echo "$as_me:$LINENO: checking for $ac_word" >&5
diff --git a/audio/rhythmbox/files/patch-daapsharing_rb-daap-src.c b/audio/rhythmbox/files/patch-daapsharing_rb-daap-src.c
new file mode 100644
index 00000000000..fdbf98e762a
--- /dev/null
+++ b/audio/rhythmbox/files/patch-daapsharing_rb-daap-src.c
@@ -0,0 +1,27 @@
+--- daapsharing/rb-daap-src.c.orig Sun Oct 16 05:50:21 2005
++++ daapsharing/rb-daap-src.c Mon Oct 17 10:30:20 2005
+@@ -34,6 +34,7 @@
+ #include <sys/ioctl.h>
+ #include <netdb.h>
+ #include <unistd.h>
++#include <signal.h>
+
+ #include <libgnome/gnome-i18n.h>
+ #include <gst/gst.h>
+@@ -580,7 +581,15 @@ gst_tcp_socket_write (int socket, const
+ size_t bytes_written = 0;
+
+ while (bytes_written < count) {
+- ssize_t wrote = send (socket, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
++ ssize_t wrote;
++#ifdef MSG_NOSIGNAL
++ wrote = send (socket, buf + bytes_written, count - bytes_written, MSG_NOSIGNAL);
++#else
++ signal (SIGPIPE, SIG_IGN);
++ wrote = send (socket, buf + bytes_written, count - bytes_written, 0);
++ signal (SIGPIPE, SIG_DFL);
++#endif
++
+
+ if (wrote <= 0) {
+ return bytes_written;
diff --git a/audio/rhythmbox/files/patch-player_rb-recorder-gst.c b/audio/rhythmbox/files/patch-player_rb-recorder-gst.c
new file mode 100644
index 00000000000..e8aae3495d1
--- /dev/null
+++ b/audio/rhythmbox/files/patch-player_rb-recorder-gst.c
@@ -0,0 +1,12 @@
+--- player/rb-recorder-gst.c.orig Wed Aug 10 20:06:11 2005
++++ player/rb-recorder-gst.c Wed Aug 10 20:06:31 2005
+@@ -25,7 +25,9 @@
+ #include <string.h>
+ #include <math.h>
+ #include <time.h>
++#ifndef __FreeBSD__
+ #include <sys/vfs.h>
++#endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/audio/rhythmbox/files/patch-corba_Makefile.in b/audio/rhythmbox/files/patch-remote_bonobo_Makefile.in
index 723285dfa01..c19ec530ea0 100644
--- a/audio/rhythmbox/files/patch-corba_Makefile.in
+++ b/audio/rhythmbox/files/patch-remote_bonobo_Makefile.in
@@ -1,5 +1,5 @@
---- corba/Makefile.in.orig Wed Aug 27 04:19:40 2003
-+++ corba/Makefile.in Wed Aug 27 04:19:56 2003
+--- remote/bonobo/Makefile.in.orig Wed Aug 27 04:19:40 2003
++++ remote/bonobo/Makefile.in Wed Aug 27 04:19:56 2003
@@ -237,7 +237,7 @@
noinst_HEADERS = Rhythmbox.h
diff --git a/audio/rhythmbox/pkg-plist b/audio/rhythmbox/pkg-plist
index 74aaaf42d9f..0ff3e3fd952 100644
--- a/audio/rhythmbox/pkg-plist
+++ b/audio/rhythmbox/pkg-plist
@@ -3,9 +3,9 @@ lib/bonobo/librb-nautilus-context-menu.so
libdata/bonobo/servers/GNOME_Rhythmbox.server
libdata/bonobo/servers/Rhythmbox_Nautilus_Context_Menu.server
libdata/pkgconfig/rhythmbox.pc
+share/dbus-1/services/org.gnome.Rhythmbox.service
share/gnome/application-registry/rhythmbox.applications
share/gnome/applications/rhythmbox.desktop
-share/gnome/gnome-2.0/ui/rhythmbox-ui.xml
share/gnome/help/rhythmbox/C/authors.xml
share/gnome/help/rhythmbox/C/fdl-appendix.xml
share/gnome/help/rhythmbox/C/figures/rb-adv.png
@@ -81,46 +81,24 @@ share/gnome/omf/rhythmbox/rhythmbox-C.omf
share/gnome/omf/rhythmbox/rhythmbox-ja.omf
share/gnome/pixmaps/rhythmbox.png
share/gnome/rhythmbox/art/about-logo.png
-share/gnome/rhythmbox/art/rhythmbox-album.png
-share/gnome/rhythmbox/art/rhythmbox-audiocd.png
-share/gnome/rhythmbox/art/rhythmbox-automatic-playlist.png
-share/gnome/rhythmbox/art/rhythmbox-dnd.png
-share/gnome/rhythmbox/art/rhythmbox-ipod.png
-share/gnome/rhythmbox/art/rhythmbox-iradio.png
-share/gnome/rhythmbox/art/rhythmbox-library.png
-share/gnome/rhythmbox/art/rhythmbox-next.png
share/gnome/rhythmbox/art/rhythmbox-no-star.png
-share/gnome/rhythmbox/art/rhythmbox-pause.png
-share/gnome/rhythmbox/art/rhythmbox-paused.png
-share/gnome/rhythmbox/art/rhythmbox-play.png
-share/gnome/rhythmbox/art/rhythmbox-playing.png
-share/gnome/rhythmbox/art/rhythmbox-playlist-menu.png
-share/gnome/rhythmbox/art/rhythmbox-playlist.png
-share/gnome/rhythmbox/art/rhythmbox-previous.png
-share/gnome/rhythmbox/art/rhythmbox-repeat.png
-share/gnome/rhythmbox/art/rhythmbox-rewind.png
share/gnome/rhythmbox/art/rhythmbox-set-star.png
-share/gnome/rhythmbox/art/rhythmbox-shuffle.png
-share/gnome/rhythmbox/art/rhythmbox-stop.png
share/gnome/rhythmbox/art/rhythmbox-tray-icon.png
share/gnome/rhythmbox/art/rhythmbox-unset-star.png
-share/gnome/rhythmbox/art/rhythmbox-visuals.png
-share/gnome/rhythmbox/art/rhythmbox-volume-max.png
-share/gnome/rhythmbox/art/rhythmbox-volume-medium.png
-share/gnome/rhythmbox/art/rhythmbox-volume-min.png
-share/gnome/rhythmbox/art/rhythmbox-volume-mute.png
-share/gnome/rhythmbox/art/rhythmbox-volume-zero.png
share/gnome/rhythmbox/glade/create-playlist.glade
+share/gnome/rhythmbox/glade/daap-prefs.glade
share/gnome/rhythmbox/glade/druid.glade
share/gnome/rhythmbox/glade/general-prefs.glade
share/gnome/rhythmbox/glade/library-prefs.glade
share/gnome/rhythmbox/glade/load-failure.glade
+share/gnome/rhythmbox/glade/recorder.glade
share/gnome/rhythmbox/glade/song-info-multiple.glade
share/gnome/rhythmbox/glade/song-info.glade
share/gnome/rhythmbox/glade/station-new.glade
share/gnome/rhythmbox/glade/station-properties.glade
share/gnome/rhythmbox/glade/uri.glade
share/gnome/rhythmbox/iradio-initial.pls
+share/gnome/rhythmbox/rhythmbox-ui.xml
share/locale/am/LC_MESSAGES/rhythmbox.mo
share/locale/ar/LC_MESSAGES/rhythmbox.mo
share/locale/az/LC_MESSAGES/rhythmbox.mo
@@ -140,6 +118,7 @@ share/locale/eu/LC_MESSAGES/rhythmbox.mo
share/locale/fi/LC_MESSAGES/rhythmbox.mo
share/locale/fr/LC_MESSAGES/rhythmbox.mo
share/locale/ga/LC_MESSAGES/rhythmbox.mo
+share/locale/gl/LC_MESSAGES/rhythmbox.mo
share/locale/he/LC_MESSAGES/rhythmbox.mo
share/locale/hr/LC_MESSAGES/rhythmbox.mo
share/locale/hu/LC_MESSAGES/rhythmbox.mo
@@ -150,9 +129,12 @@ share/locale/ja/LC_MESSAGES/rhythmbox.mo
share/locale/ko/LC_MESSAGES/rhythmbox.mo
share/locale/lt/LC_MESSAGES/rhythmbox.mo
share/locale/lv/LC_MESSAGES/rhythmbox.mo
+share/locale/mk/LC_MESSAGES/rhythmbox.mo
+share/locale/ml/LC_MESSAGES/rhythmbox.mo
share/locale/mn/LC_MESSAGES/rhythmbox.mo
share/locale/ms/LC_MESSAGES/rhythmbox.mo
share/locale/nb/LC_MESSAGES/rhythmbox.mo
+share/locale/ne/LC_MESSAGES/rhythmbox.mo
share/locale/nl/LC_MESSAGES/rhythmbox.mo
share/locale/no/LC_MESSAGES/rhythmbox.mo
share/locale/pa/LC_MESSAGES/rhythmbox.mo
@@ -161,10 +143,12 @@ share/locale/pt/LC_MESSAGES/rhythmbox.mo
share/locale/pt_BR/LC_MESSAGES/rhythmbox.mo
share/locale/ro/LC_MESSAGES/rhythmbox.mo
share/locale/ru/LC_MESSAGES/rhythmbox.mo
+share/locale/rw/LC_MESSAGES/rhythmbox.mo
share/locale/sk/LC_MESSAGES/rhythmbox.mo
share/locale/sr/LC_MESSAGES/rhythmbox.mo
share/locale/sr@Latn/LC_MESSAGES/rhythmbox.mo
share/locale/sv/LC_MESSAGES/rhythmbox.mo
+share/locale/th/LC_MESSAGES/rhythmbox.mo
share/locale/tr/LC_MESSAGES/rhythmbox.mo
share/locale/uk/LC_MESSAGES/rhythmbox.mo
share/locale/vi/LC_MESSAGES/rhythmbox.mo