aboutsummaryrefslogtreecommitdiffstats
path: root/audio/spiralloops
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-09-17 03:02:06 +0800
committerwill <will@FreeBSD.org>2000-09-17 03:02:06 +0800
commita09cbd37bde85cb97e00d0523333277e7b05e820 (patch)
tree019758a2d9a47b39a087d3d0a99e69e0ff490a04 /audio/spiralloops
parent2e7f5e6bf50bf3f317ceeba5b8fa97175f6fef7a (diff)
downloadfreebsd-ports-graphics-a09cbd37bde85cb97e00d0523333277e7b05e820.tar.gz
freebsd-ports-graphics-a09cbd37bde85cb97e00d0523333277e7b05e820.tar.zst
freebsd-ports-graphics-a09cbd37bde85cb97e00d0523333277e7b05e820.zip
Add spiralsynth 0.1.5, a nifty program that generates noise or music
(depending on the talents of the user) from a MIDI or PC keyboard, and outputs to /dev/dsp or to a .wav file. PR: 21053 Submitted by: Trevor Johnson <trevor@jpj.net>
Diffstat (limited to 'audio/spiralloops')
-rw-r--r--audio/spiralloops/Makefile36
-rw-r--r--audio/spiralloops/distinfo1
-rw-r--r--audio/spiralloops/pkg-comment1
-rw-r--r--audio/spiralloops/pkg-descr23
-rw-r--r--audio/spiralloops/pkg-plist5
5 files changed, 66 insertions, 0 deletions
diff --git a/audio/spiralloops/Makefile b/audio/spiralloops/Makefile
new file mode 100644
index 00000000000..d9323821d1c
--- /dev/null
+++ b/audio/spiralloops/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: spiralsynth
+# Date created: 2000-09-05
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $FreeBSD$
+#
+
+PORTNAME= spiralsynth
+PORTVERSION= 0.1.5
+CATEGORIES= audio
+MASTER_SITES= http://www.blueammonite.f9.co.uk/SpiralSynth/dload/ \
+ http://jpj.net/~trevor/freebsd/ports/
+DISTNAME= SpiralSynth-${PORTVERSION}
+
+MAINTAINER= trevor@jpj.net
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_X_PREFIX= yes
+
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+DOC_FILES= CHANGES COPYING README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/SpiralSynth ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/spiralsynth
+.for i in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/spiralsynth
+.endfor
+.endif
+.include <bsd.port.mk>
diff --git a/audio/spiralloops/distinfo b/audio/spiralloops/distinfo
new file mode 100644
index 00000000000..477281bb5bc
--- /dev/null
+++ b/audio/spiralloops/distinfo
@@ -0,0 +1 @@
+MD5 (SpiralSynth-0.1.5.tar.gz) = 7c2cd6fe828ef52e9127425301b9bbef
diff --git a/audio/spiralloops/pkg-comment b/audio/spiralloops/pkg-comment
new file mode 100644
index 00000000000..97494204d6b
--- /dev/null
+++ b/audio/spiralloops/pkg-comment
@@ -0,0 +1 @@
+MIDI-capable synthesizer for X
diff --git a/audio/spiralloops/pkg-descr b/audio/spiralloops/pkg-descr
new file mode 100644
index 00000000000..74b286c76cd
--- /dev/null
+++ b/audio/spiralloops/pkg-descr
@@ -0,0 +1,23 @@
+adapted from the Web page and the README:
+
+Spiral Synth is a physically modelled, monophonic, analogue
+synthesizer. It is capable of creating the kind of sounds made by
+hardware analogue synths, the noises used in electronic music.
+You can also use it to make stranger sounds. MIDI is supported,
+including velocity detection, mapped to the volume of the oscillators
+(but you can also use the PC keyboard to play the synth). Output
+is to /dev/dsp or in Microsoft RIFF (.WAV) format to a file. You
+can save and recall your sounds using the 100 patch save slots.
+
+The PC keyboard can be used to play the synth, "q" & "z" are C,
+and the keys progess from them, ie "2" is C#, "w" is D etc. These
+are just the defaults, and can be changed from the .Spiralrc file.
+The function keys change the octave.
+
+Sample output and a detailed list of features can be found on the
+home page.
+
+WWW: http://www.blueammonite.f9.co.uk/SpiralSynth/
+
+Trevor Johnson
+trevor@jpj.net
diff --git a/audio/spiralloops/pkg-plist b/audio/spiralloops/pkg-plist
new file mode 100644
index 00000000000..c78b27bdc0b
--- /dev/null
+++ b/audio/spiralloops/pkg-plist
@@ -0,0 +1,5 @@
+bin/SpiralSynth
+share/doc/spiralsynth/CHANGES
+share/doc/spiralsynth/COPYING
+share/doc/spiralsynth/README
+@dirrm share/doc/spiralsynth