aboutsummaryrefslogtreecommitdiffstats
path: root/audio/terminatorx/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-24 05:58:22 +0800
committerkrion <krion@FreeBSD.org>2003-08-24 05:58:22 +0800
commit11f1a54fe2f8cec1bfbe2a7457569abfe0227e29 (patch)
tree41a30d53c9b49c97bb89d779aad6fbe468a3abf5 /audio/terminatorx/Makefile
parentb85ce8d768edf44c39b36f3e14472ed51195abb7 (diff)
downloadfreebsd-ports-graphics-11f1a54fe2f8cec1bfbe2a7457569abfe0227e29.tar.gz
freebsd-ports-graphics-11f1a54fe2f8cec1bfbe2a7457569abfe0227e29.tar.zst
freebsd-ports-graphics-11f1a54fe2f8cec1bfbe2a7457569abfe0227e29.zip
- Update to version 3.81
PR: 55897 Submitted by: Ports Fury
Diffstat (limited to 'audio/terminatorx/Makefile')
-rw-r--r--audio/terminatorx/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index b31d33bd19a..a30aa8d671d 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= terminatorx
-PORTVERSION= 3.80
-PORTREVISION= 1
+PORTVERSION= 3.81
CATEGORIES= audio
MASTER_SITES= http://www.terminatorx.cx/dist/
DISTNAME= terminatorX-${PORTVERSION}
@@ -21,14 +20,13 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehier libxml2 gtk20
-USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomehier gnometarget gtk20 libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-docdir="${PREFIX}/share/gnome"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --disable-alsa --disable-jack \
+ --with-docdir="${PREFIX}/share/gnome"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
@@ -77,10 +75,12 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|function option_info|option_info|g' ${WRKSRC}/configure
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+ @${GREP} -lR "%%LOCALBASE%%" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|g'
+ @${GREP} -lR "%%X11BASE%%" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|%%X11BASE%%|${LOCALBASE}|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${PREFIX}/bin