aboutsummaryrefslogtreecommitdiffstats
path: root/audio/vorbis-tools
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-07-20 23:29:27 +0800
committernaddy <naddy@FreeBSD.org>2002-07-20 23:29:27 +0800
commit9d7bc0c1c70eb3d07c121855c0bfa7232d41a13a (patch)
tree037906d174ee1e353b5b99220b35a2ad01142d9e /audio/vorbis-tools
parent7a64e302157312ea7a60fa49ed4e1bdcc71b4fde (diff)
downloadfreebsd-ports-graphics-9d7bc0c1c70eb3d07c121855c0bfa7232d41a13a.tar.gz
freebsd-ports-graphics-9d7bc0c1c70eb3d07c121855c0bfa7232d41a13a.tar.zst
freebsd-ports-graphics-9d7bc0c1c70eb3d07c121855c0bfa7232d41a13a.zip
Welcome to the long-awaited release of Ogg Vorbis 1.0!
Diffstat (limited to 'audio/vorbis-tools')
-rw-r--r--audio/vorbis-tools/Makefile24
-rw-r--r--audio/vorbis-tools/distinfo2
-rw-r--r--audio/vorbis-tools/files/patch-ogg123::buffer.c31
-rw-r--r--audio/vorbis-tools/files/patch-oggenc::audio.c13
-rw-r--r--audio/vorbis-tools/files/patch-oggenc::man::oggenc.125
-rw-r--r--audio/vorbis-tools/pkg-plist6
6 files changed, 22 insertions, 79 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 5abdb96c68b..f6f17057fed 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -6,26 +6,32 @@
#
PORTNAME= vorbis-tools
-PORTVERSION= 1.0.r3
-PORTREVISION= 4
-PORTEPOCH= 2
+PORTVERSION= 1.0
+PORTEPOCH= 3
CATEGORIES= audio
-MASTER_SITES= http://www.xiph.org/ogg/vorbis/download/ \
- http://www.vorbis.com/files/rc3/unix/ \
- http://www.oddsock.org/vorbisrc3/files/rc3/unix/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
+MASTER_SITES= ftp://ftp.linuxpowered.com/pub/Vorbis/unix/ \
+ ftp://ftp.wiles.org/pub/mirrors/Vorbis/unix/ \
+ http://xiph.stratius.com/vorbis/unix/ \
+ http://www.oddsock.org/vorbis/unix/ \
+ http://www.casterclub.com/vorbis/unix/ \
+ http://www.math.utoledo.edu/~chaese/Vorbis/unix/
MAINTAINER= naddy@FreeBSD.org
LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
curl.2:${PORTSDIR}/ftp/curl \
iconv.3:${PORTSDIR}/converters/libiconv \
- vorbis.1:${PORTSDIR}/audio/libvorbis
+ vorbis.2:${PORTSDIR}/audio/libvorbis
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= ogg123.1 oggenc.1 ogginfo.1 vcut.1 vorbiscomment.1
+MAN1= ogg123.1 oggdec.1 oggenc.1 ogginfo.1 vcut.1 vorbiscomment.1
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/examples/vorbis-tools
+ ${INSTALL_DATA} ${WRKSRC}/ogg123/ogg123rc-example \
+ ${PREFIX}/share/examples/vorbis-tools/ogg123rc
.include <bsd.port.mk>
diff --git a/audio/vorbis-tools/distinfo b/audio/vorbis-tools/distinfo
index 3cdf621e7ea..823144c91a1 100644
--- a/audio/vorbis-tools/distinfo
+++ b/audio/vorbis-tools/distinfo
@@ -1 +1 @@
-MD5 (vorbis-tools-1.0rc3.tar.gz) = c28c6b28cddb1d7027afd9a47a0d7b9c
+MD5 (vorbis-tools-1.0.tar.gz) = c0a9fee54835e9c5b32d1f42c02964c9
diff --git a/audio/vorbis-tools/files/patch-ogg123::buffer.c b/audio/vorbis-tools/files/patch-ogg123::buffer.c
deleted file mode 100644
index 409b5ed9750..00000000000
--- a/audio/vorbis-tools/files/patch-ogg123::buffer.c
+++ /dev/null
@@ -1,31 +0,0 @@
-
-$FreeBSD$
-
---- ogg123/buffer.c.orig Thu Dec 20 01:24:53 2001
-+++ ogg123/buffer.c Sat Jan 19 16:24:44 2002
-@@ -85,12 +85,6 @@
- buf_t *buf = (buf_t *)arg;
-
- DEBUG("Enter buffer_thread_cleanup");
--
-- /* Cleanup thread data structures */
-- pthread_mutex_unlock(&buf->mutex);
-- pthread_mutex_destroy(&buf->mutex);
-- pthread_cond_destroy(&buf->playback_cond);
-- pthread_cond_destroy(&buf->write_cond);
- }
-
-
-@@ -430,6 +424,12 @@
- void buffer_destroy (buf_t *buf)
- {
- DEBUG("buffer_destroy");
-+
-+ /* Cleanup pthread variables */
-+ pthread_mutex_destroy(&buf->mutex);
-+ pthread_cond_destroy(&buf->write_cond);
-+ pthread_cond_destroy(&buf->playback_cond);
-+
- free(buf);
- }
-
diff --git a/audio/vorbis-tools/files/patch-oggenc::audio.c b/audio/vorbis-tools/files/patch-oggenc::audio.c
deleted file mode 100644
index 997207d3b7f..00000000000
--- a/audio/vorbis-tools/files/patch-oggenc::audio.c
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- oggenc/audio.c.orig Sat Dec 8 03:23:01 2001
-+++ oggenc/audio.c Tue Mar 26 03:32:57 2002
-@@ -570,6 +570,7 @@
- wav->bigendian = 0;
- wav->channels = format.channels;
- wav->samplesize = opt->samplesize;
-+ wav->totalsamples = 0;
-
- opt->read_samples = wav_read;
- opt->readdata = (void *)wav;
diff --git a/audio/vorbis-tools/files/patch-oggenc::man::oggenc.1 b/audio/vorbis-tools/files/patch-oggenc::man::oggenc.1
deleted file mode 100644
index 77a71037c4f..00000000000
--- a/audio/vorbis-tools/files/patch-oggenc::man::oggenc.1
+++ /dev/null
@@ -1,25 +0,0 @@
-
-$FreeBSD$
-
---- oggenc/man/oggenc.1.orig Wed Dec 19 07:46:57 2001
-+++ oggenc/man/oggenc.1 Wed Jan 16 03:27:33 2002
-@@ -1,7 +1,7 @@
- .\" Process this file with
- .\" groff -man -Tascii oggenc.1
- .\"
--.TH oggenc 1 "2001 August 13" "" "Vorbis Tools release candidate 2"
-+.TH oggenc 1 "2001 August 13" "" "Vorbis Tools"
-
- .SH NAME
- oggenc \- encode audio into the Ogg Vorbis format
-@@ -231,10 +231,6 @@
- Manpage Author:
- .br
- Stan Seibert <indigo@aztec.asu.edu>
--
--.SH BUGS
--Options -m, -M, and -q for for flexible bitrate/quality selection exist, but are not
--implemented in the vorbis encoder, and so are not documented here yet.
-
- .SH SEE ALSO
-
diff --git a/audio/vorbis-tools/pkg-plist b/audio/vorbis-tools/pkg-plist
index 213c84b5d8e..85a5e126d50 100644
--- a/audio/vorbis-tools/pkg-plist
+++ b/audio/vorbis-tools/pkg-plist
@@ -1,6 +1,12 @@
@comment $FreeBSD$
bin/ogg123
+bin/oggdec
bin/oggenc
bin/ogginfo
bin/vcut
bin/vorbiscomment
+share/examples/vorbis-tools/ogg123rc
+share/locale/fr/LC_MESSAGES/vorbis-tools.mo
+share/locale/nl/LC_MESSAGES/vorbis-tools.mo
+share/locale/sv/LC_MESSAGES/vorbis-tools.mo
+@dirrm share/examples/vorbis-tools