aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-crossfade
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-12-05 00:22:14 +0800
committeroliver <oliver@FreeBSD.org>2006-12-05 00:22:14 +0800
commit1feedb4363345937cc3dda1cb14e6561c2e89394 (patch)
treeb46c2ba5db4369e3721004073db00020fa6087d4 /audio/xmms-crossfade
parentb994191738a68584d20ed33412564a76fe26938e (diff)
downloadfreebsd-ports-graphics-1feedb4363345937cc3dda1cb14e6561c2e89394.tar.gz
freebsd-ports-graphics-1feedb4363345937cc3dda1cb14e6561c2e89394.tar.zst
freebsd-ports-graphics-1feedb4363345937cc3dda1cb14e6561c2e89394.zip
realy fix the build after importing new audacious
Diffstat (limited to 'audio/xmms-crossfade')
-rw-r--r--audio/xmms-crossfade/Makefile4
-rw-r--r--audio/xmms-crossfade/files/patch-configure43
2 files changed, 46 insertions, 1 deletions
diff --git a/audio/xmms-crossfade/Makefile b/audio/xmms-crossfade/Makefile
index 0e26ad32e96..8814d48e8ce 100644
--- a/audio/xmms-crossfade/Makefile
+++ b/audio/xmms-crossfade/Makefile
@@ -18,9 +18,11 @@ COMMENT= A Crossfading/Gapless Plugin
LIB_DEPENDS?= xmms.4:${PORTSDIR}/multimedia/xmms
USE_GCC= 3.4+
-USE_X_PREFIX= yes
HAS_CONFIGURE= yes
APP?= xmms
+.if ${APP} != audacious
+USE_X_PREFIX= yes
+.endif
PLUGDIR?= lib/${APP}/Output
PORTDOCS= README
PLIST_FILES= ${PLUGDIR}/libcrossfade.so
diff --git a/audio/xmms-crossfade/files/patch-configure b/audio/xmms-crossfade/files/patch-configure
new file mode 100644
index 00000000000..3f33e0a02a4
--- /dev/null
+++ b/audio/xmms-crossfade/files/patch-configure
@@ -0,0 +1,43 @@
+--- configure.orig Mon Dec 4 17:11:22 2006
++++ configure Mon Dec 4 17:12:03 2006
+@@ -20659,11 +20659,11 @@
+ _ACEOF
+
+ exit_patch=found
+-elif test "$PLAYER" == audacious
++elif test "$PLAYER" = audacious
+ then
+ # not required for audacious, which has a cleanup callback
+ exit_patch="not required for audacious"
+-elif test "$pthreads" == linuxthreads
++elif test "$pthreads" = linuxthreads
+ then
+ exit_patch="not required for linuxthreads"
+ else
+@@ -20672,7 +20672,7 @@
+ echo "$as_me:$LINENO: result: $exit_patch" >&5
+ echo "${ECHO_T}$exit_patch" >&6
+
+-if test "$exit_patch" == "not found"
++if test "$exit_patch" = "not found"
+ then
+ { echo "$as_me:$LINENO: WARNING: *** $PLAYER_BIN is not patched! ***
+
+@@ -20704,7 +20704,7 @@
+ _ACEOF
+
+ songchange_patch=found
+-elif test "$PLAYER" == audacious
++elif test "$PLAYER" = audacious
+ then
+ # not required for audacious, which calls flush(0)
+ songchange_patch="not required for audacious"
+@@ -20714,7 +20714,7 @@
+ echo "$as_me:$LINENO: result: $result" >&5
+ echo "${ECHO_T}$result" >&6
+
+-if test "$songchange_patch" == "not found"
++if test "$songchange_patch" = "not found"
+ then
+ { echo "$as_me:$LINENO: WARNING: *** $PLAYER_BIN is not patched! ***
+