aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-crystality
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-16 06:27:44 +0800
committeredwin <edwin@FreeBSD.org>2003-10-16 06:27:44 +0800
commitc713171c75540f858c432f3e49bdf9176aaf314b (patch)
treeec0df064c5f7f49f3d4240fc8742e65e7832cdc0 /audio/xmms-crystality
parentf9b8a43f16536bbc163670780a8ba1b1493ab25f (diff)
downloadfreebsd-ports-graphics-c713171c75540f858c432f3e49bdf9176aaf314b.tar.gz
freebsd-ports-graphics-c713171c75540f858c432f3e49bdf9176aaf314b.tar.zst
freebsd-ports-graphics-c713171c75540f858c432f3e49bdf9176aaf314b.zip
Unbreak port by adding \n\'s to printf statements
Noticed by: bento
Diffstat (limited to 'audio/xmms-crystality')
-rw-r--r--audio/xmms-crystality/Makefile9
-rw-r--r--audio/xmms-crystality/files/patch-gui.c53
2 files changed, 55 insertions, 7 deletions
diff --git a/audio/xmms-crystality/Makefile b/audio/xmms-crystality/Makefile
index 4b21c245f14..cfec8e8fed5 100644
--- a/audio/xmms-crystality/Makefile
+++ b/audio/xmms-crystality/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crystality
PORTVERSION= 0.92
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://fanthom.math.put.poznan.pl/~gyver/crystality/
PKGNAMEPREFIX= xmms-
@@ -23,15 +24,9 @@ INSTALLS_SHLIB= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/crystality-stdio ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/libcrystality.so \
${PREFIX}/lib/xmms/Effect
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/xmms-crystality/files/patch-gui.c b/audio/xmms-crystality/files/patch-gui.c
new file mode 100644
index 00000000000..b6671a3cc96
--- /dev/null
+++ b/audio/xmms-crystality/files/patch-gui.c
@@ -0,0 +1,53 @@
+--- gui.c.orig Wed Oct 15 15:25:32 2003
++++ gui.c Wed Oct 15 15:25:55 2003
+@@ -25,28 +25,28 @@
+ #include "crystality.h"
+
+ static const char about_text[] =
+-"Crystality Plugin v0.92
+-
+-Bandwidth Extender, Harmonic Booster and 3D Echo
+-You will need a good stereo and a good ear to notice quality
+-improvement, otherwise this is not for you. This plugin tries
+-to patch mp3 format flaws, not poor audio hardware!
+-For more info see README file!\n
+-Copyright (C) 2001 Rafal Bosak <gyver@fanthom.irc.pl>
+-
+-This program is free software; you can redistribute it and/or modify
+-it under the terms of the GNU General Public License as published by
+-the Free Software Foundation; either version 2 of the License, or
+-(at your option) any later version.
+-
+-This program is distributed in the hope that it will be useful,
+-but WITHOUT ANY WARRANTY; without even the implied warranty of
+-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-GNU General Public License for more details.
+-
+-You should have received a copy of the GNU General Public License
+-along with this program; if not, write to the Free Software
+-Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
++"Crystality Plugin v0.92\n\
++\n\
++Bandwidth Extender, Harmonic Booster and 3D Echo\n\
++You will need a good stereo and a good ear to notice quality\n\
++improvement, otherwise this is not for you. This plugin tries\n\
++to patch mp3 format flaws, not poor audio hardware!\n\
++For more info see README file!\n\n\
++Copyright (C) 2001 Rafal Bosak <gyver@fanthom.irc.pl>\n\
++\n\
++This program is free software; you can redistribute it and/or modify\n\
++it under the terms of the GNU General Public License as published by\n\
++the Free Software Foundation; either version 2 of the License, or\n\
++(at your option) any later version.\n\
++\n\
++This program is distributed in the hope that it will be useful,\n\
++but WITHOUT ANY WARRANTY; without even the implied warranty of\n\
++MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\n\
++GNU General Public License for more details.\n\
++\n\
++You should have received a copy of the GNU General Public License\n\
++along with this program; if not, write to the Free Software\n\
++Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA\n\
+ ";
+
+ GtkWidget *conf_dialog = NULL, *about_dialog = NULL;