aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-gbsplay
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-10-08 02:16:21 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-10-08 02:16:21 +0800
commitab3bfee0c9dbb1d5a818d48e360e531d487649ee (patch)
treefcbc6e054517295aac16d6de447c900ff45285f9 /audio/xmms-gbsplay
parenteb8abbedf9327c64ca79709d1db3371f403e61e6 (diff)
downloadfreebsd-ports-graphics-ab3bfee0c9dbb1d5a818d48e360e531d487649ee.tar.gz
freebsd-ports-graphics-ab3bfee0c9dbb1d5a818d48e360e531d487649ee.tar.zst
freebsd-ports-graphics-ab3bfee0c9dbb1d5a818d48e360e531d487649ee.zip
- While the main CLI player of gbsplay is receiving updates and is actively
maintained the XMMS plugin doesn't work past this version. Rather than removing the still working XMMS plugin in this version, decouple the slave port from master port and leave it at this version. This allows for the CLI player to be updated independently. - Add NLS option and therefore bump PORTREVISION - The CLI player is not needed as a run-dependency - Update WWW - Add license
Diffstat (limited to 'audio/xmms-gbsplay')
-rw-r--r--audio/xmms-gbsplay/Makefile39
-rw-r--r--audio/xmms-gbsplay/distinfo3
-rw-r--r--audio/xmms-gbsplay/pkg-descr2
3 files changed, 35 insertions, 9 deletions
diff --git a/audio/xmms-gbsplay/Makefile b/audio/xmms-gbsplay/Makefile
index 733c43e033a..3389a121e88 100644
--- a/audio/xmms-gbsplay/Makefile
+++ b/audio/xmms-gbsplay/Makefile
@@ -1,30 +1,40 @@
# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
+PORTNAME= gbsplay
+PORTVERSION= 0.0.8
+PORTREVISION= 8
+CATEGORIES= audio
+MASTER_SITES= LOCAL/ehaupt
PKGNAMEPREFIX= xmms-
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= XMMS plugin for playing Nintendo Game Boy(TM) audio
-MASTERDIR= ${.CURDIR}/../gbsplay
+LICENSE= GPLv2
BUILD_DEPENDS= xmms:multimedia/xmms
-RUN_DEPENDS= xmms:multimedia/xmms \
- gbsplay:audio/gbsplay
+RUN_DEPENDS= xmms:multimedia/xmms
USE_GNOME= glib12
USE_GCC= any
+HAS_CONFIGURE= yes
+USES= gmake
+USE_CSTD= gnu89
-CONFIGURE_ARGS= --disable-nas
+OPTIONS_DEFINE= NLS
-DESCR= ${.CURDIR}/pkg-descr
-PLIST= ${.CURDIR}/pkg-plist
+NLS_CONFIGURE_OFF= --disable-i18n
+NLS_USES= gettext-runtime
+
+CONFIGURE_ARGS= --disable-nas --prefix=${PREFIX}
PLIST_FILES= lib/xmms/Input/gbsxmms.so
post-extract:
@${RM} -f ${WRKSRC}/po/subdir.mk
-gbsplay-post-patch:
+post-patch:
@${REINPLACE_CMD} -e \
's|`which xmms-config`||; \
s|\(xmms-config\)|${LOCALBASE}/bin/\1|g; \
@@ -36,10 +46,23 @@ gbsplay-post-patch:
's|^objs += $$(objs_gbsplay) $$(objs_gbsinfo)||; \
s|^dsts += gbsplay gbsinfo||; \
/^default:/ s|$$(mans)||' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^\(default.*\)test|\1|' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e \
+ '/^need_include\ /d; \
+ 468s|char argc|int argc|; \
+ s|/usr/local/include|${LOCALBASE}/include|; \
+ s|/usr/local/lib|${LOCALBASE}/lib|; \
+ s|/usr/X11R6/include||; \
+ s|/usr/X11R6/lib||; \
+ s|/usr/X11/lib|${LOCALBASE}/lib|; \
+ s|/usr/lib/X11|${LOCALBASE}/lib/X11|; \
+ s|-Os||; s|-pipe||; s|-fomit-frame-pointer||; \
+ s|-march=$$ARCH||' \
+ ${WRKSRC}/configure
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/xmms/Input
${INSTALL_PROGRAM} ${WRKSRC}/gbsxmms.so \
${STAGEDIR}${PREFIX}/lib/xmms/Input
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/audio/xmms-gbsplay/distinfo b/audio/xmms-gbsplay/distinfo
new file mode 100644
index 00000000000..3eb821d6399
--- /dev/null
+++ b/audio/xmms-gbsplay/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475768149
+SHA256 (gbsplay-0.0.8.tar.gz) = 9bd95118741315e991dfe4f5108128817725c924ba81bb4938de45290e8f0926
+SIZE (gbsplay-0.0.8.tar.gz) = 57033
diff --git a/audio/xmms-gbsplay/pkg-descr b/audio/xmms-gbsplay/pkg-descr
index 48ae7fa0a94..9948046bf6b 100644
--- a/audio/xmms-gbsplay/pkg-descr
+++ b/audio/xmms-gbsplay/pkg-descr
@@ -2,4 +2,4 @@ xmms-gbsplay is a XMMS input plugin which emulates the sound hardware of the
Nintendo Game Boy(TM). It is able to play the sounds from a Game Boy(TM)
module dump (.GBS format) in XMMS.
-WWW: http://gbsplay.berlios.de/
+WWW: https://www.cgarbs.de/gbsplay.en.html