aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-wma
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-07-13 03:40:09 +0800
committervs <vs@FreeBSD.org>2004-07-13 03:40:09 +0800
commitf9430936a23e002c886ca72b04d0491c4b0d9495 (patch)
tree1ac5840d1e22c8cda5ee7f06945165d8900c3c0b /audio/xmms-wma
parentb9f0af7199ba562cdb26625afd9b7f6343ee7585 (diff)
downloadfreebsd-ports-graphics-f9430936a23e002c886ca72b04d0491c4b0d9495.tar.gz
freebsd-ports-graphics-f9430936a23e002c886ca72b04d0491c4b0d9495.tar.zst
freebsd-ports-graphics-f9430936a23e002c886ca72b04d0491c4b0d9495.zip
Remove iconv support: it simply damage headers instead of recoding them.
(bump PORTREVISION)
Diffstat (limited to 'audio/xmms-wma')
-rw-r--r--audio/xmms-wma/Makefile1
-rw-r--r--audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c50
2 files changed, 51 insertions, 0 deletions
diff --git a/audio/xmms-wma/Makefile b/audio/xmms-wma/Makefile
index ede2db62ede..1ee44708bf8 100644
--- a/audio/xmms-wma/Makefile
+++ b/audio/xmms-wma/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmms-wma
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://mcmcc.bat.ru/xmms-wma/
diff --git a/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
new file mode 100644
index 00000000000..bd02acd7ca9
--- /dev/null
+++ b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
@@ -0,0 +1,50 @@
+--- ffmpeg-strip-wma/asf.c.orig Sun Jul 11 06:51:15 2004
++++ ffmpeg-strip-wma/asf.c Sun Jul 11 06:53:34 2004
+@@ -18,8 +18,6 @@
+ */
+ #include "avformat.h"
+ #include "avi.h"
+-//#include "mpegaudio.h"
+-#include <iconv.h>
+
+ #undef NDEBUG
+ #include <assert.h>
+@@ -830,6 +828,7 @@
+ return str;
+ }
+
++/*
+ static void tag_recode(char *before, int len)
+ {
+ int result;
+@@ -859,21 +858,22 @@
+ return;
+ return;
+ }
++*/
+
+ static void get_str16_nolen(ByteIOContext *pb, int len, char *buf, int buf_size)
+ {
+- int c, lenz;
++ int c;
+ char *q;
+
+ q = buf;
+- lenz = len;
+ while (len > 0) {
+- c = get_byte(pb);
+- if ((q - buf) < buf_size-1)
+- *q++ = c;
+- len--;
+- }
+- tag_recode(buf, lenz);
++ c = get_le16(pb);
++ if ((q - buf) < buf_size - 1)
++ *q++ = c;
++ len-=2;
++ }
++
++ *q = '\0';
+ }
+
+ static int asf_probe(AVProbeData *pd)