aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms2/Makefile
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-06-09 18:59:46 +0800
committermadpilot <madpilot@FreeBSD.org>2012-06-09 18:59:46 +0800
commit694da0b63194e6488f307d7bf69573788cc7237a (patch)
tree9dcbd4cb97a914ad9ea19ad223fdb74d55bfb8cf /audio/xmms2/Makefile
parentf0dddcc19020f0bba24f16b97cbbed9f2c037318 (diff)
downloadfreebsd-ports-graphics-694da0b63194e6488f307d7bf69573788cc7237a.tar.gz
freebsd-ports-graphics-694da0b63194e6488f307d7bf69573788cc7237a.tar.zst
freebsd-ports-graphics-694da0b63194e6488f307d7bf69573788cc7237a.zip
- Use new options framework "SINGLE" feature.
Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'audio/xmms2/Makefile')
-rw-r--r--audio/xmms2/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 500ef0945ce..e76befa252e 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -30,10 +30,12 @@ PLIST_SUB+= INCLUDEDIR="include/${PORTNAME}" LIBDIR="lib/${PORTNAME}"
CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= AIRPLAY AO APE AVCODEC CDDA CURL ET FAAD FAM FLAC \
- GME GVFS ICES JACK MAD MDNS_APPLE MDNS_AVAHI MMS \
+ GME GVFS ICES JACK MAD MDNS MMS \
MODPLUG MPG123 MUSEPACK OFA PULSEAUDIO SAMBA SID \
SNDFILE SPEEX TREMOR VISUAL VOCODER VORBIS WAVPACK XML
-OPTIONS_DEFAULT= CURL FAAD FLAC MAD MDNS_APPLE VORBIS
+OPTIONS_SINGLE= MDNS
+OPTIONS_SINGLE_MDNS= MDNS_APPLE MDNS_AVAHI
+OPTIONS_DEFAULT= CURL FAAD FLAC MAD MDNS MDNS_APPLE VORBIS
AIRPLAY_DESC= Support output via Airport Express
APE_DESC= Support to playback Monkey's Audio files
@@ -47,8 +49,9 @@ GME_DESC= Support to playback video game music files
GVFS_DESC= Support to playback files via GVFS
ICES_DESC= Support to playback files to an icecast server
MAD_DESC= Support to playback MP3 files
-MDNS_APPLE_DESC= Support to announce XMMS2d via mDNS (Apple)
-MDNS_AVAHI_DESC= Support to announce XMMS2d via mDNS (Avahi)
+MDNS_DESC= Support to announce XMMS2d via mDNS (Choose implementation)
+MDNS_APPLE_DESC= Use Apple mDNS implementation
+MDNS_AVAHI_DESC= Use Avahi mDNS implementation
MMS_DESC= Support to playback streams via MMS
MPG123_DESC= Support to playback MP3 files
OFA_DESC= Support to collect MusicDNS fingerprints
@@ -208,9 +211,7 @@ EXCLUDE+= --without-plugins="mad"
PLIST_SUB+= MAD="@comment "
.endif
-.if ${PORT_OPTIONS:MMDNS_APPLE} && ${PORT_OPTIONS:MMDNS_AVAHI}
-IGNORE= you may choose either MDNS_APPLE or MDNS_AVAHI, but not both
-.elif !${PORT_OPTIONS:MMDNS_APPLE} && !${PORT_OPTIONS:MMDNS_AVAHI}
+.if empty(PORT_OPTIONS:MMDNS)
EXCLUDE+= --without-optionals="mdns"
.endif