aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xsidplay
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2002-11-18 13:22:43 +0800
committeranders <anders@FreeBSD.org>2002-11-18 13:22:43 +0800
commit7f08782b75558858b4cf8829f0767d0881ea8080 (patch)
treec29db664d2fcde685cc20ca95f5026979b0f8878 /audio/xsidplay
parentbfb4ab3b0d394a5e549fd1e105d8e8365d93007b (diff)
downloadfreebsd-ports-graphics-7f08782b75558858b4cf8829f0767d0881ea8080.tar.gz
freebsd-ports-graphics-7f08782b75558858b4cf8829f0767d0881ea8080.tar.zst
freebsd-ports-graphics-7f08782b75558858b4cf8829f0767d0881ea8080.zip
Add WITH_SIDPLAY2 knob for enabling libsidplay2/resid libraries.
Diffstat (limited to 'audio/xsidplay')
-rw-r--r--audio/xsidplay/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/xsidplay/Makefile b/audio/xsidplay/Makefile
index cb7064f75ea..68920379773 100644
--- a/audio/xsidplay/Makefile
+++ b/audio/xsidplay/Makefile
@@ -15,13 +15,20 @@ EXTRACT_SUFX= .tgz
MAINTAINER= coop9211@uidaho.edu
+.if defined(WITH_SIDPLAY2)
+LIB_DEPENDS= sidplay2.0:${PORTSDIR}/audio/libsidplay2
+.else
LIB_DEPENDS= sidplay.1:${PORTSDIR}/audio/libsidplay
+.endif
USE_X_PREFIX= yes
USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-qt3 --with-qt-binaries=${X11BASE}/bin
+CONFIGURE_ARGS+= --with-qt3 --with-qt-binaries=${X11BASE}/bin
+.if defined(WITH_SIDPLAY2)
+CONFIGURE_ARGS+= --with-sidplay2
+.endif
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
QTCFGLIBS+= ${PTHREAD_LIBS}
USE_REINPLACE= yes