aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2008-06-30 05:59:28 +0800
committertdb <tdb@FreeBSD.org>2008-06-30 05:59:28 +0800
commit035b70a6604a725be6f5013c86fd2148021f6940 (patch)
tree20460c1be3b27948227cf6d8970aa11aa1eefaca /audio
parentcd7f6eb639f0eb1ee65f9aecdbf0cb536898a8fe (diff)
downloadfreebsd-ports-graphics-035b70a6604a725be6f5013c86fd2148021f6940.tar.gz
freebsd-ports-graphics-035b70a6604a725be6f5013c86fd2148021f6940.tar.zst
freebsd-ports-graphics-035b70a6604a725be6f5013c86fd2148021f6940.zip
This is a statistic plugin for SqueezeCenter. SqueezeCenter normally
stores statistics about the last time a track was played, when a specific track was added to the library and how many times a track has been played. The problem is that all of these statistics are cleared every time you perform a full rescan of SqueezeCenter. The TrackStat plugin solves this problem by making sure that the statistics survive a rescan. Besides this TrackStat also extends the statistics a bit, one example is that it doesn't count a track as played just because you listen to the first 2 seconds of it, you will have to play a certain amount of the track until it is played. TrackStat also makes it possible to put a rating on all your tracks by holding a number between 1-5 down on the now playing screen. The other main functionality the TrackStat plugins provides is various ways to browse your music based on the statistic information. The standard SqueezeCenter only makes it possible to show most played tracks. The TrackStat plugin makes it possible to show the statistics in a lot more ways. The purpose is simply to give you another way to select which music you like to play, for example like: * Find tracks you haven't played for a long time * Find tracks you have recently added to the library * Find top rated tracks * Find least played tracks * And a lot more... WWW: http://wiki.slimdevices.com/index.php/TrackStat_plugin
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/squeezeboxserver-trackstat/Makefile33
-rw-r--r--audio/squeezeboxserver-trackstat/distinfo3
-rw-r--r--audio/squeezeboxserver-trackstat/pkg-descr28
-rw-r--r--audio/squeezeboxserver-trackstat/pkg-plist181
-rw-r--r--audio/squeezecenter-trackstat/Makefile33
-rw-r--r--audio/squeezecenter-trackstat/distinfo3
-rw-r--r--audio/squeezecenter-trackstat/pkg-descr28
-rw-r--r--audio/squeezecenter-trackstat/pkg-plist181
9 files changed, 491 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6de7f6954df..0d846416905 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -643,6 +643,7 @@
SUBDIR += squeezecenter-dynamicplaylist
SUBDIR += squeezecenter-lazysearch
SUBDIR += squeezecenter-superdatetime
+ SUBDIR += squeezecenter-trackstat
SUBDIR += streamripper
SUBDIR += streamtranscoder
SUBDIR += streamtuner
diff --git a/audio/squeezeboxserver-trackstat/Makefile b/audio/squeezeboxserver-trackstat/Makefile
new file mode 100644
index 00000000000..5eb6f7fc142
--- /dev/null
+++ b/audio/squeezeboxserver-trackstat/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: squeezecenter-trackstat
+# Date created: 21 June 2008
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trackstat
+PORTVERSION= 2.0.b09
+CATEGORIES= audio
+MASTER_SITES= http://erland.homeip.net/download/do/downloadapplication?name=slimserver-trackstat&filename=/
+PKGNAMEPREFIX= squeezecenter-
+DISTNAME= TrackStat-${PORTVERSION:S/b/beta/}
+DIST_SUBDIR= squeezecenter
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SqueezeCenter plugin to store ratings and statistics about songs
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/squeezecenter
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= squeezecenter
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+ ${CP} -R ${WRKSRC}/TrackStat/* ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+
+.include <bsd.port.mk>
diff --git a/audio/squeezeboxserver-trackstat/distinfo b/audio/squeezeboxserver-trackstat/distinfo
new file mode 100644
index 00000000000..ec740d7d55b
--- /dev/null
+++ b/audio/squeezeboxserver-trackstat/distinfo
@@ -0,0 +1,3 @@
+MD5 (squeezecenter/TrackStat-2.0.beta09.zip) = 4030af7aaa0d894c9a33a535be9d4bbf
+SHA256 (squeezecenter/TrackStat-2.0.beta09.zip) = de002f3d31625411922d45c33870ac1066305f4ea7578718e45b1bdd57020f74
+SIZE (squeezecenter/TrackStat-2.0.beta09.zip) = 310834
diff --git a/audio/squeezeboxserver-trackstat/pkg-descr b/audio/squeezeboxserver-trackstat/pkg-descr
new file mode 100644
index 00000000000..65e205c30b6
--- /dev/null
+++ b/audio/squeezeboxserver-trackstat/pkg-descr
@@ -0,0 +1,28 @@
+This is a statistic plugin for SqueezeCenter. SqueezeCenter normally
+stores statistics about the last time a track was played, when a
+specific track was added to the library and how many times a track has
+been played. The problem is that all of these statistics are cleared
+every time you perform a full rescan of SqueezeCenter.
+
+The TrackStat plugin solves this problem by making sure that the
+statistics survive a rescan. Besides this TrackStat also extends the
+statistics a bit, one example is that it doesn't count a track as
+played just because you listen to the first 2 seconds of it, you will
+have to play a certain amount of the track until it is played.
+TrackStat also makes it possible to put a rating on all your tracks by
+holding a number between 1-5 down on the now playing screen.
+
+The other main functionality the TrackStat plugins provides is various
+ways to browse your music based on the statistic information. The
+standard SqueezeCenter only makes it possible to show most played
+tracks. The TrackStat plugin makes it possible to show the statistics
+in a lot more ways. The purpose is simply to give you another way to
+select which music you like to play, for example like:
+
+ * Find tracks you haven't played for a long time
+ * Find tracks you have recently added to the library
+ * Find top rated tracks
+ * Find least played tracks
+ * And a lot more...
+
+WWW: http://wiki.slimdevices.com/index.php/TrackStat_plugin
diff --git a/audio/squeezeboxserver-trackstat/pkg-plist b/audio/squeezeboxserver-trackstat/pkg-plist
new file mode 100644
index 00000000000..3b7996c489d
--- /dev/null
+++ b/audio/squeezeboxserver-trackstat/pkg-plist
@@ -0,0 +1,181 @@
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/albumratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/albumratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/artistratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/artistratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackdata.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/albumheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/artistheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackheaderdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueries/problems.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueries/statistics.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/problems.template
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/problems.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/statistics.template
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/statistics.xml
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/html/images/h_PLUGIN_TRACKSTAT.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/index.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/controls.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/trackstat.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/index.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/listitems.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/mixerlink65.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/backup.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/basic.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/enabledstatistic.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/favorites.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/interface.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/rating.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/subpage_chooser.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/controls.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/browse.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/controls.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/dynamicplaylist.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/empty.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/star.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/star_noborder.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/trackstat.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/index.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/listitems.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/nowplaying.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/songinfo.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/LICENSE.txt
+%%SLIMDIR%%/Plugins/TrackStat/MenuTemplates/trackstat.template
+%%SLIMDIR%%/Plugins/TrackStat/MenuTemplates/trackstat.xml
+%%SLIMDIR%%/Plugins/TrackStat/Menus/trackstat.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatalbum.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatartist.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatgenre.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatplaylist.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatyear.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayed.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayed.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedartists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedartists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/notrated.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/notrated.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyadded.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyadded.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyaddedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyaddedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/toprated.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/toprated.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedartists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedartists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedgenres.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedgenres.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedplaylists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedplaylists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedyears.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedyears.xml
+%%SLIMDIR%%/Plugins/TrackStat/README.txt
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbcreate.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_added.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_history.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_musicbrainz.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_url_type.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_url_type255.sql
+%%SLIMDIR%%/Plugins/TrackStat/TrackStatiTunesUpdateWin.pl
+%%SLIMDIR%%/Plugins/TrackStat/iPengConfiguration/trackstat.ipeng.xml
+%%SLIMDIR%%/Plugins/TrackStat/install.xml
+%%SLIMDIR%%/Plugins/TrackStat/lib/Plugins-TrackStat-Plugin.par
+%%SLIMDIR%%/Plugins/TrackStat/strings.txt
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/lib
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/iPengConfiguration
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/SQL/mysql
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/SQL
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Mixes
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Menus
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/MenuTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/DataQueries
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/ContextMenus
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat
+@dirrmtry %%SLIMDIR%%/Plugins
+@dirrmtry %%SLIMDIR%%
diff --git a/audio/squeezecenter-trackstat/Makefile b/audio/squeezecenter-trackstat/Makefile
new file mode 100644
index 00000000000..5eb6f7fc142
--- /dev/null
+++ b/audio/squeezecenter-trackstat/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: squeezecenter-trackstat
+# Date created: 21 June 2008
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trackstat
+PORTVERSION= 2.0.b09
+CATEGORIES= audio
+MASTER_SITES= http://erland.homeip.net/download/do/downloadapplication?name=slimserver-trackstat&filename=/
+PKGNAMEPREFIX= squeezecenter-
+DISTNAME= TrackStat-${PORTVERSION:S/b/beta/}
+DIST_SUBDIR= squeezecenter
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SqueezeCenter plugin to store ratings and statistics about songs
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/squeezecenter
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= squeezecenter
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+ ${CP} -R ${WRKSRC}/TrackStat/* ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+
+.include <bsd.port.mk>
diff --git a/audio/squeezecenter-trackstat/distinfo b/audio/squeezecenter-trackstat/distinfo
new file mode 100644
index 00000000000..ec740d7d55b
--- /dev/null
+++ b/audio/squeezecenter-trackstat/distinfo
@@ -0,0 +1,3 @@
+MD5 (squeezecenter/TrackStat-2.0.beta09.zip) = 4030af7aaa0d894c9a33a535be9d4bbf
+SHA256 (squeezecenter/TrackStat-2.0.beta09.zip) = de002f3d31625411922d45c33870ac1066305f4ea7578718e45b1bdd57020f74
+SIZE (squeezecenter/TrackStat-2.0.beta09.zip) = 310834
diff --git a/audio/squeezecenter-trackstat/pkg-descr b/audio/squeezecenter-trackstat/pkg-descr
new file mode 100644
index 00000000000..65e205c30b6
--- /dev/null
+++ b/audio/squeezecenter-trackstat/pkg-descr
@@ -0,0 +1,28 @@
+This is a statistic plugin for SqueezeCenter. SqueezeCenter normally
+stores statistics about the last time a track was played, when a
+specific track was added to the library and how many times a track has
+been played. The problem is that all of these statistics are cleared
+every time you perform a full rescan of SqueezeCenter.
+
+The TrackStat plugin solves this problem by making sure that the
+statistics survive a rescan. Besides this TrackStat also extends the
+statistics a bit, one example is that it doesn't count a track as
+played just because you listen to the first 2 seconds of it, you will
+have to play a certain amount of the track until it is played.
+TrackStat also makes it possible to put a rating on all your tracks by
+holding a number between 1-5 down on the now playing screen.
+
+The other main functionality the TrackStat plugins provides is various
+ways to browse your music based on the statistic information. The
+standard SqueezeCenter only makes it possible to show most played
+tracks. The TrackStat plugin makes it possible to show the statistics
+in a lot more ways. The purpose is simply to give you another way to
+select which music you like to play, for example like:
+
+ * Find tracks you haven't played for a long time
+ * Find tracks you have recently added to the library
+ * Find top rated tracks
+ * Find least played tracks
+ * And a lot more...
+
+WWW: http://wiki.slimdevices.com/index.php/TrackStat_plugin
diff --git a/audio/squeezecenter-trackstat/pkg-plist b/audio/squeezecenter-trackstat/pkg-plist
new file mode 100644
index 00000000000..3b7996c489d
--- /dev/null
+++ b/audio/squeezecenter-trackstat/pkg-plist
@@ -0,0 +1,181 @@
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/albumratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/albumratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/artistratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/artistratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackdata.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/albumheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/artistheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackheaderdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueries/problems.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueries/statistics.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/problems.template
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/problems.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/statistics.template
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/statistics.xml
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/html/images/h_PLUGIN_TRACKSTAT.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/index.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/controls.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/trackstat.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/index.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/listitems.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/mixerlink65.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/backup.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/basic.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/enabledstatistic.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/favorites.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/interface.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/rating.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings/subpage_chooser.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/controls.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/html/images/trackstat_mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/browse.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/controls.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/dynamicplaylist.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/empty.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/star.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/star_noborder.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images/trackstat.png
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/index.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/listitems.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/nowplaying.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/songinfo.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/trackstat.css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/trackstat10scale.css
+%%SLIMDIR%%/Plugins/TrackStat/LICENSE.txt
+%%SLIMDIR%%/Plugins/TrackStat/MenuTemplates/trackstat.template
+%%SLIMDIR%%/Plugins/TrackStat/MenuTemplates/trackstat.xml
+%%SLIMDIR%%/Plugins/TrackStat/Menus/trackstat.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatalbum.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatartist.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatgenre.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatplaylist.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatyear.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayed.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayed.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedartists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedartists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/notrated.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/notrated.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyadded.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyadded.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyaddedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyaddedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/toprated.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/toprated.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedartists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedartists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedgenres.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedgenres.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedplaylists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedplaylists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedyears.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedyears.xml
+%%SLIMDIR%%/Plugins/TrackStat/README.txt
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbcreate.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_added.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_history.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_musicbrainz.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_url_type.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_url_type255.sql
+%%SLIMDIR%%/Plugins/TrackStat/TrackStatiTunesUpdateWin.pl
+%%SLIMDIR%%/Plugins/TrackStat/iPengConfiguration/trackstat.ipeng.xml
+%%SLIMDIR%%/Plugins/TrackStat/install.xml
+%%SLIMDIR%%/Plugins/TrackStat/lib/Plugins-TrackStat-Plugin.par
+%%SLIMDIR%%/Plugins/TrackStat/strings.txt
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/lib
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/iPengConfiguration
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/SQL/mysql
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/SQL
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Mixes
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Menus
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/MenuTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/iPeng
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/settings
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Classic
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/DataQueries
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/ContextMenus
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat
+@dirrmtry %%SLIMDIR%%/Plugins
+@dirrmtry %%SLIMDIR%%