aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-03-13 22:41:44 +0800
committerrakuco <rakuco@FreeBSD.org>2016-03-13 22:41:44 +0800
commit09d5a1cc0117ab4e10a620f8865cb07d6e52dda8 (patch)
tree036499a3ba68f6da770c2232bbeb8f7a5c906aff /audio
parent24f614e6586d6a4a9464235725e20014996132bc (diff)
downloadfreebsd-ports-graphics-09d5a1cc0117ab4e10a620f8865cb07d6e52dda8.tar.gz
freebsd-ports-graphics-09d5a1cc0117ab4e10a620f8865cb07d6e52dda8.tar.zst
freebsd-ports-graphics-09d5a1cc0117ab4e10a620f8865cb07d6e52dda8.zip
New port: audio/dsbmixer.
DSBMixer is a tabbed GTK+ mixer for FreeBSD. For each installed mixer device as well as for USB sound devices plugged in at runtime, DSBMixer opens a tab. Furthermore, it allows you to configure several aspects of your sound card(s), such as selecting recording sources, choosing your default audio device, and amplification. WWW: http://freeshell.de/~mk/projects/dsbmixer.html PR: 207782 Submitted by: Marcel Kaiser <mk@nic-nac-project.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/dsbmixer/Makefile29
-rw-r--r--audio/dsbmixer/distinfo2
-rw-r--r--audio/dsbmixer/pkg-descr7
-rw-r--r--audio/dsbmixer/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1ba8496c6d3..d4c1e6971b9 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -106,6 +106,7 @@
SUBDIR += discid
SUBDIR += dream
SUBDIR += drumpiler
+ SUBDIR += dsbmixer
SUBDIR += dssi
SUBDIR += dtmfdial
SUBDIR += dumb
diff --git a/audio/dsbmixer/Makefile b/audio/dsbmixer/Makefile
new file mode 100644
index 00000000000..7a3ab69f622
--- /dev/null
+++ b/audio/dsbmixer/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= dsbmixer
+PORTVERSION= 0.2.5
+CATEGORIES= audio
+MASTER_SITES= http://freeshell.de/~mk/download/
+
+MAINTAINER= mk@nic-nac-project.org
+COMMENT= Tabbed GTK+ mixer for FreeBSD
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= dsbwrtsysctl:${PORTSDIR}/sysutils/dsbwrtsysctl
+
+USES= tar:tgz pkgconfig
+USE_GNOME= gtk20
+
+OPTIONS_DEFINE= DEVD NLS
+OPTIONS_DEFAULT=DEVD NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+DEVD_DESC= Add new USB audio devices at runtime
+NLS_MAKE_ARGS_OFF= -DWITHOUT_GETTEXT
+DEVD_MAKE_ARGS_OFF= -DWITHOUT_DEVD
+
+MAKE_ARGS+= INSTALL_BACKEND="${INSTALL_PROGRAM}"
+
+.include <bsd.port.mk>
diff --git a/audio/dsbmixer/distinfo b/audio/dsbmixer/distinfo
new file mode 100644
index 00000000000..9c94a47117e
--- /dev/null
+++ b/audio/dsbmixer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dsbmixer-0.2.5.tgz) = 96fa3e0222e596250b541187ddb9ce07acec507c961f1385cd5dd80ead5fb4fc
+SIZE (dsbmixer-0.2.5.tgz) = 94720
diff --git a/audio/dsbmixer/pkg-descr b/audio/dsbmixer/pkg-descr
new file mode 100644
index 00000000000..de81853bfa9
--- /dev/null
+++ b/audio/dsbmixer/pkg-descr
@@ -0,0 +1,7 @@
+DSBMixer is a tabbed GTK+ mixer for FreeBSD. For each installed mixer device
+as well as for USB sound devices plugged in at runtime, DSBMixer opens a tab.
+Furthermore, it allows you to configure several aspects of your sound card(s),
+such as selecting recording sources, choosing your default audio device, and
+amplification.
+
+WWW: http://freeshell.de/~mk/projects/dsbmixer.html
diff --git a/audio/dsbmixer/pkg-plist b/audio/dsbmixer/pkg-plist
new file mode 100644
index 00000000000..74977da1f1b
--- /dev/null
+++ b/audio/dsbmixer/pkg-plist
@@ -0,0 +1,4 @@
+bin/dsbmixer
+@(root,wheel,4750) libexec/dsbmixer_backend
+share/applications/dsbmixer.desktop
+%%NLS%%share/locale/de/LC_MESSAGES/dsbmixer.mo