aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-16 18:59:21 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-16 18:59:21 +0800
commit0ceaef9382f2c372d9086970c15acc9ae40055d0 (patch)
treee9f0b863dcbcf5244034ef8596ae35825ecb9aa3 /audio
parentb8ffec4e651180bad39eb483237db3126501b9aa (diff)
downloadfreebsd-ports-graphics-0ceaef9382f2c372d9086970c15acc9ae40055d0.tar.gz
freebsd-ports-graphics-0ceaef9382f2c372d9086970c15acc9ae40055d0.tar.zst
freebsd-ports-graphics-0ceaef9382f2c372d9086970c15acc9ae40055d0.zip
- Support staging
- Add LICENSE
Diffstat (limited to 'audio')
-rw-r--r--audio/playmidi/Makefile6
-rw-r--r--audio/playmidi/files/patch-Makefile53
-rw-r--r--audio/playmidi/pkg-plist1
3 files changed, 32 insertions, 28 deletions
diff --git a/audio/playmidi/Makefile b/audio/playmidi/Makefile
index 7934c1a40a0..a4ba264dc51 100644
--- a/audio/playmidi/Makefile
+++ b/audio/playmidi/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= MIDI player
+LICENSE= GPLv2
+
WRKSRC= ${WRKDIR}/${PORTNAME}-2.4
ONLY_FOR_ARCHS= i386 amd64
@@ -17,8 +19,6 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ENV= PREFIX=${PREFIX}
INSTALL_TARGET= install.lame install.man
-MAN1= playmidi.1
-NO_STAGE= yes
OPTIONS_SINGLE= DEFAULTDEVICE
OPTIONS_SINGLE_DEFAULTDEVICE= EXTERNAL YAMAHA2 YAMAHA4 GRAVISULTRA SBAWE32
@@ -43,7 +43,7 @@ CONFIGURE_ENV+= ans1=3
.elif ${PORT_OPTIONS:MGRAVISULTRA}
CONFIGURE_ENV+= ans1=4
.elif ${PORT_OPTIONS:MSBAWE32}
-CONFIGURE_ENV+= ans1=5
+CONFIGURE_ENV+= ans1=5
.endif # EXTERNAL is default anyway; just use other defaults
.include <bsd.port.mk>
diff --git a/audio/playmidi/files/patch-Makefile b/audio/playmidi/files/patch-Makefile
index 15bc07ae7d2..d08757d1c3a 100644
--- a/audio/playmidi/files/patch-Makefile
+++ b/audio/playmidi/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Thu Oct 1 11:39:18 1998
-+++ Makefile Tue Aug 15 23:27:03 2000
+--- Makefile.orig 1998-10-01 04:39:18.000000000 +0200
++++ Makefile 2014-02-16 11:55:45.713871624 +0100
@@ -12,39 +12,40 @@
# ncurses usually /usr/lib, -L/usr/local/lib doesn't hurt
@@ -42,8 +42,8 @@
INCLUDES= $(INCNC) $(INCX11) $(INCVGA) $(INCAWE)
-INSTALLDIR = /usr/bin
-INSTALL = install -s
-+INSTALLDIR = ${PREFIX}/bin
-+MIDI = ${PREFIX}/share/midi
++INSTALLDIR = ${DESTDIR}${PREFIX}/bin
++MIDI = ${DESTDIR}${PREFIX}/share/midi
+#INSTALL = install -s
# if you are using the GUS Ultra driver module, add -DULTRA_DRIVER
@@ -97,24 +97,24 @@
$(INSTALLDIR)/splaymidi: splaymidi
- $(INSTALL) splaymidi $(INSTALLDIR)
--
--/etc/std.o3:
-- cp -i std.o3 /etc
+ ${BSD_INSTALL_PROGRAM} splaymidi $(INSTALLDIR)
--/etc/drums.o3:
-- cp -i drums.o3 /etc
+-/etc/std.o3:
+- cp -i std.o3 /etc
+$(MIDI)/std.o3:
+ ${BSD_INSTALL_DATA} std.o3 $(MIDI)
+
+$(MIDI)/drums.o3:
+ ${BSD_INSTALL_DATA} drums.o3 $(MIDI)
--/etc/std.sb:
-- cp -i std.sb /etc
+-/etc/drums.o3:
+- cp -i drums.o3 /etc
+$(MIDI)/std.sb:
+ ${BSD_INSTALL_DATA} std.sb $(MIDI)
+-/etc/std.sb:
+- cp -i std.sb /etc
+-
-/etc/drums.sb:
- cp -i drums.sb /etc
+$(MIDI)/drums.sb:
@@ -122,35 +122,38 @@
$(XAPPDEFAULTS)/XPlaymidi:
- cp -i XPlaymidi.ad $(XAPPDEFAULTS)/XPlaymidi
-+ ${BSD_INSTALL_DATA} XPlaymidi.ad $(XAPPDEFAULTS)/XPlaymidi
-
+-
-install: $(INSTALLDIR)/playmidi $(INSTALLDIR)/splaymidi \
- $(INSTALLDIR)/xplaymidi /etc/std.o3 /etc/drums.o3 \
- /etc/std.sb /etc/drums.sb $(XAPPDEFAULTS)/XPlaymidi
+-
+-install.novga: $(INSTALLDIR)/playmidi \
+- $(INSTALLDIR)/xplaymidi /etc/std.o3 /etc/drums.o3 \
+- /etc/std.sb /etc/drums.sb $(XAPPDEFAULTS)/XPlaymidi
++ ${BSD_INSTALL_DATA} XPlaymidi.ad $(XAPPDEFAULTS)/XPlaymidi
+
+-install.noX11: $(INSTALLDIR)/playmidi $(INSTALLDIR)/splaymidi \
+- /etc/std.o3 /etc/drums.o3 /etc/std.sb /etc/drums.sb
+dirs:
+ -@mkdir -p $(MIDI)
--install.novga: $(INSTALLDIR)/playmidi \
-- $(INSTALLDIR)/xplaymidi /etc/std.o3 /etc/drums.o3 \
+-install.Xonly: $(INSTALLDIR)/xplaymidi /etc/std.o3 /etc/drums.o3 \
- /etc/std.sb /etc/drums.sb $(XAPPDEFAULTS)/XPlaymidi
+-
+-install.lame: $(INSTALLDIR)/playmidi \
+- /etc/std.o3 /etc/drums.o3 /etc/std.sb /etc/drums.sb
+install: dirs $(INSTALLDIR)/playmidi $(INSTALLDIR)/splaymidi \
+ $(INSTALLDIR)/xplaymidi $(MIDI)/std.o3 $(MIDI)/drums.o3 \
+ $(MIDI)/std.sb $(MIDI)/drums.sb $(XAPPDEFAULTS)/XPlaymidi
-
--install.noX11: $(INSTALLDIR)/playmidi $(INSTALLDIR)/splaymidi \
-- /etc/std.o3 /etc/drums.o3 /etc/std.sb /etc/drums.sb
++
+install.novga: dirs $(INSTALLDIR)/playmidi \
+ $(INSTALLDIR)/xplaymidi $(MIDI)/std.o3 $(MIDI)/drums.o3 \
+ $(MIDI)/std.sb $(MIDI)/drums.sb $(XAPPDEFAULTS)/XPlaymidi
-
--install.Xonly: $(INSTALLDIR)/xplaymidi /etc/std.o3 /etc/drums.o3 \
-- /etc/std.sb /etc/drums.sb $(XAPPDEFAULTS)/XPlaymidi
++
+install.noX11: dirs $(INSTALLDIR)/playmidi $(INSTALLDIR)/splaymidi \
+ $(MIDI)/std.o3 $(MIDI)/drums.o3 \
+ $(MIDI)/std.sb $(MIDI)/drums.sb
-
--install.lame: $(INSTALLDIR)/playmidi \
-- /etc/std.o3 /etc/drums.o3 /etc/std.sb /etc/drums.sb
++
+install.Xonly: dirs $(INSTALLDIR)/xplaymidi \
+ $(MIDI)/std.o3 $(MIDI)/drums.o3 \
+ $(MIDI)/std.sb $(MIDI)/drums.sb $(XAPPDEFAULTS)/XPlaymidi
@@ -161,7 +164,7 @@
install.man:
- cp playmidi.1 /usr/man/man1/
-+ ${BSD_INSTALL_MAN} playmidi.1 ${PREFIX}/man/man1/
++ ${BSD_INSTALL_MAN} playmidi.1 ${DESTDIR}${PREFIX}/man/man1/
clean:
rm -f *.o playmidi splaymidi xplaymidi a.out toy seq2mid beat
diff --git a/audio/playmidi/pkg-plist b/audio/playmidi/pkg-plist
index c81bc3c57d6..3ee6c846a25 100644
--- a/audio/playmidi/pkg-plist
+++ b/audio/playmidi/pkg-plist
@@ -1,4 +1,5 @@
bin/playmidi
+man/man1/playmidi.1.gz
share/midi/drums.o3
share/midi/drums.sb
share/midi/std.o3