aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-09-07 11:47:30 +0800
committermarcus <marcus@FreeBSD.org>2007-09-07 11:47:30 +0800
commit17891ef30ffa189b00e697fa136b2a25e3818e4b (patch)
tree39ce0b8ce1cbc0a8c134d0b19e1ea213e5622edd /audio
parenta4d79e29e4950a1d1c85ad8d691b32b11a29d8f1 (diff)
downloadfreebsd-ports-graphics-17891ef30ffa189b00e697fa136b2a25e3818e4b.tar.gz
freebsd-ports-graphics-17891ef30ffa189b00e697fa136b2a25e3818e4b.tar.zst
freebsd-ports-graphics-17891ef30ffa189b00e697fa136b2a25e3818e4b.zip
As promised, remove net-im/gaim, and all dependent ports. Gaim has been
replaced by net-im/pidgin.
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gaim-festival/Makefile35
-rw-r--r--audio/gaim-festival/distinfo3
-rw-r--r--audio/gaim-festival/files/patch-Makefile15
-rw-r--r--audio/gaim-festival/files/patch-festival.c53
-rw-r--r--audio/gaim-festival/pkg-descr6
6 files changed, 0 insertions, 113 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6392efff198..8c787f480a7 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -179,7 +179,6 @@
SUBDIR += funktrackergold
SUBDIR += gai-album
SUBDIR += gai-visual-audio
- SUBDIR += gaim-festival
SUBDIR += gbsplay
SUBDIR += gdam
SUBDIR += gdrdao
diff --git a/audio/gaim-festival/Makefile b/audio/gaim-festival/Makefile
deleted file mode 100644
index 61353494bfd..00000000000
--- a/audio/gaim-festival/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# New ports collection makefile for: gaim-festival
-# Date created: 2 Jan 2005
-# Whom: Bruce M Simpson <bms@FreeBSD.org>
-#
-# $FreeBSD$
-# $MCom: ports/audio/gaim-festival/Makefile,v 1.1 2006/10/04 22:31:17 ahze Exp $
-
-PORTNAME= festival
-PORTVERSION= 1.0
-PORTREVISION= 8
-CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= festival-gaim
-PKGNAMEPREFIX= gaim-
-DISTNAME= festival-gaim-1.00
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Festival speech support for Gaim
-
-BUILD_DEPENDS= gaim:${PORTSDIR}/net-im/gaim
-RUN_DEPENDS= festival:${PORTSDIR}/audio/festival \
- gaim:${PORTSDIR}/net-im/gaim
-
-USE_GNOME= gtk20
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15:env
-MAKE_ENV= LOCALBASE=${LOCALBASE}
-
-PLIST_FILES= lib/gaim/festival.so
-
-NOMAN=
-
-do-configure:
-
-.include <bsd.port.mk>
diff --git a/audio/gaim-festival/distinfo b/audio/gaim-festival/distinfo
deleted file mode 100644
index 2c8541f342d..00000000000
--- a/audio/gaim-festival/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (festival-gaim-1.00.tar.gz) = b94bedc6494a9c223b07b0ab53f13cc2
-SHA256 (festival-gaim-1.00.tar.gz) = ef8328b38db63cc75bb246a648034a5c0715a50c8ad417b4a178d6bb0d8147a6
-SIZE (festival-gaim-1.00.tar.gz) = 43649
diff --git a/audio/gaim-festival/files/patch-Makefile b/audio/gaim-festival/files/patch-Makefile
deleted file mode 100644
index 51fe2eb8110..00000000000
--- a/audio/gaim-festival/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig Tue Sep 21 04:43:09 2004
-+++ Makefile Thu Feb 9 22:00:13 2006
-@@ -1,8 +1,7 @@
--FESTIVAL_VOICES_PATH=/usr/share/festival/voices
--PLUGIN_GAIM_PATH=/usr/lib/gaim
--PKG_CONFIG_PATH=/usr/lib/pkgconfig
--PLUGIN_CFLAGS=`pkg-config gtk+-2.0 --cflags` `pkg-config glib-2.0 --cflags` -DPLUGIN_VERSION=\"$(PLUGIN_VERSION)\" -DFESTIVAL_VOICES_PATH=\"$(FESTIVAL_VOICES_PATH)\" -march=pentium3 -O3 -pipe
-+FESTIVAL_VOICES_PATH=${LOCALBASE}/share/festival/lib/voices
-+PLUGIN_GAIM_PATH=${PREFIX}/lib/gaim
-+PKG_CONFIG_PATH=${LOCALBASE}/libdata/pkgconfig
-+PLUGIN_CFLAGS=`pkg-config gtk+-2.0 --cflags` `pkg-config glib-2.0 --cflags` -DPLUGIN_VERSION=\"$(PLUGIN_VERSION)\" -DFESTIVAL_VOICES_PATH=\"$(FESTIVAL_VOICES_PATH)\" -O3 -pipe
- PLUGIN_LIBS=`pkg-config gtk+-2.0 --libs` `pkg-config glib-2.0 --libs`
- LIBTOOL=libtool
--CC= gcc
-
diff --git a/audio/gaim-festival/files/patch-festival.c b/audio/gaim-festival/files/patch-festival.c
deleted file mode 100644
index 731ad7b5a02..00000000000
--- a/audio/gaim-festival/files/patch-festival.c
+++ /dev/null
@@ -1,53 +0,0 @@
---- festival.c.orig Thu Aug 18 20:02:32 2005
-+++ festival.c Thu Aug 18 20:11:48 2005
-@@ -435,10 +435,11 @@
- {
- char *stripped;
- const char *alias = get_best_name(account, who);
-- silent_joins = NULL;
-
- GString *buffer= g_string_new("");
- GString *ascii;
-+
-+ silent_joins = NULL;
- ascii = g_string_new(g_convert (what, strlen (what),
- "ISO-8859-1", "UTF-8",
- NULL, NULL, NULL));
-@@ -613,7 +614,12 @@
- plugin_load(GaimPlugin *plugin) {
-
- FILE *which_pf;
-- char line[1024];
-+ char line[1024], proc[1024];
-+ int errno=0;
-+ void *conv_handle;
-+ void *blist_handle;
-+ void *accounts_handle;
-+
- which_pf= popen("which festival 2>/dev/null","r");
- fscanf(which_pf,"%1023s",line);
- pclose(which_pf);
-@@ -621,10 +627,8 @@
- if( *line != '/')
- return FALSE;
-
-- char proc[1024];
- sprintf(proc, "%s %s", snd((char *)gaim_prefs_get_string("/gaim/gtk/sound/method")), line);
-
-- int errno=0;
- festival_pf= popen(proc,"w");
-
- if(errno) {
-@@ -634,9 +638,9 @@
-
- load_conf();
-
-- void *conv_handle = gaim_conversations_get_handle();
-- void *blist_handle = gaim_blist_get_handle();
-- void *accounts_handle = gaim_accounts_get_handle();
-+ conv_handle = gaim_conversations_get_handle();
-+ blist_handle = gaim_blist_get_handle();
-+ accounts_handle = gaim_accounts_get_handle();
-
- gaim_signal_connect(conv_handle, "received-im-msg",
- plugin, GAIM_CALLBACK(im_recv_im), NULL);
diff --git a/audio/gaim-festival/pkg-descr b/audio/gaim-festival/pkg-descr
deleted file mode 100644
index 24f9d05e790..00000000000
--- a/audio/gaim-festival/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-gaim-festival is a plugin for gaim to drive the festival speech synthesizer.
-
-WWW: http://festival-gaim.sourceforge.net/
-
-Bruce
-bms@FreeBSD.org