aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-29 22:57:53 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-29 22:57:53 +0800
commit1dad6f4c5708b87cdf0f13deac9b2a513c5c991e (patch)
treebe5bc9c9f8286c6c0f3a3d5c8801b17f0f4c72bd /audio
parentcb5581d80c4c46e74cf3523a1cab7b6e1f27a8cd (diff)
downloadfreebsd-ports-graphics-1dad6f4c5708b87cdf0f13deac9b2a513c5c991e.tar.gz
freebsd-ports-graphics-1dad6f4c5708b87cdf0f13deac9b2a513c5c991e.tar.zst
freebsd-ports-graphics-1dad6f4c5708b87cdf0f13deac9b2a513c5c991e.zip
- Use proper ${INSTALL_XXX} instead of ${INSTALL} for installing binaries and
scripts; - remove junk at the beginning of files/bktrctl.sh. PR: 37427 Submitted by: maintainer
Diffstat (limited to 'audio')
-rw-r--r--audio/fmio/Makefile17
-rw-r--r--audio/fmio/files/bktrctl.sh68
2 files changed, 9 insertions, 76 deletions
diff --git a/audio/fmio/Makefile b/audio/fmio/Makefile
index d21142372b6..5c1ba5a3010 100644
--- a/audio/fmio/Makefile
+++ b/audio/fmio/Makefile
@@ -16,28 +16,29 @@ MAN1= fmio.1
MANCOMPRESSED= no
pre-build:
-.if !defined(WITH_XTREME)
+.if !defined(WITH_BKTR)
@${ECHO_MSG}
@${ECHO_MSG} "If you want to compile with Highway Xtreme support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_XTREME=yes\""
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BKTR=yes\""
@${ECHO_MSG}
.endif
post-build:
-.if defined(WITH_XTREME)
+.if defined(WITH_BKTR)
@${MAKE} ${WRKSRC}/utils/bktrctl
.endif
do-install:
-.if defined(WITH_XTREME)
- ${INSTALL} ${WRKSRC}/utils/bktrctl ${PREFIX}/bin
- ${INSTALL} ${FILESDIR}/bktrctl.sh ${PREFIX}/etc/rc.d
+.if defined(WITH_BKTR)
+ ${INSTALL_PROGRAM} ${WRKSRC}/utils/bktrctl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${FILESDIR}/bktrctl.sh ${PREFIX}/etc/rc.d
.endif
- ${INSTALL} -m 4555 ${WRKSRC}/fmio ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/fmio ${PREFIX}/bin
+ ${CHMOD} 4555 ${PREFIX}/bin/fmio
${INSTALL_MAN} ${WRKSRC}/fmio.1 ${MANPREFIX}/man/man1
post-install:
-.if !defined(WITH_XTREME)
+.if !defined(WITH_BKTR)
${GREP} -v "bktrctl.sh" ${TMPPLIST} > ${TMPPLIST}.tmp
${MV} -f ${TMPPLIST}.tmp ${TMPPLIST}
.endif
diff --git a/audio/fmio/files/bktrctl.sh b/audio/fmio/files/bktrctl.sh
index 5325885f204..f8112afe8f8 100644
--- a/audio/fmio/files/bktrctl.sh
+++ b/audio/fmio/files/bktrctl.sh
@@ -1,71 +1,3 @@
-
-Apply the patch and add file given below
-
-diff -ur fmio.old/Makefile fmio/Makefile
---- fmio.old/Makefile Mon Mar 18 20:56:28 2002
-+++ fmio/Makefile Wed Apr 24 00:15:23 2002
-@@ -6,7 +6,7 @@
- #
-
- PORTNAME= fmio
--PORTVERSION= 1.2.18
-+PORTVERSION= 1.2.25
- CATEGORIES= audio
- MASTER_SITES= http://www.jumbo.narod.ru/src/fmio/
-
-@@ -16,10 +16,33 @@
- MANCOMPRESSED= no
-
- pre-build:
-- ${PERL} -pi.orig -e "s@lib fmio man@lib fmio@g; \
-- s@install -c -o root@#install@g" ${WRKSRC}/Makefile
-+.if !defined(WITH_XTREME)
-+ @${ECHO_MSG}
-+ @${ECHO_MSG} "If you want to compile with Highway Xtreme support,"
-+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_XTREME=yes\""
-+ @${ECHO_MSG}
-+.endif
-
--post-install:
-+post-build:
-+.if defined(WITH_XTREME)
-+ @${MAKE} ${WRKSRC}/utils/bktrctl
-+.endif
-+
-+do-install:
-+.if defined(WITH_XTREME)
-+ ${INSTALL} ${WRKSRC}/utils/bktrctl ${PREFIX}/bin
-+ ${INSTALL} files/bktrctl.sh ${PREFIX}/etc/rc.d
-+.endif
-+ ${INSTALL} -m 4555 ${WRKSRC}/fmio ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/fmio.1 ${MANPREFIX}/man/man1
-+
-+
-+
-+post-install:
-+.if !defined(WITH_XTREME)
-+ ${GREP} -v "bktrctl.sh" ${TMPPLIST} > ${TMPPLIST}.tmp
-+ ${MV} -f ${TMPPLIST}.tmp ${TMPPLIST}
-+.endif
-+
-
- .include <bsd.port.mk>
-diff -ur fmio.old/distinfo fmio/distinfo
---- fmio.old/distinfo Mon Mar 18 20:56:28 2002
-+++ fmio/distinfo Tue Apr 23 14:55:43 2002
-@@ -1 +1 @@
--MD5 (fmio-1.2.18.tar.gz) = 3260dfb3e9ae3a7baa9912bf26ec1d43
-+MD5 (fmio-1.2.25.tar.gz) = 4dacdd09098e83866b9309d4d9abf289
-diff -ur fmio.old/pkg-plist fmio/pkg-plist
---- fmio.old/pkg-plist Sat Apr 7 04:33:50 2001
-+++ fmio/pkg-plist Tue Apr 23 23:25:01 2002
-@@ -1 +1,2 @@
- bin/fmio
-+etc/rc.d/bktrctl.sh
-
-
--------------- files/bktrctl.sh ---------------------------
-
#!/bin/sh