aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrnoland <rnoland@FreeBSD.org>2009-08-17 10:59:20 +0800
committerrnoland <rnoland@FreeBSD.org>2009-08-17 10:59:20 +0800
commit2a3443917842ab0e4a909824f840d71165e5397d (patch)
tree927ea64c5d816e573b91d879f9c1f26f85e94e39 /audio
parent1120af216790bb53c866a623378948b75ebee5f5 (diff)
downloadfreebsd-ports-graphics-2a3443917842ab0e4a909824f840d71165e5397d.tar.gz
freebsd-ports-graphics-2a3443917842ab0e4a909824f840d71165e5397d.tar.zst
freebsd-ports-graphics-2a3443917842ab0e4a909824f840d71165e5397d.zip
The hal detection component rejects everything except pcm0. This is
not correct on FreeBSD. This patch allows pulse to identify all valid pcm devices in the gnome sound preferences. Approved by: marcus
Diffstat (limited to 'audio')
-rw-r--r--audio/pulseaudio/Makefile2
-rw-r--r--audio/pulseaudio/files/patch-src_modules_module-hal-detect.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index afe7f1849fa..aa0fa5bb991 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pulseaudio
PORTVERSION= 0.9.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
diff --git a/audio/pulseaudio/files/patch-src_modules_module-hal-detect.c b/audio/pulseaudio/files/patch-src_modules_module-hal-detect.c
new file mode 100644
index 00000000000..fd7f8bd45e5
--- /dev/null
+++ b/audio/pulseaudio/files/patch-src_modules_module-hal-detect.c
@@ -0,0 +1,11 @@
+--- src/modules/module-hal-detect.c.orig 2009-04-04 20:16:18.000000000 -0500
++++ src/modules/module-hal-detect.c 2009-08-16 16:09:49.000000000 -0500
+@@ -293,7 +293,7 @@
+
+ /* We only care for the main device */
+ device = libhal_device_get_property_int(context, udi, "oss.device", &error);
+- if (dbus_error_is_set(&error) || device != 0)
++ if (dbus_error_is_set(&error))
+ goto finish;
+
+ r = TRUE;