aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-03-10 03:41:12 +0800
committerlofi <lofi@FreeBSD.org>2004-03-10 03:41:12 +0800
commit344150edd9e7a3101f87e63d531bdae2b9dbb21f (patch)
treeaa2a54a33e5e6163905ac68a0a01153dd9038687 /audio
parent0bf4cb87335558d7d6c7a77212d01366ca69ca07 (diff)
downloadfreebsd-ports-graphics-344150edd9e7a3101f87e63d531bdae2b9dbb21f.tar.gz
freebsd-ports-graphics-344150edd9e7a3101f87e63d531bdae2b9dbb21f.tar.zst
freebsd-ports-graphics-344150edd9e7a3101f87e63d531bdae2b9dbb21f.zip
Update to KDE 3.2.1 / QT 3.3.1
Important changes: ================== KDE: - Audio/arts does not install artswrapper anymore, instead it is provided by audio/artswrapper. See UPDATING. - misc/kdeaddons3 is now a metaport with editors/kate-plugins editors/vimpart games/atlantikdesigner misc/kaddressbook-plugins misc/kfile-plugins misc/kicker-applets misc/knewsticker-scripts misc/konq-plugins misc/ksig misc/renamedlgplugins multimedia/noatun-plugins net/kontact-plugins as slave ports. - A number of KDE ports now uses OPTIONS do make various WITH_* options more visible. - Plist fixes - devel/kdevelop should be able to detect FreeBSD's autoconf/automake now for newly created projects. - kdebase will no longer remove previous KDM configurations. This won't take effect during the update from 3.2.0 to 3.2.1 (as deinstalling 3.2.0 will still remove the configuration), but subsequent updates will merge old configs. QT: - Previous versions of QT could be compiled with debugging-support enabled by defining DEBUG. This switch has been renamed to the more unambiguous WANT_QT_DEBUG (similar to WANT_KDE_DEBUG in the KDE ports).
Diffstat (limited to 'audio')
-rw-r--r--audio/arts/Makefile6
-rw-r--r--audio/arts/distinfo4
-rw-r--r--audio/arts/files/patch-soundserver-Makefile.in58
-rw-r--r--audio/arts/pkg-plist6
-rw-r--r--audio/artswrapper/Makefile2
5 files changed, 68 insertions, 8 deletions
diff --git a/audio/arts/Makefile b/audio/arts/Makefile
index db60a99784c..b6e4ae79a13 100644
--- a/audio/arts/Makefile
+++ b/audio/arts/Makefile
@@ -7,12 +7,11 @@
#
PORTNAME= arts
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.2.1
PORTEPOCH= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/3.2/src
+MASTER_SITE_SUBDIR= stable/${KDE_VERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
@@ -36,4 +35,5 @@ CFLAGS+= -DHAVE_VASPRINTF
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+
.include <bsd.port.mk>
diff --git a/audio/arts/distinfo b/audio/arts/distinfo
index ef3b26853b4..07fba721c9a 100644
--- a/audio/arts/distinfo
+++ b/audio/arts/distinfo
@@ -1,2 +1,2 @@
-MD5 (KDE/arts-1.2.0.tar.bz2) = f17708ad3c91b0a2f0c83674f78c3e53
-SIZE (KDE/arts-1.2.0.tar.bz2) = 993338
+MD5 (KDE/arts-1.2.1.tar.bz2) = 84877632917893438c629803e7b004f3
+SIZE (KDE/arts-1.2.1.tar.bz2) = 1039479
diff --git a/audio/arts/files/patch-soundserver-Makefile.in b/audio/arts/files/patch-soundserver-Makefile.in
new file mode 100644
index 00000000000..bdeb225da37
--- /dev/null
+++ b/audio/arts/files/patch-soundserver-Makefile.in
@@ -0,0 +1,58 @@
+--- soundserver/Makefile.in.orig Sun Feb 29 22:25:27 2004
++++ soundserver/Makefile.in Thu Mar 4 16:07:59 2004
+@@ -344,7 +344,7 @@
+
+
+ ###### "real" programs
+-bin_PROGRAMS = artsd artsplay artscat artswrapper artsshell artsrec
++bin_PROGRAMS = artsd artsplay artscat artsshell artsrec
+
+ artsd_LDADD = libsoundserver_idl.la $(FLOWLIBS) \
+ $(top_builddir)/mcop_mt/libmcop_mt.la $(USE_THREADS)
+@@ -364,10 +364,6 @@
+ artsplay_SOURCES = artsplay.cc
+ artsplay_COMPILE_FIRST = soundserver.h artsversion.h
+
+-artswrapper_SOURCES = artswrapper.c
+-artswrapper_INCLUDES = -I$(top_builddir) -DEXECUTE=\"$(artsdpath)\"
+-artswrapper_LDADD = $(LIBPOSIX4)
+-
+ artsshell_LDADD = libsoundserver_idl.la $(USE_THREADS)
+ artsshell_SOURCES = artsshell.cc tradercheck.cc
+ artsshell_COMPILE_FIRST = soundserver.h artsversion.h
+@@ -431,7 +427,7 @@
+ #>+ 1
+ libsoundserver_idl_la_OBJECTS = soundserver.lo
+ bin_PROGRAMS = artsd$(EXEEXT) artsplay$(EXEEXT) artscat$(EXEEXT) \
+- artswrapper$(EXEEXT) artsshell$(EXEEXT) artsrec$(EXEEXT)
++ artsshell$(EXEEXT) artsrec$(EXEEXT)
+ PROGRAMS = $(bin_PROGRAMS)
+
+ am_artscat_OBJECTS = artscat.$(OBJEXT)
+@@ -568,14 +564,14 @@
+ $(libartswavplayobject_la_SOURCES) $(libkmedia2_la_SOURCES) \
+ $(libkmedia2_idl_la_SOURCES) $(libsoundserver_idl_la_SOURCES) \
+ $(artscat_SOURCES) $(artsd_SOURCES) $(artsplay_SOURCES) \
+- $(artsrec_SOURCES) $(artsshell_SOURCES) $(artswrapper_SOURCES)
++ $(artsrec_SOURCES) $(artsshell_SOURCES)
+ DATA = $(mcopclass_DATA) $(mcoptype_DATA)
+
+ HEADERS = $(artsinclude_HEADERS)
+
+ DIST_COMMON = $(artsinclude_HEADERS) Makefile.am Makefile.in \
+ artsversion-new.h.in
+-SOURCES = $(libartsgslplayobject_la_SOURCES) $(libartswavplayobject_la_SOURCES) $(libkmedia2_la_SOURCES) $(libkmedia2_idl_la_SOURCES) $(libsoundserver_idl_la_SOURCES) $(artscat_SOURCES) $(artsd_SOURCES) $(artsplay_SOURCES) $(artsrec_SOURCES) $(artsshell_SOURCES) $(artswrapper_SOURCES)
++SOURCES = $(libartsgslplayobject_la_SOURCES) $(libartswavplayobject_la_SOURCES) $(libkmedia2_la_SOURCES) $(libkmedia2_idl_la_SOURCES) $(libsoundserver_idl_la_SOURCES) $(artscat_SOURCES) $(artsd_SOURCES) $(artsplay_SOURCES) $(artsrec_SOURCES) $(artsshell_SOURCES)
+
+ #>- all: all-am
+ #>+ 1
+@@ -691,9 +687,6 @@
+ artsshell$(EXEEXT): $(artsshell_OBJECTS) $(artsshell_DEPENDENCIES)
+ @rm -f artsshell$(EXEEXT)
+ $(CXXLINK) $(artsshell_LDFLAGS) $(artsshell_OBJECTS) $(artsshell_LDADD) $(LIBS)
+-artswrapper$(EXEEXT): $(artswrapper_OBJECTS) $(artswrapper_DEPENDENCIES)
+- @rm -f artswrapper$(EXEEXT)
+- $(LINK) $(artswrapper_LDFLAGS) $(artswrapper_OBJECTS) $(artswrapper_LDADD) $(LIBS)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT) core *.core
diff --git a/audio/arts/pkg-plist b/audio/arts/pkg-plist
index 9ffb598cb1e..664258fa256 100644
--- a/audio/arts/pkg-plist
+++ b/audio/arts/pkg-plist
@@ -5,7 +5,6 @@ bin/artsdsp
bin/artsplay
bin/artsrec
bin/artsshell
-bin/artswrapper
bin/mcopidl
include/arts/anyref.h
include/arts/artsflow.h
@@ -158,3 +157,8 @@ lib/mcop/soundserver.mcopclass
lib/mcop/soundserver.mcoptype
lib/mcop/x11globalcomm.mcopclass
lib/mcop/x11globalcomm.mcoptype
+@dirrm lib/mcop/Arts
+@dirrm lib/mcop
+@dirrm include/artsc
+@dirrm include/arts/gsl
+@dirrm include/arts
diff --git a/audio/artswrapper/Makefile b/audio/artswrapper/Makefile
index 86eb284cb9e..50070768247 100644
--- a/audio/artswrapper/Makefile
+++ b/audio/artswrapper/Makefile
@@ -14,8 +14,6 @@ EXTRACT_SUFX= # none
MAINTAINER= kde@freebsd.org
COMMENT= Setuid wrapper for arts
-IGNORE= This port is part of KDE 3.2.1 and is not yet ready
-
NO_WRKSUBDIR= yes
PLIST_FILES= bin/artswrapper