aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /audio
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-graphics-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-graphics-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-graphics-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/ario/Makefile2
-rw-r--r--audio/clementine-player/Makefile3
-rw-r--r--audio/cueplayer/Makefile3
-rw-r--r--audio/gmpc-libnotify/Makefile3
-rw-r--r--audio/gmpc-libnotify/files/patch-src_plugin.c20
-rw-r--r--audio/gmpc-wikipedia/Makefile3
-rw-r--r--audio/goobox/Makefile4
-rw-r--r--audio/goobox/files/patch-src_main.c11
-rw-r--r--audio/padevchooser/Makefile4
-rw-r--r--audio/padevchooser/files/patch-src_padevchooser.c11
-rw-r--r--audio/rhythmbox/Makefile10
-rw-r--r--audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c11
-rw-r--r--audio/vagalume/Makefile3
14 files changed, 76 insertions, 13 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1f31894159f..e8c5732b174 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -360,6 +360,7 @@
SUBDIR += libbpm
SUBDIR += libbs2b
SUBDIR += libcanberra
+ SUBDIR += libcanberra-gtk3
SUBDIR += libcdaudio
SUBDIR += libcddb
SUBDIR += libcddb-doc
diff --git a/audio/ario/Makefile b/audio/ario/Makefile
index 484a290d635..26f717e5b42 100644
--- a/audio/ario/Makefile
+++ b/audio/ario/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ario
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/ario-player/ario-player/${PORTVERSION}
@@ -17,6 +18,7 @@ LICENSE= GPLv2
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
gcrypt:${PORTSDIR}/security/libgcrypt \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
curl:${PORTSDIR}/ftp/curl \
notify:${PORTSDIR}/devel/libnotify \
soup:${PORTSDIR}/devel/libsoup22 \
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index d05c8cc606d..db64fa53575 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clementine
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -player
@@ -16,7 +17,7 @@ COMMENT= A cross-platform music player based on Amarok 1.4
LIB_DEPENDS= lastfm.0:${PORTSDIR}/audio/liblastfm \
tag.1:${PORTSDIR}/audio/taglib \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
xine.1:${PORTSDIR}/multimedia/libxine \
mtp:${PORTSDIR}/audio/libmtp
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
diff --git a/audio/cueplayer/Makefile b/audio/cueplayer/Makefile
index 722d70d6765..5f3bdb8be83 100644
--- a/audio/cueplayer/Makefile
+++ b/audio/cueplayer/Makefile
@@ -7,13 +7,14 @@
PORTNAME= cueplayer
PORTVERSION= 0.28
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
MAINTAINER= g.veniamin@googlemail.com
COMMENT= CUE player
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
USE_QT_VER= 4
QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build network
diff --git a/audio/gmpc-libnotify/Makefile b/audio/gmpc-libnotify/Makefile
index 76f9ef312cf..3cf49e201c8 100644
--- a/audio/gmpc-libnotify/Makefile
+++ b/audio/gmpc-libnotify/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmpc-libnotify
PORTVERSION= 0.20.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.sarine.nl/Programs/gmpc/${PORTVERSION}/ \
http://freebsd.unixfreunde.de/sources/
@@ -15,7 +16,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= A libnotify for gmpc
LIB_DEPENDS= mpd.3:${PORTSDIR}/audio/libmpd \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
RUN_DEPENDS= gmpc:${PORTSDIR}/audio/gmpc
diff --git a/audio/gmpc-libnotify/files/patch-src_plugin.c b/audio/gmpc-libnotify/files/patch-src_plugin.c
new file mode 100644
index 00000000000..3e4a485aad5
--- /dev/null
+++ b/audio/gmpc-libnotify/files/patch-src_plugin.c
@@ -0,0 +1,20 @@
+--- src/plugin.c.orig 2011-08-15 20:17:11.000000000 +0200
++++ src/plugin.c 2011-08-15 20:18:35.000000000 +0200
+@@ -149,16 +149,13 @@ static void libnotify_song_changed(MpdOb
+ if(not == NULL)
+ {
+ // notify_notification_close(not, NULL);
+- not = notify_notification_new(summary, buffer,NULL, NULL);
++ not = notify_notification_new(summary, buffer,NULL);
+ }
+ else{
+ notify_notification_update(not, summary, buffer, NULL);
+ }
+ notify_notification_set_urgency(not, NOTIFY_URGENCY_LOW);
+
+- if(cfg_get_single_value_as_int_with_default(config, "libnotify-plugin", "attach-to-tray", TRUE))
+- notify_notification_attach_to_status_icon(not, tray_icon2_gsi);
+-
+ g_free(summary);
+ /* Add the song to the widget */
+ g_object_set_data_full(G_OBJECT(not), "mpd-song", mpd_songDup(song), (GDestroyNotify)mpd_freeSong);
diff --git a/audio/gmpc-wikipedia/Makefile b/audio/gmpc-wikipedia/Makefile
index 8e57c2dc555..fe631dfbbd4 100644
--- a/audio/gmpc-wikipedia/Makefile
+++ b/audio/gmpc-wikipedia/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmpc-wikipedia
PORTVERSION= 0.20.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.sarine.nl/Programs/gmpc/${PORTVERSION}/ \
http://freebsd.unixfreunde.de/sources/
@@ -16,7 +17,7 @@ COMMENT= Wikipedia info for gmpc
LIB_DEPENDS= mpd.3:${PORTSDIR}/audio/libmpd \
soup-2.4.1:${PORTSDIR}/devel/libsoup \
- webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+ webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
RUN_DEPENDS= gmpc:${PORTSDIR}/audio/gmpc
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index d64af3c1fe6..aa429d30c49 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= goobox
PORTVERSION= 1.9.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -38,7 +38,7 @@ OPTIONS= NOTIFY "Enable libnotify support" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+= --enable-notification
.else
CONFIGURE_ARGS+= --disable-notification
diff --git a/audio/goobox/files/patch-src_main.c b/audio/goobox/files/patch-src_main.c
new file mode 100644
index 00000000000..aabcd8b783c
--- /dev/null
+++ b/audio/goobox/files/patch-src_main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2011-08-15 20:09:01.000000000 +0200
++++ src/main.c 2011-08-15 20:09:22.000000000 +0200
+@@ -698,7 +698,7 @@ system_notify (GooWindow *window,
+ }
+
+ if (notification == NULL) {
+- notification = notify_notification_new (title, msg, "goobox", NULL);
++ notification = notify_notification_new (title, msg, "goobox");
+ notify_notification_set_urgency (notification, NOTIFY_URGENCY_LOW);
+ notify_notification_add_action (notification,
+ GTK_STOCK_MEDIA_NEXT,
diff --git a/audio/padevchooser/Makefile b/audio/padevchooser/Makefile
index 1cd295f67b9..1781c1eca8e 100644
--- a/audio/padevchooser/Makefile
+++ b/audio/padevchooser/Makefile
@@ -7,7 +7,7 @@
PORTNAME= padevchooser
PORTVERSION= 0.9.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
@@ -16,7 +16,7 @@ COMMENT= GTK icon tray for PulseAudio
LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
pulse.0:${PORTSDIR}/audio/pulseaudio \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
avahi-core:${PORTSDIR}/net/avahi
RUN_DEPENDES= dbus-daemon:${PORTSDIR}/devel/dbus
diff --git a/audio/padevchooser/files/patch-src_padevchooser.c b/audio/padevchooser/files/patch-src_padevchooser.c
new file mode 100644
index 00000000000..c2f3046e8f6
--- /dev/null
+++ b/audio/padevchooser/files/patch-src_padevchooser.c
@@ -0,0 +1,11 @@
+--- src/padevchooser.c.orig 2011-08-11 21:41:17.000000000 +0200
++++ src/padevchooser.c 2011-08-11 21:41:42.000000000 +0200
+@@ -162,7 +162,7 @@ static void notify_event(const char *tit
+
+ if (!notification) {
+ s = g_strdup_printf("<i>%s</i>\n%s", title, text);
+- notification = notify_notification_new(title, s, "audio-card", GTK_WIDGET(tray_icon));
++ notification = notify_notification_new(title, s, "audio-card");
+ notify_notification_set_category(notification, "device.added");
+ notify_notification_set_urgency(notification, NOTIFY_URGENCY_LOW);
+ g_signal_connect_swapped(G_OBJECT(notification), "closed", G_CALLBACK(notification_closed), NULL);
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 72b23765e85..500823bc373 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/rhythmbox/Makefile,v 1.111 2010/09/28 15:55:46 kwm Exp $
+# $MCom: ports/audio/rhythmbox/Makefile,v 1.115 2011/05/04 18:44:36 kwm Exp $
#
PORTNAME= rhythmbox
PORTVERSION= 0.12.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -27,6 +27,8 @@ LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
gnome-media-profiles.0:${PORTSDIR}/audio/gnome-media \
brasero-media.3:${PORTSDIR}/sysutils/brasero
+CONFLICTS= rhythmbox-2.[0-9]* rhythmbox-3.[0-9]*
+
USE_BZIP2= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
@@ -89,7 +91,7 @@ PLIST_SUB+= MTP="@comment "
.if defined(WITH_DAAP)
CONFIGURE_ARGS+= --enable-daap --with-mdns=avahi
LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app \
- gnome-keyring:${PORTSDIR}/security/gnome-keyring
+ gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
PLIST_SUB+= DAAP=""
.else
.if exists(${LOCALBASE}/lib/libavahi-client.a)
@@ -100,7 +102,7 @@ PLIST_SUB+= DAAP="@comment "
.endif
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
.else
CONFIGURE_ARGS+= --disable-libnotify
diff --git a/audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c b/audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c
new file mode 100644
index 00000000000..923a00e9461
--- /dev/null
+++ b/audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c
@@ -0,0 +1,11 @@
+--- plugins/status-icon/rb-status-icon-plugin.c.orig 2011-08-21 21:46:27.000000000 +0200
++++ plugins/status-icon/rb-status-icon-plugin.c 2011-08-21 21:46:43.000000000 +0200
+@@ -394,7 +394,7 @@ do_notify (RBStatusIconPlugin *plugin,
+ icon_name = NULL;
+
+ if (plugin->priv->notification == NULL) {
+- plugin->priv->notification = notify_notification_new (primary, secondary, icon_name, NULL);
++ plugin->priv->notification = notify_notification_new (primary, secondary, icon_name);
+
+ g_signal_connect_object (plugin->priv->notification,
+ "closed",
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
index 4e2d0541bd0..bb856dd9bf0 100644
--- a/audio/vagalume/Makefile
+++ b/audio/vagalume/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vagalume
PORTVERSION= 0.8.5
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://vagalume.igalia.com/files/source/ \
${MASTER_SITE_DEBIAN_POOL}
@@ -53,7 +54,7 @@ PLIST_SUB+= DBUS="@comment "
.if !defined(WITHOUT_TRAY)
CONFIGURE_ARGS+=--enable-tray-icon
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libnotify.pc:${PORTSDIR}/devel/libnotify
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+=--disable-tray-icon
.endif