aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-02-27 00:43:00 +0800
committerdanfe <danfe@FreeBSD.org>2013-02-27 00:43:00 +0800
commit4a66f0143f498b57a69bcf0fd35ed4b231faa448 (patch)
tree7b327edf8d3952daa63319d66a81b1e27d064904 /audio
parent9734940c6c5d478d53f9a31f1dbb5e6137edf0b5 (diff)
downloadfreebsd-ports-graphics-4a66f0143f498b57a69bcf0fd35ed4b231faa448.tar.gz
freebsd-ports-graphics-4a66f0143f498b57a69bcf0fd35ed4b231faa448.tar.zst
freebsd-ports-graphics-4a66f0143f498b57a69bcf0fd35ed4b231faa448.zip
- Trim the Makefile header
- Define LICENSE (GPLv2) - Unmute installation commands - Reword COMMENT, sort knobs, etc. - Reformat port description
Diffstat (limited to 'audio')
-rw-r--r--audio/trommler/Makefile39
-rw-r--r--audio/trommler/pkg-descr15
2 files changed, 23 insertions, 31 deletions
diff --git a/audio/trommler/Makefile b/audio/trommler/Makefile
index 8807ab46315..cfe88ffa85f 100644
--- a/audio/trommler/Makefile
+++ b/audio/trommler/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: trommler
-# Date created: 17 Apr 2003
-# Whom: David Yeske <dyeske@gmail.com>
-#
+# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= trommler
PORTVERSION= 3.8
@@ -13,33 +9,30 @@ MASTER_SITES= http://muth.org/Robert/Trommler/
DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK based drum machine
+COMMENT= GTK+2 based drum machine
-WRKSRC= ${WRKDIR}/Trommler
+LICENSE= GPLv2
-USE_GNOME= gtk20
USE_GMAKE= yes
+USE_GNOME= gtk20
+
+WRKSRC= ${WRKDIR}/Trommler
post-patch:
-#the third Makefile edit replaces the contents
-#of a comment so CC can be respected
- @${REINPLACE_CMD} -e \
- 's|-O9|${CFLAGS}|; \
- s|-Werror||; \
- s|^# Makefile|CC=${CC}|' \
- ${WRKSRC}/Makefile
-
- @${REINPLACE_CMD} -e \
- 's|"/Drums"|"${PREFIX}/share/trommler/Drums"|' \
+# The third edit replaces the contents of a comment, so CC can be respected
+ @${REINPLACE_CMD} -e 's|-O9|${CFLAGS}| ; s|-Werror|| ; \
+ s|^# Makefile|CC=${CC}|' ${WRKSRC}/Makefile
+
+ @${REINPLACE_CMD} -e 's|"/Drums"|"${PREFIX}/share/trommler/Drums"|' \
${WRKSRC}/gui.c
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/playsample ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/trommler ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/wav2smp ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/playsample ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/trommler ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wav2smp ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/trommler/Drums
@${MKDIR} ${PREFIX}/share/trommler/Songs
- @${INSTALL_DATA} ${WRKSRC}/Drums/*.smp ${PREFIX}/share/trommler/Drums
- @${INSTALL_DATA} ${WRKSRC}/Songs/*.sng ${PREFIX}/share/trommler/Songs
+ ${INSTALL_DATA} ${WRKSRC}/Drums/*.smp ${PREFIX}/share/trommler/Drums
+ ${INSTALL_DATA} ${WRKSRC}/Songs/*.sng ${PREFIX}/share/trommler/Songs
.include <bsd.port.mk>
diff --git a/audio/trommler/pkg-descr b/audio/trommler/pkg-descr
index afe335bba68..b48675123f2 100644
--- a/audio/trommler/pkg-descr
+++ b/audio/trommler/pkg-descr
@@ -1,11 +1,10 @@
-Trommler is a GTK based drum machine with the following
-features:
+Trommler is a GTK+2 based drum machine with the following features:
-- Use of 16 bit 44100kHz mono drum samples
-- Realtime audio output using the /dev/dsp device
-- Audio output to file
-- Variable number of beats per patter
-- Volume adjustment of drum samples
-- Stereo panning of (mono) drum samples
+ - Use of 16 bit 44100 kHz mono drum samples
+ - Real-time (stereo) audio output using the OSS API
+ - Alternatively, audio output to file
+ - Complex rhythms (variable number of beats per pattern)
+ - Volume adjustment of drum samples
+ - Stereo panning of (mono) drum samples
WWW: http://muth.org/Robert/Trommler/