aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-04-24 05:19:54 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-04-24 05:19:54 +0800
commit5bc9df87ec81682d71fb22ef9ad86ce035c5f974 (patch)
tree6ec878dae1956549e105c20ab0c6fddf5fe5d8ab /audio
parentf75cda335fdb77662f250771e1e6cb16a9d6f3b0 (diff)
downloadfreebsd-ports-graphics-5bc9df87ec81682d71fb22ef9ad86ce035c5f974.tar.gz
freebsd-ports-graphics-5bc9df87ec81682d71fb22ef9ad86ce035c5f974.tar.zst
freebsd-ports-graphics-5bc9df87ec81682d71fb22ef9ad86ce035c5f974.zip
audio/py-soundcloud: Python SoundCloud API library
- Add Python SoundCloud ABI Library 0.5.0 - Include README.rst - Add test target Reviewed by: feld (mentor) Approved by: feld (mentor) Differential Revision: D5967
Diffstat (limited to 'audio')
-rw-r--r--audio/py-soundcloud/Makefile31
-rw-r--r--audio/py-soundcloud/distinfo2
-rw-r--r--audio/py-soundcloud/pkg-descr3
3 files changed, 36 insertions, 0 deletions
diff --git a/audio/py-soundcloud/Makefile b/audio/py-soundcloud/Makefile
new file mode 100644
index 00000000000..78b1a9bb516
--- /dev/null
+++ b/audio/py-soundcloud/Makefile
@@ -0,0 +1,31 @@
+# Created by: Bernard Spil <brnrd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= soundcloud
+PORTVERSION= 0.5.0
+CATEGORIES= audio devel www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= Bernard Spil <brnrd@FreeBSD.org>
+COMMENT= A friendly wrapper library for the Soundcloud API
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.1.2:devel/py-nose
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+PORTDOCS= README.rst
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
+
+do-test:
+ cd ${WRKSRC} ; nosetests --with-doctest
+
+.include <bsd.port.mk>
diff --git a/audio/py-soundcloud/distinfo b/audio/py-soundcloud/distinfo
new file mode 100644
index 00000000000..e9933850023
--- /dev/null
+++ b/audio/py-soundcloud/distinfo
@@ -0,0 +1,2 @@
+SHA256 (soundcloud-0.5.0.tar.gz) = aad2003592cec945f835f158f7b41ba8bf805c5738a2fcc5629668ea1df653d5
+SIZE (soundcloud-0.5.0.tar.gz) = 10861
diff --git a/audio/py-soundcloud/pkg-descr b/audio/py-soundcloud/pkg-descr
new file mode 100644
index 00000000000..2821ba559dd
--- /dev/null
+++ b/audio/py-soundcloud/pkg-descr
@@ -0,0 +1,3 @@
+py-soundcloud is a friendly wrapper around the `Soundcloud API`
+
+WWW: https://github.com/soundcloud/soundcloud-python