aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-06-27 07:31:04 +0800
committergahr <gahr@FreeBSD.org>2008-06-27 07:31:04 +0800
commit65ffcae50c6c3cd5786cc3246d75dea34560e4dd (patch)
tree6e3dbd3b0c3252dc7321e0e327d4202dec2d424e /audio
parenta346b32723e976665054cc48b7969849797db9c7 (diff)
downloadfreebsd-ports-graphics-65ffcae50c6c3cd5786cc3246d75dea34560e4dd.tar.gz
freebsd-ports-graphics-65ffcae50c6c3cd5786cc3246d75dea34560e4dd.tar.zst
freebsd-ports-graphics-65ffcae50c6c3cd5786cc3246d75dea34560e4dd.zip
- Fix segmentation fault when ejecting a CD
- Fix typo in my e-mail address - Bump portrevision
Diffstat (limited to 'audio')
-rw-r--r--audio/tcd/Makefile1
-rw-r--r--audio/tcd/files/patch-tcd.c11
-rw-r--r--audio/tcd/files/patch-tcd_mb.c2
-rw-r--r--audio/tcd/files/patch-tcd_mb.h2
4 files changed, 11 insertions, 5 deletions
diff --git a/audio/tcd/Makefile b/audio/tcd/Makefile
index c89d48409da..47fd1c2eb60 100644
--- a/audio/tcd/Makefile
+++ b/audio/tcd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tcd
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/tcd/files/patch-tcd.c b/audio/tcd/files/patch-tcd.c
index dc61a4e5750..0a2a2af9277 100644
--- a/audio/tcd/files/patch-tcd.c
+++ b/audio/tcd/files/patch-tcd.c
@@ -1,6 +1,11 @@
---- src/tcd.c.orig 2008-06-26 19:40:23.000000000 +0200
-+++ src/tcd.c 2008-06-26 19:40:47.000000000 +0200
-@@ -221,7 +221,7 @@
+--- src/tcd.c.orig 2004-06-15 22:32:31.000000000 +0200
++++ src/tcd.c 2008-06-27 01:25:01.000000000 +0200
+@@ -217,11 +217,11 @@
+ static void detect_disc_change(void)
+ {
+ unsigned long discid = cddb_discid(state.cdrom);
+- if (discid != state.current_discid) {
++ if (CD_INDRIVE(state.cdrom->status) && discid != state.current_discid) {
if (state.cd_info.modified) {
tcd_writediskinfo(&state.cd_info, state.cdrom);
}
diff --git a/audio/tcd/files/patch-tcd_mb.c b/audio/tcd/files/patch-tcd_mb.c
index abdf65532c1..cd42d1c0572 100644
--- a/audio/tcd/files/patch-tcd_mb.c
+++ b/audio/tcd/files/patch-tcd_mb.c
@@ -2,7 +2,7 @@
+++ src/tcd_mb.c 2008-06-26 21:43:09.000000000 +0200
@@ -0,0 +1,98 @@
+/*-
-+ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.ch>
++ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.org>
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
diff --git a/audio/tcd/files/patch-tcd_mb.h b/audio/tcd/files/patch-tcd_mb.h
index 1e9aa881929..aaa59bd4f44 100644
--- a/audio/tcd/files/patch-tcd_mb.h
+++ b/audio/tcd/files/patch-tcd_mb.h
@@ -2,7 +2,7 @@
+++ src/tcd_mb.h 2008-06-26 19:37:19.000000000 +0200
@@ -0,0 +1,44 @@
+/*-
-+ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.ch>
++ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.org>
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions