aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-03-20 19:59:20 +0800
committernovel <novel@FreeBSD.org>2005-03-20 19:59:20 +0800
commit68b0a05cbe5bff570ec082b7b64ef0a009e654f5 (patch)
tree735796cdfb000e8c976554ce0b5039f33e7cad23 /audio
parenta48f100af55abedf086a6659b20854bbb59c505e (diff)
downloadfreebsd-ports-graphics-68b0a05cbe5bff570ec082b7b64ef0a009e654f5.tar.gz
freebsd-ports-graphics-68b0a05cbe5bff570ec082b7b64ef0a009e654f5.tar.zst
freebsd-ports-graphics-68b0a05cbe5bff570ec082b7b64ef0a009e654f5.zip
Avoid using pkg-plist, docs patch.
PR: 78865 Submitted by: Mark Daniel Reidel (maintainer) Approved by: krion (mentor) (implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/ncmpc/Makefile14
-rw-r--r--audio/ncmpc/files/patch-doc-ncmpc.1.diff25
-rw-r--r--audio/ncmpc/pkg-plist10
3 files changed, 36 insertions, 13 deletions
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index a6b488f5ec0..86c13f730b2 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -26,13 +26,21 @@ OPTIONS= NLS "Native language support" on \
.include <bsd.port.pre.mk>
USE_ICONV= yes
+PLIST_FILES= bin/ncmpc \
+ %%EXAMPLESDIR%%/config \
+ %%EXAMPLESDIR%%/keys \
+ =%%EXAMPLESDIR%%/ncmpc.lirc
+PLIST_DIRS=%%EXAMPLESDIR%%
.ifdef(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+LANGUAGES=de sv es ru fr
+.for language in ${LANGUAGES}
+PLIST_FILES+=share/locale/${language}/LC_MESSAGES/ncmpc.mo
+.endfor
+
.endif
.if !defined(WITHOUT_CLOCK_SCREEN)
@@ -49,7 +57,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/ncmpc.lirc ${EXAMPLESDIR}/
${INSTALL_MAN} ${WRKSRC}/doc/ncmpc.1 ${MAN1PREFIX}/man/man1/
.if !defined(WITHOUT_NLS)
-.for language in de sv es ru fr
+.for language in ${LANGUAGES}
${MKDIR} ${LOCALBASE}/share/locale/${language}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/po/${language}.gmo ${PREFIX}/share/locale/${language}/LC_MESSAGES/ncmpc.mo
.endfor
diff --git a/audio/ncmpc/files/patch-doc-ncmpc.1.diff b/audio/ncmpc/files/patch-doc-ncmpc.1.diff
new file mode 100644
index 00000000000..8e60f86fa71
--- /dev/null
+++ b/audio/ncmpc/files/patch-doc-ncmpc.1.diff
@@ -0,0 +1,25 @@
+--- doc/ncmpc.1 Mon Mar 7 03:02:10 2005
++++ doc/ncmpc.1 Mon Mar 7 03:26:54 2005
+@@ -54,6 +54,12 @@
+ .B \-P, \-\-key\-file=FILE
+ Read key bindings from FILE.
+ .TP
++.B \-m, \-\-mouse
++Enable ncurses mouse events.
++.TP
++.B \-M, \-\-no\-mouse
++Disable ncurses mouse events.
++.TP
+ Mandatory or optional arguments to long options are also mandatory or optional for any corresponding short options.
+ .SH "CONFIGURATION"
+ When ncmpc start it tries to read user setting from the ~/ncmpc/config file. If no user configuration is found ncmpc tries to load global settings from $SYSCONFDIR/ncmpc/config (the actual path is displayed on the help screen). An example configuration file (config.sample) should be provided with ncmpc.
+@@ -72,6 +78,9 @@
+ .B wide\-cursor = yes|no
+ Make the cursor as wide as the screen.
+ .TP
++.B enable\-mouse = yes|no
++Ncurses mouse events.
++.TP
+ .B wrap\-around = yes|no
+ Wrapped cursor movement.
+ .TP
diff --git a/audio/ncmpc/pkg-plist b/audio/ncmpc/pkg-plist
deleted file mode 100644
index 768eebd361f..00000000000
--- a/audio/ncmpc/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-bin/ncmpc
-%%EXAMPLESDIR%%/config
-%%EXAMPLESDIR%%/keys
-%%EXAMPLESDIR%%/ncmpc.lirc
-%%NLS%%share/locale/de/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/es/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/ncmpc.mo
-@dirrm %%EXAMPLESDIR%%