aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2013-12-08 06:08:49 +0800
committerfeld <feld@FreeBSD.org>2013-12-08 06:08:49 +0800
commit785706ddb1d0c0c3a0d43d4a49fce9bbd7e7054a (patch)
tree501bbfb407fc34c9a08cd559951f6503c37d5ef0 /audio
parent2f2372805cfe1e3f223e5906fff6fae4ad26d048 (diff)
downloadfreebsd-ports-graphics-785706ddb1d0c0c3a0d43d4a49fce9bbd7e7054a.tar.gz
freebsd-ports-graphics-785706ddb1d0c0c3a0d43d4a49fce9bbd7e7054a.tar.zst
freebsd-ports-graphics-785706ddb1d0c0c3a0d43d4a49fce9bbd7e7054a.zip
Add support for the LastGenre plugin
Approved by: swills (mentor, implicit)
Diffstat (limited to 'audio')
-rw-r--r--audio/beets/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/beets/Makefile b/audio/beets/Makefile
index 37645702ffc..eb636216269 100644
--- a/audio/beets/Makefile
+++ b/audio/beets/Makefile
@@ -23,12 +23,13 @@ NO_STAGE= yes
USE_PYTHON= 2.7+
USE_PYDISTUTILS= easy_install
-OPTIONS_DEFINE= BEATPORT CHROMA DISCOGS FFMPEG REPLAYGAIN WEB
+OPTIONS_DEFINE= BEATPORT CHROMA DISCOGS LASTFM FFMPEG REPLAYGAIN WEB
OPTIONS_DEFAULT=
CHROMA_DESC= Audio Fingerprinting Plugin
BEATPORT_DESC= Beatport Catalog Autotagging Support
DISCOGS_DESC= Discogs Search Plugin
+LASTFM_DESC= LastGenre Plugin
REPLAYGAIN_DESC= Normalize Audio Loudness
WEB_DESC= Webserver Music Player Plugin
@@ -36,6 +37,7 @@ CHROMA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyacoustid>=0:${PORTSDIR}/audio/py-py
BEATPORT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:${PORTSDIR}/www/py-requests
DISCOGS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}discogs-client>=0:${PORTSDIR}/audio/py-discogs-client
FFMPEG_RUN_DEPENDS= ffmpeg>=2:${PORTSDIR}/multimedia/ffmpeg
+LASTFM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pylast>=0:${PORTSDIR}/audio/py-pylast
REPLAYGAIN_RUN_DEPENDS= mp3gain>=0:${PORTSDIR}/audio/mp3gain
REPLAYGAIN_RUN_DEPENDS+= aacgain>=0:${PORTSDIR}/audio/aacgain
WEB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0:${PORTSDIR}/www/py-flask