aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-04-13 16:51:31 +0800
committerlofi <lofi@FreeBSD.org>2006-04-13 16:51:31 +0800
commit7eb94b1566d028c9c2714ac8d076fc0e512eb32b (patch)
treed7c57d60c950e1b5b0ed605e56048a88bedd861b /audio
parentd0689562ed26c877dd30f12decd82bc8f2bc8d70 (diff)
downloadfreebsd-ports-graphics-7eb94b1566d028c9c2714ac8d076fc0e512eb32b.tar.gz
freebsd-ports-graphics-7eb94b1566d028c9c2714ac8d076fc0e512eb32b.tar.zst
freebsd-ports-graphics-7eb94b1566d028c9c2714ac8d076fc0e512eb32b.zip
Juk's configure check for tunepimp 0.4 is broken - and I would've never noticed
if it weren't for gcc 2.95, since gcc 3.4 simply irons over the member function parameter mismatches. Way to facilitate creating hard to spot runtime-bugs. With this fix, juk actually uses the updated tunepimp API.
Diffstat (limited to 'audio')
-rw-r--r--audio/juk/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
index 9256f1fcd4f..31416d3d375 100644
--- a/audio/juk/Makefile
+++ b/audio/juk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= juk
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -60,6 +60,10 @@ pre-everything::
@${ECHO_MSG}
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|LIBS="-ltunepimp $$LIBS"|LIBS="-ltunepimp -liconv $$LIBS"|g' \
+ ${WRKSRC}/configure
+
do-build:
cd ${WRKSRC}/arts/runtime && ${SETENV} ${MAKE_ENV} ${GMAKE}
cd ${WRKSRC}/juk && ${SETENV} ${MAKE_ENV} ${GMAKE}