aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-04 15:37:48 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-04 15:37:48 +0800
commit8f9aa7ae80f016f893ba9868ed17b90705ec5483 (patch)
treeb7bba3b47001de11d7cec5922dfe4f8355a21020 /audio
parent6794cfec9877066c60d46487445c5d7ba104a016 (diff)
downloadfreebsd-ports-graphics-8f9aa7ae80f016f893ba9868ed17b90705ec5483.tar.gz
freebsd-ports-graphics-8f9aa7ae80f016f893ba9868ed17b90705ec5483.tar.zst
freebsd-ports-graphics-8f9aa7ae80f016f893ba9868ed17b90705ec5483.zip
audio/libgroove: unbreak build with ffmpeg 3.x
groove/encoder.c:84:19: error: 'avcodec_encode_audio2' is deprecated [-Werror,-Wdeprecated-declarations] int errcode = avcodec_encode_audio2(e->stream->codec, &e->pkt, frame, &got_packet); ^ /usr/local/include/libavcodec/avcodec.h:5283:5: note: 'avcodec_encode_audio2' has been explicitly marked deprecated here int avcodec_encode_audio2(AVCodecContext *avctx, AVPacket *avpkt, ^ groove/encoder.c:84:52: error: 'codec' is deprecated [-Werror,-Wdeprecated-declarations] int errcode = avcodec_encode_audio2(e->stream->codec, &e->pkt, frame, &got_packet); ^ /usr/local/include/libavformat/avformat.h:893:21: note: 'codec' has been explicitly marked deprecated here AVCodecContext *codec; ^ groove/encoder.c:94:5: error: 'av_free_packet' is deprecated [-Werror,-Wdeprecated-declarations] av_free_packet(&e->pkt); ^ /usr/local/include/libavcodec/avcodec.h:4472:6: note: 'av_free_packet' has been explicitly marked deprecated here void av_free_packet(AVPacket *pkt); ^ groove/encoder.c:101:34: error: 'codec' is deprecated [-Werror,-Wdeprecated-declarations] avcodec_close(e->stream->codec); ^ /usr/local/include/libavformat/avformat.h:893:21: note: 'codec' has been explicitly marked deprecated here AVCodecContext *codec; ^ groove/encoder.c:134:44: error: 'codec' is deprecated [-Werror,-Wdeprecated-declarations] AVCodecContext *codec_ctx = e->stream->codec; ^ /usr/local/include/libavformat/avformat.h:893:21: note: 'codec' has been explicitly marked deprecated here AVCodecContext *codec; ^ groove/encoder.c:148:16: error: 'codec' is deprecated [-Werror,-Wdeprecated-declarations] e->stream->codec = codec_ctx; ^ /usr/local/include/libavformat/avformat.h:893:21: note: 'codec' has been explicitly marked deprecated here AVCodecContext *codec; ^ groove/encoder.c:620:24: error: 'codec' is deprecated [-Werror,-Wdeprecated-declarations] 0 : e->stream->codec->frame_size; ^ /usr/local/include/libavformat/avformat.h:893:21: note: 'codec' has been explicitly marked deprecated here AVCodecContext *codec; ^ 7 errors generated. PR: 207547
Diffstat (limited to 'audio')
-rw-r--r--audio/libgroove/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/audio/libgroove/Makefile b/audio/libgroove/Makefile
index 96e921efd15..62e852ff571 100644
--- a/audio/libgroove/Makefile
+++ b/audio/libgroove/Makefile
@@ -23,6 +23,7 @@ GH_ACCOUNT= andrewrk
USES= cmake:outsource
USE_SDL= sdl2
USE_LDCONFIG= yes
+CFLAGS+= -Wno-error=deprecated-declarations # ffmpeg 3.1
PLIST_SUB+= VER1=${PORTVERSION:R:R} \
VER3=${PORTVERSION}