aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-23 02:39:37 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-23 02:39:37 +0800
commit94e0bc185dfb47bbc6d496c50dae795bffaa5cd7 (patch)
tree519335fbf67a85f923b2a9013f48df9430170ea0 /audio
parent86f54d661cf88abdc9c2b759b74b9560114c776c (diff)
downloadfreebsd-ports-graphics-94e0bc185dfb47bbc6d496c50dae795bffaa5cd7.tar.gz
freebsd-ports-graphics-94e0bc185dfb47bbc6d496c50dae795bffaa5cd7.tar.zst
freebsd-ports-graphics-94e0bc185dfb47bbc6d496c50dae795bffaa5cd7.zip
Fix build with clang 3.3
Diffstat (limited to 'audio')
-rw-r--r--audio/penguinsap/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index 60e9d5a49d3..0af3e41a782 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -24,9 +24,13 @@ PLIST_FILES= bin/sap
.include <bsd.port.pre.mk>
+_CLANG!= clang --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+
.if ${CXX:T} != "clang++"
+.if ${_CLANG} < 33
CXXFLAGS+= --no-exceptions
.endif
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|linux/soundcard\.h|sys/soundcard\.h|' \