aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-05 06:42:59 +0800
committermiwi <miwi@FreeBSD.org>2009-05-05 06:42:59 +0800
commita79674a10d14f1fc5d2085231b80265e150bdefa (patch)
treee96452df49b1a501397baa197bfbea5a2855a5f0 /audio
parent9faac97a82e6505121e334647a3227ac84d6e987 (diff)
downloadfreebsd-ports-graphics-a79674a10d14f1fc5d2085231b80265e150bdefa.tar.gz
freebsd-ports-graphics-a79674a10d14f1fc5d2085231b80265e150bdefa.tar.zst
freebsd-ports-graphics-a79674a10d14f1fc5d2085231b80265e150bdefa.zip
2009-04-28 audio/festival+OGI: unmaintained, does not work with current versions of GCC, needs gcc295 which has been failing to build for months
2009-04-17 net-mgmt/nrpe: Obsolete version, consider migration to net-mgmt/nrpe2
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/festival+OGI/Makefile108
-rw-r--r--audio/festival+OGI/distinfo12
-rw-r--r--audio/festival+OGI/files/FreeBSD.mak15
-rw-r--r--audio/festival+OGI/files/festival.sh5
-rw-r--r--audio/festival+OGI/files/festival_client.sh4
-rw-r--r--audio/festival+OGI/files/patch-ab26
-rw-r--r--audio/festival+OGI/files/patch-ac25
-rw-r--r--audio/festival+OGI/files/patch-ad35
-rw-r--r--audio/festival+OGI/files/patch-ae13
-rw-r--r--audio/festival+OGI/files/patch-af16
-rw-r--r--audio/festival+OGI/files/patch-ag13
-rw-r--r--audio/festival+OGI/files/patch-ah13
-rw-r--r--audio/festival+OGI/files/patch-ai18
-rw-r--r--audio/festival+OGI/files/patch-al17
-rw-r--r--audio/festival+OGI/files/patch-am13
-rw-r--r--audio/festival+OGI/files/patch-an13
-rw-r--r--audio/festival+OGI/files/patch-ao13
-rw-r--r--audio/festival+OGI/files/patch-ap12
-rw-r--r--audio/festival+OGI/files/patch-aq10
-rw-r--r--audio/festival+OGI/files/patch-festival_config_config20
-rw-r--r--audio/festival+OGI/files/patch-speech_tools__config__rules__install.mak11
-rw-r--r--audio/festival+OGI/files/patch-speech_tools_voxware.cc13
-rw-r--r--audio/festival+OGI/files/sitevars.scm2
-rw-r--r--audio/festival+OGI/files/top-Makefile3
-rw-r--r--audio/festival+OGI/pkg-descr23
-rw-r--r--audio/festival+OGI/pkg-message6
-rw-r--r--audio/festival+OGI/pkg-plist131
28 files changed, 0 insertions, 591 deletions
diff --git a/audio/Makefile b/audio/Makefile
index b816eb8b473..1c0a0f79a02 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -157,7 +157,6 @@
SUBDIR += festalon
SUBDIR += festdoc
SUBDIR += festival
- SUBDIR += festival+OGI
SUBDIR += festlex-cmu
SUBDIR += festlex-czech
SUBDIR += festlex-ifd
diff --git a/audio/festival+OGI/Makefile b/audio/festival+OGI/Makefile
deleted file mode 100644
index daebf644917..00000000000
--- a/audio/festival+OGI/Makefile
+++ /dev/null
@@ -1,108 +0,0 @@
-# New ports collection makefile for: festival+OGI
-# Date created: 2003-11-05
-# Whom: trevor
-# based on pkgsrc/audio/festival from NetBSD
-#
-# $NetBSD: Makefile,v 1.27 2003/10/06 21:40:17 jmc Exp $
-# $FreeBSD$
-#
-
-PORTNAME= festival+OGI
-PORTVERSION= 1.4.1
-PORTREVISION= 2
-CATEGORIES= audio accessibility
-MASTER_SITES= ${MASTER_SITE_NETBSD}
-DISTFILES= festival-${PORTVERSION}.tar.gz \
- speech_tools-1.2.1.tar.gz \
- OGIresLPC-2.0.9.tar.gz
-
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= OGIfestpatch-1.4.1.2.tar.gz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Text-to-speech system with OGI residual LPC synthesizer
-
-LIB_DEPENDS= audio.2:${PORTSDIR}/audio/nas \
- esd.2:${PORTSDIR}/audio/esound
-
-CONFLICTS= festival-*
-DIST_SUBDIR= festival
-
-RESTRICTED= no-commercial-use
-
-DEPRECATED= unmaintained, does not work with current versions of GCC, needs gcc295 which has been failing to build for months
-EXPIRATION_DATE=2009-04-28
-
-FESTIVAL= ${WRKSRC}/festival
-FESTIVAL_ARCH= ${ARCH:S/i386/ix86/}
-FHOME= ${PREFIX}/share/festival
-MAKE_ENV+= PKG_EST_HOME=${SPEECHTOOLS} \
- EST_HOME=${SPEECHTOOLS} \
- PKG_FESTIVAL_BUILD_HOME=${FESTIVAL} \
- PKG_FESTIVAL_HOME=${FHOME} \
- PKG_COMPILER="${CC}" \
- PKG_LOCALBASE=${LOCALBASE} \
- PKG_PREFIX=${PREFIX} \
- GCC27_CC="${CC}" \
- GCC27_CXX="${CXX}"
-MAN1= festival.1 festival_client.1
-USE_GCC= 2.95
-USE_GMAKE= yes
-SPEECHTOOLS= ${WRKSRC}/speech_tools
-WRKSRC= ${WRKDIR}
-
-post-extract:
- @${TAR} -C ${WRKSRC} -xzf \
- ${DISTDIR}/${DIST_SUBDIR}/OGIfestpatch-1.4.1.2.tar.gz
-
-pre-patch:
- ${CP} ${FESTIVAL}/config/config-dist ${FESTIVAL}/config/config
- ${CP} ${SPEECHTOOLS}/config/config-dist ${SPEECHTOOLS}/config/config
- ${CHMOD} u+w ${FESTIVAL}/config/config ${SPEECHTOOLS}/config/config
-
-post-patch:
-.for ii in compilers/gcc27.mak config config-dist
- @${MV} ${SPEECHTOOLS}/config/${ii} ${SPEECHTOOLS}/config/${ii}.orig
- @${SED} -e "s:= gcc:= gcc295:g" < ${SPEECHTOOLS}/config/${ii}.orig \
- > ${SPEECHTOOLS}/config/${ii}
-.endfor
- @${CP} ${FILESDIR}/top-Makefile ${WRKSRC}/Makefile
- @${CP} ${FILESDIR}/FreeBSD.mak ${SPEECHTOOLS}/config/systems/FreeBSD.mak
-.for i in 4 5
- @${LN} -fs ${SPEECHTOOLS}/config/systems/ix86_FreeBSD3.3.mak \
- ${SPEECHTOOLS}/config/systems/${FESTIVAL_ARCH}_FreeBSD3.${i}.mak
-.endfor
-.for ii in 4 5 6 7 8
-.for jj in 0 1 2 3 4 5 6 7 8 9 10 11
- @${LN} -fs ${SPEECHTOOLS}/config/systems/ix86_FreeBSD3.3.mak \
- ${SPEECHTOOLS}/config/systems/${FESTIVAL_ARCH}_FreeBSD${ii}.${jj}.mak
-.endfor
-.endfor
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
- ${WRKSRC}/speech_tools/config/systems/default.mak
-
-do-install:
- ${MKDIR} ${FHOME}/lib/voices/english/ ${FHOME}/lib/voices/italian/ \
- ${FHOME}/lib/voices/spanish/ ${FHOME}/lib/dicts
- ${CHMOD} -R u+w,a+r,og-w ${FESTIVAL}/lib
- ${FIND} ${FESTIVAL}/lib -type d -print0 | ${XARGS} -0 ${CHMOD} 755
- cd ${FESTIVAL} && ${CP} -pPR lib examples ${FHOME}
- ${RM} -rf ${FHOME}/lib/etc/*FreeBSD*
- ${INSTALL_PROGRAM} ${FESTIVAL}/lib/etc/*FreeBSD*/audsp ${PREFIX}/libexec
-.for ii in festival festival_client
- ${INSTALL_PROGRAM} ${FESTIVAL}/src/main/${ii} \
- ${PREFIX}/libexec/${ii}.naked
-.endfor
-.for ii in festival.sh festival_client.sh sitevars.scm
- ${SED} "s%@PKG_FESTIVAL_LOCATION@%${FHOME}%; \
- s%@PKG_PREFIX@%${PREFIX}%" <${FILESDIR}/${ii} > ${WRKDIR}/${ii}
-.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/festival.sh ${PREFIX}/bin/festival
- ${INSTALL_SCRIPT} ${WRKDIR}/festival_client.sh \
- ${PREFIX}/bin/festival_client
- ${INSTALL_DATA} ${WRKDIR}/sitevars.scm ${FHOME}/lib/sitevars.scm
-.for ii in ${MAN1}
- ${INSTALL_MAN} ${FESTIVAL}/doc/${ii} ${PREFIX}/man/man1/
-.endfor
-
-.include <bsd.port.mk>
diff --git a/audio/festival+OGI/distinfo b/audio/festival+OGI/distinfo
deleted file mode 100644
index 3600aaa11af..00000000000
--- a/audio/festival+OGI/distinfo
+++ /dev/null
@@ -1,12 +0,0 @@
-MD5 (festival/festival-1.4.1.tar.gz) = 1cf585adfd5f8f14a3eed71200c5cbde
-SIZE (festival/festival-1.4.1.tar.gz) = 543335
-SHA256 (festival/festival-1.4.1.tar.gz) = edbc60c559c0d45fc41dc141e02d6c1344dad536189fdfce144dac819721d5ac
-MD5 (festival/speech_tools-1.2.1.tar.gz) = 4b77d63f202a410868cc79b5e0640b9b
-SIZE (festival/speech_tools-1.2.1.tar.gz) = 1206616
-SHA256 (festival/speech_tools-1.2.1.tar.gz) = 0a90b4512acb9097aa008adfe7dde015b31376cd0625786e8f9bf60e96c664e1
-MD5 (festival/OGIresLPC-2.0.9.tar.gz) = abd5246049210028a24a5c1a349d21c7
-SIZE (festival/OGIresLPC-2.0.9.tar.gz) = 140306
-SHA256 (festival/OGIresLPC-2.0.9.tar.gz) = 11145af96395c9be29aad9b44eb10d1a80c276d6194403dbc4c0dabf20842c33
-MD5 (festival/OGIfestpatch-1.4.1.2.tar.gz) = aae864d857fd6a1a7eec06fcc963268d
-SIZE (festival/OGIfestpatch-1.4.1.2.tar.gz) = 32904
-SHA256 (festival/OGIfestpatch-1.4.1.2.tar.gz) = 0773f1d997be202c8e9a0e537da382438ebd16cb7d97921d3208edfaa0836534
diff --git a/audio/festival+OGI/files/FreeBSD.mak b/audio/festival+OGI/files/FreeBSD.mak
deleted file mode 100644
index 9def3f8a14e..00000000000
--- a/audio/festival+OGI/files/FreeBSD.mak
+++ /dev/null
@@ -1,15 +0,0 @@
-include $(EST)/config/systems/default.mak
-
-## echo -n doesn't work (well only sometimes ?)
-ECHO_N = /usr/bin/printf "%s"
-
-NAWK=awk
-
-NAS_LIB=$(PKG_LOCALBASE)/lib
-NAS_INCLUDE=$(PKG_LOCALBASE)/include
-
-X11_LIB=$(PKG_LOCALBASE)/lib
-X11_INCLUDE=$(PKG_LOCALBASE)/include
-
-OS_INCLUDES+=-I$(PKG_PREFIX)/include
-OS_LIBS+=-L$(PKG_PREFIX)/lib
diff --git a/audio/festival+OGI/files/festival.sh b/audio/festival+OGI/files/festival.sh
deleted file mode 100644
index 6d606b8a44e..00000000000
--- a/audio/festival+OGI/files/festival.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-# path for audsp
-PATH=@PKG_PREFIX@/libexec:$PATH
-export PATH
-exec festival.naked --libdir @PKG_FESTIVAL_LOCATION@/lib $*
diff --git a/audio/festival+OGI/files/festival_client.sh b/audio/festival+OGI/files/festival_client.sh
deleted file mode 100644
index fc4ba4c944b..00000000000
--- a/audio/festival+OGI/files/festival_client.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-PATH=@PKG_PREFIX@/libexec:$PATH
-export PATH
-exec festival_client.naked @PKG_FESTIVAL_LOCATION@/lib $*
diff --git a/audio/festival+OGI/files/patch-ab b/audio/festival+OGI/files/patch-ab
deleted file mode 100644
index 4e4141c556e..00000000000
--- a/audio/festival+OGI/files/patch-ab
+++ /dev/null
@@ -1,26 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-ab,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- festival/doc/Makefile Thu Jun 17 20:29:54 1999
-+++ festival/doc/Makefile Mon Oct 11 06:06:35 1999
-@@ -44,7 +44,7 @@
-
- EXAMPLE_TO_DOCUMENT=
-
--FESTIVAL=$(TOP)/bin/festival --libdir $(TOP)/lib
-+FESTIVAL=$(TOP)/src/main/festival --libdir $(TOP)/lib
-
- # Include some of EST documentation.
- DOCXX_EXTRA_FILES =
-@@ -72,9 +72,9 @@
- %.1 : %.head %.options %.tail
- cat $^ >$@
- %.options : $(TOP)/src/main/%
-- $(TOP)/bin/$* -man_options >$@
-+ $(FESTIVAL)$* -man_options >$@
- %.options : $(TOP)/src/main/%.exe
-- $(TOP)/bin/$* -man_options >$@
-+ $(FESTIVAL)$* -man_options >$@
-
- festival.info: festival.texi festfunc.texi festvars.texi festfeat.texi
- @ if [ ! -d info ] ; \
diff --git a/audio/festival+OGI/files/patch-ac b/audio/festival+OGI/files/patch-ac
deleted file mode 100644
index 8c3edc79ffc..00000000000
--- a/audio/festival+OGI/files/patch-ac
+++ /dev/null
@@ -1,25 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-ac,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- festival/examples/benchmark Thu Feb 27 00:47:45 1997
-+++ festival/examples/benchmark Mon Oct 11 05:41:14 1999
-@@ -1,6 +1,6 @@
- #!/bin/sh
-
--default_libdir="/projects/festival/lib"
-+default_libdir="$FESTIVAL_HOME/lib"
-
- while true
- do
-@@ -15,9 +15,9 @@
- esac
- done
-
--text=${1-"$HOME/projects/festival/examples/benchmark.text"}
-+text=${1-"$FESTIVAL_HOME/examples/benchmark.text"}
-
--for i in . src/main ../src/main $HOME/projects/festival/src/main /cstr/bin
-+for i in . src/main ../src/main $FESTIVAL_HOME/src/main
- do
- if [ -n "$festival" ]
- then
diff --git a/audio/festival+OGI/files/patch-ad b/audio/festival+OGI/files/patch-ad
deleted file mode 100644
index bb3dd80ec65..00000000000
--- a/audio/festival+OGI/files/patch-ad
+++ /dev/null
@@ -1,35 +0,0 @@
-$FreeBSD$
-
---- speech_tools/config/config.orig Thu Nov 18 19:10:29 1999
-+++ speech_tools/config/config Fri Jun 16 17:03:16 2000
-@@ -15,7 +15,7 @@
- ## You may need to set this explicitly if automounter or NFS
- ## side effects cause problems
-
--EST_HOME := $(shell (cd $(EST); pwd))
-+EST_HOME := $(PKG_EST_HOME)
-
- ###########################################################################
- ## System type.
-@@ -77,10 +77,10 @@
- ## specify a program to play files in a desired format.
-
- ## NCD's network audio system, This is recommended.
--# INCLUDE_MODULES += NAS_AUDIO
-+INCLUDE_MODULES += NAS_AUDIO
-
- ## Elightenment Sound Demon, for KDE etc.
--# INCLUDE_MODULES += ESD_AUDIO
-+INCLUDE_MODULES += ESD_AUDIO
-
- ## Native audio for your platform (sun, linux, freebsd, irix, windows)
- INCLUDE_MODULES += NATIVE_AUDIO
-@@ -95,7 +95,7 @@
- INCLUDE_MODULES += EDITLINE
-
- # speech recognition
--#INCLUDE_MODULES += ASR
-+INCLUDE_MODULES += ASR
-
-
- ## Scheme
diff --git a/audio/festival+OGI/files/patch-ae b/audio/festival+OGI/files/patch-ae
deleted file mode 100644
index 8f02e28804b..00000000000
--- a/audio/festival+OGI/files/patch-ae
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-ae,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- speech_tools/include/EST_unix.h Sun May 30 20:53:04 1999
-+++ speech_tools/include/EST_unix.h Mon Oct 11 05:40:15 1999
-@@ -53,6 +53,7 @@
- # include <sys/wait.h>
- # include <sys/resource.h>
- # include <dirent.h>
-+# define unix 1
- #elif defined(SYSTEM_IS_WIN32)
- # include <io.h>
- # include "win32/EST_unix_win32.h"
diff --git a/audio/festival+OGI/files/patch-af b/audio/festival+OGI/files/patch-af
deleted file mode 100644
index 0e62c621341..00000000000
--- a/audio/festival+OGI/files/patch-af
+++ /dev/null
@@ -1,16 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-af,v 1.1 1999/10/11 14:13:49 proff Exp $
-
---- festival/config/project.mak-dist Mon Oct 11 21:41:08 1999
-+++ festival/config/project.mak Mon Oct 11 22:27:37 1999
-@@ -70,8 +70,8 @@
-
- # Place where programs are compiled
-
--PROJECT_MAIN_DIR=$(FESTIVAL_HOME)/src/main
--PROJECT_SCRIPTS_DIR=$(FESTIVAL_HOME)/src/scripts
-+PROJECT_MAIN_DIR=$(PKG_FESTIVAL_BUILD_HOME)/src/main
-+PROJECT_SCRIPTS_DIR=$(PKG_FESTIVAL_BUILD_HOME)/src/scripts
-
- # Where the main RCS tree is, probably only used within CSTR
-
diff --git a/audio/festival+OGI/files/patch-ag b/audio/festival+OGI/files/patch-ag
deleted file mode 100644
index 944135e39da..00000000000
--- a/audio/festival+OGI/files/patch-ag
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-ag,v 1.1 2000/05/05 20:54:57 hubertf Exp $
-
---- speech_tools/config/modules/nas_audio.mak.orig Fri May 5 20:55:15 2000
-+++ speech_tools/config/modules/nas_audio.mak Fri May 5 20:58:07 2000
-@@ -45,6 +45,6 @@
- AUDIO_DEFINES += -DSUPPORT_NAS
- AUDIO_INCLUDES += -I$(NAS_INCLUDE)
- MODULE_LIBS += -L$(NAS_LIB) -laudio
--MODULE_EXTRA_LIBS += -L$(X11_LIB) -lX11 -lXt
-+MODULE_EXTRA_LIBS += -L$(X11_LIB) -Wl,-R $(X11_LIB) -lX11 -lXt
-
-
diff --git a/audio/festival+OGI/files/patch-ah b/audio/festival+OGI/files/patch-ah
deleted file mode 100644
index 07085075631..00000000000
--- a/audio/festival+OGI/files/patch-ah
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-ah,v 1.1 2000/05/05 20:54:57 hubertf Exp $
-
---- festival/config/modules/nas_audio.mak.orig Fri May 5 21:07:15 2000
-+++ festival/config/modules/nas_audio.mak Fri May 5 21:07:29 2000
-@@ -44,6 +44,6 @@
-
- AUDIO_DEFINES += -DSUPPORT_NAS
- AUDIO_INCLUDES += -I$(NAS_INCLUDE)
--MODULE_LIBS += -L$(NAS_LIB) -laudio -L$(X11_LIB) -lX11 -lXt
-+MODULE_LIBS += -L$(NAS_LIB) -laudio -L$(X11_LIB) -Wl,-R$(X11_LIB) -lX11 -lXt
-
-
diff --git a/audio/festival+OGI/files/patch-ai b/audio/festival+OGI/files/patch-ai
deleted file mode 100644
index feb28d51713..00000000000
--- a/audio/festival+OGI/files/patch-ai
+++ /dev/null
@@ -1,18 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-ai,v 1.2 2000/05/31 14:51:16 dmcmahill Exp $
-
-work around pmax compiler bug
-
---- speech_tools/grammar/ngram/Makefile.orig Sun May 30 06:59:41 1999
-+++ speech_tools/grammar/ngram/Makefile Tue May 30 12:41:32 2000
-@@ -49,3 +49,10 @@
- include $(TOP)/config/common_make_rules
-
-+ifeq ($(MACHINETYPE),pmax)
-+
-+ngrammar_io.o: ngrammar_io.cc
-+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../../include ${OS_INCLUDES} ngrammar_io.cc
-+
-+endif
-+
-
diff --git a/audio/festival+OGI/files/patch-al b/audio/festival+OGI/files/patch-al
deleted file mode 100644
index f6d3730d093..00000000000
--- a/audio/festival+OGI/files/patch-al
+++ /dev/null
@@ -1,17 +0,0 @@
-$FreeBSD$
-$NetBSD: patch-al,v 1.1 2000/05/31 14:51:17 dmcmahill Exp $
-
-work around pmax compiler bug
-
---- festival/src/modules/Duration/Makefile.orig Sun May 30 08:07:31 1999
-+++ festival/src/modules/Duration/Makefile Wed May 31 09:22:01 2000
-@@ -51,3 +51,9 @@
- include $(TOP)/config/common_make_rules
-
-+ifeq ($(MACHINETYPE),pmax)
-+
-+duration.o:duration.cc
-+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../include -I../../../src/include -I../../../../speech_tools/include ${OS_INCLUDES} duration.cc
-+
-+endif
-
diff --git a/audio/festival+OGI/files/patch-am b/audio/festival+OGI/files/patch-am
deleted file mode 100644
index 3cd79202f9d..00000000000
--- a/audio/festival+OGI/files/patch-am
+++ /dev/null
@@ -1,13 +0,0 @@
-passing `int *' as argument 3 of `accept(int, sockaddr *, socklen_t *)' changes signedness
-
---- speech_tools/utils/EST_Server.cc.orig Thu Nov 18 23:14:51 1999
-+++ speech_tools/utils/EST_Server.cc Sun Jun 11 17:27:17 2000
-@@ -647,7 +647,7 @@
-
- while (connected() &&
- (csocket = accept(p_socket, (struct sockaddr *) &sin,
-- SOCKLEN_CAST &sin_size))>=0)
-+ (socklen_t *) &sin_size))>=0)
- {
- if (p_trace)
- *p_trace << "connection " << csocket << "\n";
diff --git a/audio/festival+OGI/files/patch-an b/audio/festival+OGI/files/patch-an
deleted file mode 100644
index 405e46cffbf..00000000000
--- a/audio/festival+OGI/files/patch-an
+++ /dev/null
@@ -1,13 +0,0 @@
-passing `int *' as argument 3 of `getsockname(int, sockaddr *, socklen_t *)' changes signedness
-
---- speech_tools/utils/EST_ServiceTable.cc.orig Thu Nov 18 23:15:21 1999
-+++ speech_tools/utils/EST_ServiceTable.cc Sun Jun 11 17:28:29 2000
-@@ -296,7 +296,7 @@
-
- // This only gets the port number
-
-- if (getsockname(socket, (struct sockaddr *)&sin, SOCKLEN_CAST &size) != 0)
-+ if (getsockname(socket, (struct sockaddr *)&sin, (socklen_t *) &size) != 0)
- EST_sys_error("Can't find my address");
-
-
diff --git a/audio/festival+OGI/files/patch-ao b/audio/festival+OGI/files/patch-ao
deleted file mode 100644
index 73b77083ebf..00000000000
--- a/audio/festival+OGI/files/patch-ao
+++ /dev/null
@@ -1,13 +0,0 @@
-passing `int *' as argument 3 of `getpeername(int, sockaddr *, socklen_t *)' changes signedness
-
---- ./festival/src/arch/festival/server.cc.orig Thu Nov 18 23:46:47 1999
-+++ ./festival/src/arch/festival/server.cc Sun Jun 11 17:48:45 2000
-@@ -206,7 +206,7 @@
- const char *client_hostnum;
- const char *reason = "";
-
-- getpeername(fd,(struct sockaddr *)&peer,SOCKLEN_CAST &addrlen);
-+ getpeername(fd,(struct sockaddr *)&peer, (socklen_t *) &addrlen);
- clienthost = gethostbyaddr((char *)&peer.sin_addr,
- sizeof(peer.sin_addr),AF_INET);
- client_hostnum = inet_ntoa(peer.sin_addr);
diff --git a/audio/festival+OGI/files/patch-ap b/audio/festival+OGI/files/patch-ap
deleted file mode 100644
index 0794c74870f..00000000000
--- a/audio/festival+OGI/files/patch-ap
+++ /dev/null
@@ -1,12 +0,0 @@
---- speech_tools/audio/nas.cc.orig Thu Oct 14 16:26:29 1999
-+++ speech_tools/audio/nas.cc Fri Jun 16 17:24:25 2000
-@@ -57,7 +57,8 @@
-
- int nas_supported = TRUE;
-
--int endian_int = 1;
-+extern int endian_int;
-+int endian_int = 1;
- #define NAS_BIG_ENDIAN (((char *)&endian_int)[0] == 0)
-
- static void na_sync_play_cb(AuServer *aud, AuEventHandlerRec *handler,
diff --git a/audio/festival+OGI/files/patch-aq b/audio/festival+OGI/files/patch-aq
deleted file mode 100644
index 012bfe0c981..00000000000
--- a/audio/festival+OGI/files/patch-aq
+++ /dev/null
@@ -1,10 +0,0 @@
---- speech_tools/audio/esd.cc.orig Mon Oct 4 15:39:01 1999
-+++ speech_tools/audio/esd.cc Fri Jun 16 17:49:10 2000
-@@ -66,7 +66,6 @@
-
- bool esd_supported = TRUE;
-
--int endian_int = 1;
- #define ESD_BIG_ENDIAN (((char *)&endian_int)[0] == 0)
-
- EST_String server;
diff --git a/audio/festival+OGI/files/patch-festival_config_config b/audio/festival+OGI/files/patch-festival_config_config
deleted file mode 100644
index f205088536a..00000000000
--- a/audio/festival+OGI/files/patch-festival_config_config
+++ /dev/null
@@ -1,20 +0,0 @@
-$FreeBSD$
-
---- festival/config/config Mon Oct 11 07:48:44 1999
-+++ festival/config/config Mon Oct 11 05:48:33 1999
-@@ -20,7 +20,7 @@
- ## You may need to set this explicitly if automounter or NFS
- ## side effects cause problems
-
--FESTIVAL_HOME := $(shell (cd $(TOP); pwd))
-+FESTIVAL_HOME := $(PKG_FESTIVAL_HOME)
-
- ###########################################################################
- ## Feature selection.
-@@ -70,3 +70,6 @@
- ## in config/configs/default.mak.
-
-
-+ALSO_INCLUDE += OGIcommon
-+ALSO_INCLUDE += OGIdbase
-+ALSO_INCLUDE += OGIresLPC
diff --git a/audio/festival+OGI/files/patch-speech_tools__config__rules__install.mak b/audio/festival+OGI/files/patch-speech_tools__config__rules__install.mak
deleted file mode 100644
index 00f52f05281..00000000000
--- a/audio/festival+OGI/files/patch-speech_tools__config__rules__install.mak
+++ /dev/null
@@ -1,11 +0,0 @@
---- speech_tools/config/rules/install.mak.orig Sun May 30 10:51:10 1999
-+++ speech_tools/config/rules/install.mak Sun Oct 29 20:50:07 2006
-@@ -39,8 +39,6 @@
-
-
-
--PROJECT_HOME_PATH := $(shell mkdir -p $($(PROJECT_PREFIX)_HOME); cd $($(PROJECT_PREFIX)_HOME); pwd)
--
- PROJECT_TOP_PATH := $(shell (cd $(TOP); pwd))
-
- S = _static
diff --git a/audio/festival+OGI/files/patch-speech_tools_voxware.cc b/audio/festival+OGI/files/patch-speech_tools_voxware.cc
deleted file mode 100644
index 6e9b564ed8a..00000000000
--- a/audio/festival+OGI/files/patch-speech_tools_voxware.cc
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- speech_tools/audio/voxware.cc.orig Tue Sep 28 16:38:22 1999
-+++ speech_tools/audio/voxware.cc Wed Oct 29 08:06:38 2003
-@@ -61,7 +61,7 @@
- #include "EST_error.h"
-
- #ifdef SUPPORT_FREEBSD16
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
- #include <fcntl.h>
- int freebsd16_supported = TRUE;
- int linux16_supported = FALSE;
diff --git a/audio/festival+OGI/files/sitevars.scm b/audio/festival+OGI/files/sitevars.scm
deleted file mode 100644
index e80dbfa1c73..00000000000
--- a/audio/festival+OGI/files/sitevars.scm
+++ /dev/null
@@ -1,2 +0,0 @@
-(set! system-voice-path '("@PKG_FESTIVAL_LOCATION@/lib/voices"))
-(set! sgml_parse_progname "nsgmls")
diff --git a/audio/festival+OGI/files/top-Makefile b/audio/festival+OGI/files/top-Makefile
deleted file mode 100644
index ee190c4fe49..00000000000
--- a/audio/festival+OGI/files/top-Makefile
+++ /dev/null
@@ -1,3 +0,0 @@
-all:
- cd speech_tools && $(MAKE)
- cd festival && $(MAKE)
diff --git a/audio/festival+OGI/pkg-descr b/audio/festival+OGI/pkg-descr
deleted file mode 100644
index 8b53b5920d1..00000000000
--- a/audio/festival+OGI/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-This is Festival 1.4.1 with OGIresLPC, the residual LPC synthesizer
-plugin from the Center for Spoken Language Understanding at the
-Oregon Health & Science University (formerly Oregon Graduate Institute
-of Science & Technology). The plugin "provides a new signal
-processing engine and new voices" (it is needed by the abc, aec,
-hvs, jph, mwm and tll voices) but is for non-commercial use only.
-
-from the Festival authors:
-
- The Festival Speech Synthesis System is a general multi-lingual
- text-to-speech system for Unix platforms. It is written
- in C++ and includes a Scheme-based scripting language.
- Included with Festival are lexicons and voices that together
- form a whole text-to-speech system.
-
-For output via esd do:
-
- (Parameter.set 'Audio_Method 'esdaudio)
-
-NAS and direct output are documented in section 23 of the manual.
-
-WWW: http://www.cslu.ogi.edu/tts/
- http://www.cstr.ed.ac.uk/projects/festival/
diff --git a/audio/festival+OGI/pkg-message b/audio/festival+OGI/pkg-message
deleted file mode 100644
index 8043e6681d2..00000000000
--- a/audio/festival+OGI/pkg-message
+++ /dev/null
@@ -1,6 +0,0 @@
-**************************************************************************
-* You need to install at least one festvox-* package before festival can *
-* do anything other than mumble silently to itself. See the festival *
-* package description, the festdoc package (share/doc/festival/*), *
-* or the festival home page for more information. *
-**************************************************************************
diff --git a/audio/festival+OGI/pkg-plist b/audio/festival+OGI/pkg-plist
deleted file mode 100644
index fd08d0aa08d..00000000000
--- a/audio/festival+OGI/pkg-plist
+++ /dev/null
@@ -1,131 +0,0 @@
-@comment $FreeBSD$
-@comment $NetBSD: PLIST,v 1.1 2001/11/01 00:15:49 zuntum Exp $
-share/festival/lib/ogi_effect.scm
-share/festival/lib/ogi_enhance.scm
-share/festival/lib/ogi_gswdurtreeZ_wb.scm
-share/festival/lib/ogi_hack.scm
-share/festival/lib/ogi_kddurtreeZ_wb.scm
-share/festival/lib/ogi_klatt_durs_wb.scm
-share/festival/lib/ogi_languages.scm
-share/festival/lib/ogi_lexicons.scm
-share/festival/lib/ogi_lts_worldbet.scm
-share/festival/lib/ogi_phrase.scm
-share/festival/lib/ogi_postlex.scm
-share/festival/lib/ogi_synthesis.scm
-share/festival/lib/ogi_token.scm
-share/festival/lib/ogi_unitsel.scm
-share/festival/lib/ogi_wordsynth.scm
-share/festival/lib/ogi_worldbet_phones.scm
-bin/festival
-bin/festival_client
-libexec/festival.naked
-libexec/festival_client.naked
-libexec/audsp
-share/festival/lib/Makefile
-share/festival/lib/VCLocalRules
-share/festival/lib/mrpa_phones.scm
-share/festival/lib/mrpa_allophones.scm
-share/festival/lib/radio_phones.scm
-share/festival/lib/holmes_phones.scm
-share/festival/lib/darpa_phones.scm
-share/festival/lib/phoneset.scm
-share/festival/lib/mrpa_durs.scm
-share/festival/lib/klatt_durs.scm
-share/festival/lib/gswdurtreeZ.scm
-share/festival/lib/f2bdurtreeZ.scm
-share/festival/lib/tobi.scm
-share/festival/lib/f2bf0lr.scm
-share/festival/lib/tobi_rules.scm
-share/festival/lib/tilt.scm
-share/festival/lib/sec.ts20.quad.ngrambin
-share/festival/lib/sec.B.hept.ngrambin
-share/festival/lib/init.scm
-share/festival/lib/synthesis.scm
-share/festival/lib/module_description.scm
-share/festival/lib/lexicons.scm
-share/festival/lib/festival.scm
-share/festival/lib/intonation.scm
-share/festival/lib/duration.scm
-share/festival/lib/pos.scm
-share/festival/lib/phrase.scm
-share/festival/lib/voices.scm
-share/festival/lib/tts.scm
-share/festival/lib/festdoc.scm
-share/festival/lib/languages.scm
-share/festival/lib/token.scm
-share/festival/lib/mbrola.scm
-share/festival/lib/display.scm
-share/festival/lib/postlex.scm
-share/festival/lib/tokenpos.scm
-share/festival/lib/festtest.scm
-share/festival/lib/cslush.scm
-share/festival/lib/cart_aux.scm
-share/festival/lib/pauses.scm
-share/festival/lib/scfg.scm
-share/festival/lib/mettree.scm
-share/festival/lib/java.scm
-share/festival/lib/lts.scm
-share/festival/lib/engmorph.scm
-share/festival/lib/engmorphsyn.scm
-share/festival/lib/lts_build.scm
-share/festival/lib/Sable.v0_2.dtd
-share/festival/lib/sable-latin.ent
-share/festival/lib/festival.el
-share/festival/lib/scfg_wsj_wp20.gram
-share/festival/lib/speech.properties
-share/festival/lib/email-mode.scm
-share/festival/lib/ogimarkup-mode.scm
-share/festival/lib/sable-mode.scm
-share/festival/lib/soleml-mode.scm
-share/festival/lib/etc/Makefile
-share/festival/lib/etc/email_filter
-@dirrm share/festival/lib/etc
-share/festival/lib/siod.scm
-share/festival/lib/web.scm
-share/festival/lib/cstr.scm
-share/festival/lib/fringe.scm
-share/festival/lib/sitevars.scm
-share/festival/examples/Makefile
-share/festival/examples/webdemo.scm
-share/festival/examples/ex1.email
-share/festival/examples/ex1.ogi
-share/festival/examples/example.sable
-share/festival/examples/example2.sable
-share/festival/examples/tobi.stml
-share/festival/examples/example.th
-share/festival/examples/intro.text
-share/festival/examples/spintro.text
-share/festival/examples/benchmark.text
-share/festival/examples/saytime.sh
-share/festival/examples/speech_pm_1.0.tar
-share/festival/examples/text2pos.sh
-share/festival/examples/latest.sh
-share/festival/examples/scfg_parse_text.sh
-share/festival/examples/text2wave.sh
-share/festival/examples/make_utts.sh
-share/festival/examples/dumpfeats.sh
-share/festival/examples/durmeanstd.sh
-share/festival/examples/benchmark
-share/festival/examples/festival_client.pl
-share/festival/examples/toksearch.scm
-share/festival/examples/th-mode.scm
-share/festival/examples/addr-mode.scm
-share/festival/examples/festival_client.c
-share/festival/examples/festival_client.h
-share/festival/examples/benchmark.orig
-share/festival/examples/saytime
-share/festival/examples/text2pos
-share/festival/examples/latest
-share/festival/examples/scfg_parse_text
-share/festival/examples/text2wave
-share/festival/examples/make_utts
-share/festival/examples/dumpfeats
-share/festival/examples/durmeanstd
-@dirrm share/festival/lib/voices/spanish
-@dirrm share/festival/lib/voices/italian
-@dirrm share/festival/lib/voices/english
-@dirrm share/festival/lib/voices
-@dirrm share/festival/lib/dicts
-@dirrm share/festival/lib
-@dirrm share/festival/examples
-@dirrm share/festival