aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-01-21 04:30:58 +0800
committertrevor <trevor@FreeBSD.org>2002-01-21 04:30:58 +0800
commitb21d2a52499771de4813fcd64f371eb7f0868bda (patch)
treeb716dfdc4e47bb426e8142de74bffa3855d39557 /audio
parentbf9d6cebcd4385e5e343a6567105fb93b9bdb591 (diff)
downloadfreebsd-ports-graphics-b21d2a52499771de4813fcd64f371eb7f0868bda.tar.gz
freebsd-ports-graphics-b21d2a52499771de4813fcd64f371eb7f0868bda.tar.zst
freebsd-ports-graphics-b21d2a52499771de4813fcd64f371eb7f0868bda.zip
Try to fix linking error introduced in last revision.
Diffstat (limited to 'audio')
-rw-r--r--audio/snd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 6f20eb23aaa..a3c00c74d80 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -60,8 +60,10 @@ CONFIGURE_ARGS+= --with-gtk-extra
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --with-no-gui
.endif
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CFLAGS="${CFLAGS}"
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
GNU_CONFIGURE= yes
@@ -77,7 +79,6 @@ WRKSRC= ${WRKDIR}/snd-5
post-configure:
@${PERL} -pi -e "s: -ldl::g" ${WRKSRC}/makefile
- @${PERL} -pi -e "s:-lm -lm:-lm:g" ${WRKSRC}/makefile
pre-install:
${ECHO} bin/snd > ${PLIST}