aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
committerbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
commitba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7 (patch)
treeb7aed86ac84412d11603ce23b7893d46f0d7475b /audio
parent3fcb7028e93fb51c19b4379e9c99091b90563e30 (diff)
downloadfreebsd-ports-graphics-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.gz
freebsd-ports-graphics-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.zst
freebsd-ports-graphics-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.zip
Convert bsd.gnustep.mk to USES=gnustep
Simplify gnustep ports Hook into the regular ports framework: - LIB_DEPENDS for library dependencies - Use regular USE_LDCONFIG Reuse USES=objc (automatic) USE_GNUSTEP is now a macro to set the dependencies and build feature needed. Accepted arguments: back base build gui Merge deskutils/preferencepanes into deskutils/systempreferences
Diffstat (limited to 'audio')
-rw-r--r--audio/cddb-bundle/Makefile7
-rw-r--r--audio/gnustep-cdplayer/Makefile18
-rw-r--r--audio/mpdcon/Makefile10
3 files changed, 13 insertions, 22 deletions
diff --git a/audio/cddb-bundle/Makefile b/audio/cddb-bundle/Makefile
index 2722d217a97..f3eecc9ad28 100644
--- a/audio/cddb-bundle/Makefile
+++ b/audio/cddb-bundle/Makefile
@@ -14,11 +14,8 @@ COMMENT= CDDB client bundle GNUstep
LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= tar:bzip2
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
+USES= tar:bzip2 gnustep
+USE_GNUSTEP= back build
CDPLAYER_VERSION= 0.5.1
WRKSRC= ${WRKDIR}/CDPlayer-${CDPLAYER_VERSION}/Cddb
diff --git a/audio/gnustep-cdplayer/Makefile b/audio/gnustep-cdplayer/Makefile
index 713550bf543..c7dc597905f 100644
--- a/audio/gnustep-cdplayer/Makefile
+++ b/audio/gnustep-cdplayer/Makefile
@@ -13,22 +13,18 @@ COMMENT= GNUstep CD player with CDDB support
LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcdaudio.so:${PORTSDIR}/audio/libcdaudio
+LIB_DEPENDS= libcdaudio.so:${PORTSDIR}/audio/libcdaudio \
+ libPrefsModule.so:${PORTSDIR}/deskutils/preferences
-USES= tar:bzip2
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LOCAL_BUNDLES+= Cddb:${CDDB_BUNDLE_PORT}
-USE_GNUSTEP_SYSTEM_LIBS+= PrefsModule:${PREFERENCES_PORT}
+BUILD_DEPENDS= cddb-bundle>0:${PORTSDIR}/audio/cddb-bundle
+RUN_DEPENDS= cddb-bundle>0:${PORTSDIR}/audio/cddb-bundle
+
+USES= tar:bzip2 gnustep
+USE_GNUSTEP= back build
WRKSRC= ${WRKDIR}/CDPlayer-${PORTVERSION}
MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_LOCAL_ROOT}
-CDDB_BUNDLE_PORT?= audio/cddb-bundle
-PREFERENCES_PORT?= deskutils/preferences
-
post-install:
${STRIP_CMD} \
${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/AudioCD.bundle/AudioCD \
diff --git a/audio/mpdcon/Makefile b/audio/mpdcon/Makefile
index 1fad121e4d4..bf191e25203 100644
--- a/audio/mpdcon/Makefile
+++ b/audio/mpdcon/Makefile
@@ -13,13 +13,11 @@ COMMENT= MPD client for GNUstep
LICENSE= GPLv2
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_LOCAL_LIBS+= SQLClient:databases/sqlclient
+USES= gnustep
+USE_GNUSTEP= base gui back build
-LIB_DEPENDS+= libmpdclient.so.2:${PORTSDIR}/audio/libmpdclient
+LIB_DEPENDS= libmpdclient.so.2:${PORTSDIR}/audio/libmpdclient \
+ libSQLClient.so:${PORTSDIR}/databases/sqlclient
post-patch:
${REINPLACE_CMD} -e \