aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2004-12-12 00:58:20 +0800
committerbland <bland@FreeBSD.org>2004-12-12 00:58:20 +0800
commitbf3010195d10995a48d2ce03b3a398e47b7072f2 (patch)
tree7647c08ae8538de12db86734d8b0dceeb2d1123b /audio
parent8f5114fb33efe716970c559f129e67b1f0f5428e (diff)
downloadfreebsd-ports-graphics-bf3010195d10995a48d2ce03b3a398e47b7072f2.tar.gz
freebsd-ports-graphics-bf3010195d10995a48d2ce03b3a398e47b7072f2.tar.zst
freebsd-ports-graphics-bf3010195d10995a48d2ce03b3a398e47b7072f2.zip
Update to 0.5.15
Diffstat (limited to 'audio')
-rw-r--r--audio/sound-juicer/Makefile3
-rw-r--r--audio/sound-juicer/distinfo4
-rw-r--r--audio/sound-juicer/files/patch-src::cd-drive.c31
3 files changed, 19 insertions, 19 deletions
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 9af50fccf8e..59c5cebaf0e 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sound-juicer
-PORTVERSION= 0.5.14
-PORTREVISION= 1
+PORTVERSION= 0.5.15
CATEGORIES= audio gnome
MASTER_SITES= http://www.burtonini.com/computing/
DIST_SUBDIR= gnome2
diff --git a/audio/sound-juicer/distinfo b/audio/sound-juicer/distinfo
index ac518a1eece..b9e30b62342 100644
--- a/audio/sound-juicer/distinfo
+++ b/audio/sound-juicer/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/sound-juicer-0.5.14.tar.gz) = 21ac5d1b9497b3bba2e4050b995bb865
-SIZE (gnome2/sound-juicer-0.5.14.tar.gz) = 591553
+MD5 (gnome2/sound-juicer-0.5.15.tar.gz) = f1c344b2dcd3f0efd4f9e0318f8526e1
+SIZE (gnome2/sound-juicer-0.5.15.tar.gz) = 594694
diff --git a/audio/sound-juicer/files/patch-src::cd-drive.c b/audio/sound-juicer/files/patch-src::cd-drive.c
index 690b0953e19..56d594fb962 100644
--- a/audio/sound-juicer/files/patch-src::cd-drive.c
+++ b/audio/sound-juicer/files/patch-src::cd-drive.c
@@ -1,10 +1,10 @@
---- src/cd-drive.c.orig Tue Sep 28 23:37:37 2004
-+++ src/cd-drive.c Wed Nov 10 22:37:44 2004
-@@ -578,7 +578,49 @@
+--- src/cd-drive.c.orig Sun Dec 12 01:39:32 2004
++++ src/cd-drive.c Sun Dec 12 01:41:50 2004
+@@ -596,7 +596,49 @@
#if defined(__linux__) || defined(__FreeBSD__)
-+#if !defined(__linux__)
++#if !defined(__linux)
+static int
+get_device_max_read_speed (char *device)
+{
@@ -14,11 +14,11 @@
+
+ max_speed = -1;
+
-+ fd = open (device, O_RDONLY|O_EXCL|O_NONBLOCK);
++ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
+ if (fd < 0) {
+ return -1;
+ }
-+
+
+ get_read_write_speed (fd, &read_speed, &write_speed);
+ close (fd);
+ max_speed = (int)floor (read_speed) / CD_ROM_SPEED;
@@ -26,7 +26,7 @@
+ return max_speed;
+}
+#endif
-
++
+static int
+get_device_max_write_speed (char *device)
+{
@@ -36,7 +36,7 @@
+
+ max_speed = -1;
+
-+ fd = open (device, O_RDONLY|O_EXCL|O_NONBLOCK);
++ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
+ if (fd < 0) {
+ return -1;
+ }
@@ -50,10 +50,12 @@
#endif /* __linux__ || __FreeBSD__ */
-@@ -782,49 +824,6 @@
+@@ -798,50 +840,6 @@
+ }
+ }
return NULL;
- }
-
+-}
+-
-#if !defined(__linux)
-static int
-get_device_max_read_speed (char *device)
@@ -64,7 +66,7 @@
-
- max_speed = -1;
-
-- fd = open (device, O_RDONLY|O_EXCL|O_NONBLOCK);
+- fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
- if (fd < 0) {
- return -1;
- }
@@ -86,7 +88,7 @@
-
- max_speed = -1;
-
-- fd = open (device, O_RDONLY|O_EXCL|O_NONBLOCK);
+- fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
- if (fd < 0) {
- return -1;
- }
@@ -96,7 +98,6 @@
- max_speed = (int)floor (write_speed) / CD_ROM_SPEED;
-
- return max_speed;
--}
+ }
static char *
- get_scsi_cd_name (int bus, int id, int lun, const char *dev,