aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
committertijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
commitc06f97c7c46a03f3f6bb887aee3534bece5267a1 (patch)
tree320f49e86d38a480aace5bd0e27c34d6c8f75c2c /audio
parent682bd0d0ee3984087ff6a9f3bf4b0552db04d013 (diff)
downloadfreebsd-ports-graphics-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.gz
freebsd-ports-graphics-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.zst
freebsd-ports-graphics-c06f97c7c46a03f3f6bb887aee3534bece5267a1.zip
Replace USE_AUTOTOOLS=libltdl with an ordinary LIB_DEPENDS in all ports.
There are only 60 such ports so there doesn't need to be a separate keyword or USES for this. Approved by: portmgr (bapt)
Diffstat (limited to 'audio')
-rw-r--r--audio/dvda-author/Makefile10
-rw-r--r--audio/glame/Makefile2
-rw-r--r--audio/libcanberra/Makefile4
-rw-r--r--audio/libmp3splt/Makefile3
-rw-r--r--audio/mp3splt-gtk/Makefile4
-rw-r--r--audio/mp3splt/Makefile6
-rw-r--r--audio/mpg123/Makefile3
-rw-r--r--audio/pulseaudio/Makefile2
-rw-r--r--audio/sox/Makefile4
9 files changed, 21 insertions, 17 deletions
diff --git a/audio/dvda-author/Makefile b/audio/dvda-author/Makefile
index 6e0cee34a5a..423f5feb48f 100644
--- a/audio/dvda-author/Makefile
+++ b/audio/dvda-author/Makefile
@@ -13,16 +13,16 @@ MAINTAINER= martin.dieringer@gmx.de
COMMENT= Author and playback unencrypted and uncompressed Audio-DVDs
LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
- libogg.so:${PORTSDIR}/audio/libogg \
- libsox.so:${PORTSDIR}/audio/sox \
- libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
- libpng15.so:${PORTSDIR}/graphics/png
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libsox.so:${PORTSDIR}/audio/sox \
+ libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
+ libltdl.so:${PORTSDIR}/devel/libltdl \
+ libpng15.so:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/FLAC
-USE_AUTOTOOLS= libltdl
USES= tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-flac=${LOCALBASE}/lib/libFLAC.so \
diff --git a/audio/glame/Makefile b/audio/glame/Makefile
index e1602f41f6d..1fc560e5b24 100644
--- a/audio/glame/Makefile
+++ b/audio/glame/Makefile
@@ -14,9 +14,9 @@ BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= libmp3lame.so:${PORTSDIR}/audio/lame \
libmad.so:${PORTSDIR}/audio/libmad \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libltdl.so:${PORTSDIR}/devel/libltdl \
libguile.so:${PORTSDIR}/lang/guile
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
USES= gettext gmake pathfix pkgconfig libtool makeinfo
diff --git a/audio/libcanberra/Makefile b/audio/libcanberra/Makefile
index 6fd649c02f2..19cba312c69 100644
--- a/audio/libcanberra/Makefile
+++ b/audio/libcanberra/Makefile
@@ -14,13 +14,13 @@ COMMENT= Implementation of the Freedesktop sound theme spec
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LGPL
-LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libltdl.so:${PORTSDIR}/devel/libltdl
USES= gmake libtool pathfix pkgconfig
USE_GNOME= gnomeprefix gtk20 gconf2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libltdl
CONFIGURE_ARGS= --disable-lynx --disable-tdb --disable-alsa
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/libmp3splt/Makefile b/audio/libmp3splt/Makefile
index 986fa801b5b..49df9cc713f 100644
--- a/audio/libmp3splt/Makefile
+++ b/audio/libmp3splt/Makefile
@@ -12,11 +12,12 @@ COMMENT= Library for splitting of various audio files
LICENSE= GPLv2
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-cutter --disable-doxygen_doc
USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libltdl
OPTIONS_MULTI= plugin
OPTIONS_MULTI_plugin= MAD VORBIS
diff --git a/audio/mp3splt-gtk/Makefile b/audio/mp3splt-gtk/Makefile
index 8fa79fae492..143509a17fa 100644
--- a/audio/mp3splt-gtk/Makefile
+++ b/audio/mp3splt-gtk/Makefile
@@ -16,10 +16,10 @@ LIB_DEPENDS= libmp3splt.so:${PORTSDIR}/audio/libmp3splt \
libmad.so:${PORTSDIR}/audio/libmad \
libogg.so:${PORTSDIR}/audio/libogg \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
- libid3tag.so:${PORTSDIR}/audio/libid3tag
+ libid3tag.so:${PORTSDIR}/audio/libid3tag \
+ libltdl.so:${PORTSDIR}/devel/libltdl
INSTALLS_OMF= yes
-USE_AUTOTOOLS= libltdl
USE_GSTREAMER= yes
USE_GNOME= gnomedocutils gtk20
GNU_CONFIGURE= yes
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
index 55e5d4263db..3ece642f0ec 100644
--- a/audio/mp3splt/Makefile
+++ b/audio/mp3splt/Makefile
@@ -11,10 +11,10 @@ COMMENT= Utility to split MP3 and Ogg files (via CUE sheets)
LICENSE= GPLv2
-LIB_DEPENDS= libmp3splt.so:${PORTSDIR}/audio/libmp3splt
+LIB_DEPENDS= libmp3splt.so:${PORTSDIR}/audio/libmp3splt \
+ libltdl.so:${PORTSDIR}/devel/libltdl
-USES= pkgconfig:build
-USE_AUTOTOOLS= libltdl
+USES= pkgconfig:build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-oggsplt_symlink
CONFIGURE_ENV+= PKG_CONFIG_PATH=${LOCALBASE}/lib/pkgconfig
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index 002598bb444..cde136be7c6 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -12,8 +12,9 @@ COMMENT= Command-line player for MPEG Layer 1, 2, and 3 audio files
LICENSE= LGPL21
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= tar:bzip2 gmake libtool:keepla pathfix
-USE_AUTOTOOLS= libltdl
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 1aa087361df..f467ebb1a88 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
libspeexdsp.so:${PORTSDIR}/audio/speex \
libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libltdl.so:${PORTSDIR}/devel/libltdl \
libgdbm.so:${PORTSDIR}/databases/gdbm \
libck-connector.so:${PORTSDIR}/sysutils/consolekit
@@ -28,7 +29,6 @@ USE_XORG= x11 sm xtst ice
USE_LDCONFIG= yes
USES= execinfo gettext gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libltdl
MAKE_JOBS_UNSAFE=yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index 81ca6601d00..b47b5819b2f 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -13,12 +13,14 @@ COMMENT= SOund eXchange - universal sound sample translator
LICENSE= LGPL21 GPLv2
LICENSE_COMB= dual
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
CONFLICTS= play-[0-9]*
GNU_CONFIGURE= yes
USES= pkgconfig libtool
USE_LDCONFIG= yes
-USE_AUTOTOOLS= aclocal autoconf automake libltdl
+USE_AUTOTOOLS= aclocal autoconf automake
OPTIONS_DEFINE= ALSA AO AMRNB AMRWB FFMPEG FLAC GSM ID3TAG LADSPA LAME \
MAD PNG PULSEAUDIO SNDFILE VORBIS WAVPACK