aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-12-21 09:05:38 +0800
committerpawel <pawel@FreeBSD.org>2013-12-21 09:05:38 +0800
commitc813b1095b8294894304d30f009baaf87426b7b7 (patch)
treef77ead2b02e81b35e3c00303d55ba29444150b96 /audio
parentf389107e640193398f057afb5435b490a20f7e69 (diff)
downloadfreebsd-ports-graphics-c813b1095b8294894304d30f009baaf87426b7b7.tar.gz
freebsd-ports-graphics-c813b1095b8294894304d30f009baaf87426b7b7.tar.zst
freebsd-ports-graphics-c813b1095b8294894304d30f009baaf87426b7b7.zip
- Fix build with clang
- Add LICENSE, desktop entry file - Support staging PR: ports/184891 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/gtkguitune/Makefile17
-rw-r--r--audio/gtkguitune/files/patch-lcdview.cc16
-rw-r--r--audio/gtkguitune/pkg-descr9
3 files changed, 31 insertions, 11 deletions
diff --git a/audio/gtkguitune/Makefile b/audio/gtkguitune/Makefile
index 7fb4c01ef51..0109b7384a5 100644
--- a/audio/gtkguitune/Makefile
+++ b/audio/gtkguitune/Makefile
@@ -3,32 +3,35 @@
PORTNAME= gtkguitune
PORTVERSION= 0.8
-PORTREVISION= 3
+DISTVERSIONPREFIX= gtk2-
+PORTREVISION= 4
CATEGORIES= audio
-MASTER_SITES= http://www.oocities.org/harpin_floh/mysoft/
-DISTNAME= ${PORTNAME}-gtk2-${PORTVERSION}
+MASTER_SITES= GENTOO/distfiles \
+ http://www.oocities.org/harpin_floh/mysoft/
MAINTAINER= ports@FreeBSD.org
COMMENT= Guitar (and other instruments) tuner for GTK+2
-LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
+LICENSE= GPLv2 # (or later)
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= pkgconfig
-NO_STAGE= yes
+USE_GNOME= gtkmm24
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
PLIST_FILES= bin/${PORTNAME} \
share/icons/hicolor/scalable/apps/guitune_logo.svg
+DESKTOP_ENTRIES="GtkGuitune" "" "guitune_logo" "${PORTNAME}" "" ""
+
post-patch:
@${REINPLACE_CMD} -e \
's|VERSION=0.7|VERSION=${PORTVERSION}|g' ${WRKSRC}/configure
-.for file in guitune.cc main.cc
+.for i in guitune.cc main.cc
@${REINPLACE_CMD} -e \
- 's|<linux/soundcard.h>|<sys/soundcard.h>|' ${WRKSRC}/${file}
+ 's|<linux/soundcard.h>|<sys/soundcard.h>|' ${WRKSRC}/${i}
.endfor
.include <bsd.port.mk>
diff --git a/audio/gtkguitune/files/patch-lcdview.cc b/audio/gtkguitune/files/patch-lcdview.cc
new file mode 100644
index 00000000000..c6d63c58ac7
--- /dev/null
+++ b/audio/gtkguitune/files/patch-lcdview.cc
@@ -0,0 +1,16 @@
+--- lcdview.cc.orig
++++ lcdview.cc
+@@ -23,11 +23,12 @@
+
+ #include "lcdview.h"
+
+-LCDView::LCDView(const char * str = 0)
++LCDView::LCDView(const char * str)
+ {
+ i_LCD_num = 11;
+ i_string_maxlen = 1000;
+ i_string = new char [i_string_maxlen];
++ str = 0;
+ set( str );
+
+ i_col_bg. set( "black" ); get_colormap()->alloc_color( i_col_bg );
diff --git a/audio/gtkguitune/pkg-descr b/audio/gtkguitune/pkg-descr
index 71b7a25c853..cc814cc88ad 100644
--- a/audio/gtkguitune/pkg-descr
+++ b/audio/gtkguitune/pkg-descr
@@ -1,6 +1,7 @@
-gtkguitune is a program for tuning guitars and other instruments. Rather than
-using FFT like many programs, it counts the number of triggerings between two
-trigger levels in a certain amount of time, which tends to be more accurate for
-instrument tuning while requiring less processing than FFT.
+gtkguitune is a program for tuning guitars and other instruments.
+Rather than using FFT like many programs, it counts the number of
+triggerings between two trigger levels in a certain amount of time,
+which tends to be more accurate for instrument tuning while requiring
+less processing than FFT.
WWW: http://www.oocities.com/harpin_floh/kguitune_page.html