aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-05-27 21:25:00 +0800
committerijliao <ijliao@FreeBSD.org>2002-05-27 21:25:00 +0800
commitdee77b134aec99d5f7c863b2b8c3051d06d5267a (patch)
tree732fd48bb96e5d47b4e62eab0e4d02458d0bfd09 /audio
parent80c8690d2bdcdaf0b8cd2db77ffa4dc364f6ad40 (diff)
downloadfreebsd-ports-graphics-dee77b134aec99d5f7c863b2b8c3051d06d5267a.tar.gz
freebsd-ports-graphics-dee77b134aec99d5f7c863b2b8c3051d06d5267a.tar.zst
freebsd-ports-graphics-dee77b134aec99d5f7c863b2b8c3051d06d5267a.zip
add gnump3d 0.9.9.7
A streaming server for MP3's, OGG vorbis, and other streamable audio files
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gnump3d/Makefile26
-rw-r--r--audio/gnump3d/distinfo1
-rw-r--r--audio/gnump3d/files/patch-freebsd15
-rw-r--r--audio/gnump3d/files/patch-server.c10
-rw-r--r--audio/gnump3d/pkg-comment1
-rw-r--r--audio/gnump3d/pkg-descr4
-rw-r--r--audio/gnump3d/pkg-plist17
8 files changed, 75 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index b6091934a0a..004e2947ec9 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -81,6 +81,7 @@
SUBDIR += gnomemedia
SUBDIR += gnomemedia2
SUBDIR += gnowavcut
+ SUBDIR += gnump3d
SUBDIR += gogo
SUBDIR += gqmpeg
SUBDIR += gramofile
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
new file mode 100644
index 00000000000..7b05e864ebb
--- /dev/null
+++ b/audio/gnump3d/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: gnump3d
+# Date created: May 27, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnump3d
+PORTVERSION= 0.9.9.7
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+ALL_TARGET= freebsd
+
+MAN1= mp3d.1 mp3d.conf.1 mp3d-top.1
+
+post-patch:
+ @${PERL} -pi -e "s,^PREFIX,#PREFIX,g ; \
+ s,/usr/local,${PREFIX},g ; \
+ s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/mkfiles/freebsd
+
+.include <bsd.port.mk>
diff --git a/audio/gnump3d/distinfo b/audio/gnump3d/distinfo
new file mode 100644
index 00000000000..b607c4076ed
--- /dev/null
+++ b/audio/gnump3d/distinfo
@@ -0,0 +1 @@
+MD5 (gnump3d-0.9.9.7.tar.gz) = 3aaf16eabf4f4517fd0c89cc1aeb3718
diff --git a/audio/gnump3d/files/patch-freebsd b/audio/gnump3d/files/patch-freebsd
new file mode 100644
index 00000000000..02529f16500
--- /dev/null
+++ b/audio/gnump3d/files/patch-freebsd
@@ -0,0 +1,15 @@
+--- mkfiles/freebsd.orig Mon May 27 21:23:17 2002
++++ mkfiles/freebsd Mon May 27 21:23:31 2002
+@@ -116,10 +116,10 @@
+ install ../mp3d.conf $(CONFIGDIR)
+ # Default template.
+ install -d $(TEMPLATEDIR)/default
+- cp -R ../templates/default/ $(TEMPLATEDIR)
++ cp -R ../templates/default $(TEMPLATEDIR)
+ # Simple template
+ install -d $(TEMPLATEDIR)/simple
+- cp -R ../templates/simple/ $(TEMPLATEDIR)
++ cp -R ../templates/simple $(TEMPLATEDIR)
+ install ../templates/README $(TEMPLATEDIR)
+ # Man pages.
+ install -d $(MANDIR)
diff --git a/audio/gnump3d/files/patch-server.c b/audio/gnump3d/files/patch-server.c
new file mode 100644
index 00000000000..d0541a2d2af
--- /dev/null
+++ b/audio/gnump3d/files/patch-server.c
@@ -0,0 +1,10 @@
+--- src/server.c.orig Mon May 27 20:51:04 2002
++++ src/server.c Mon May 27 20:51:22 2002
+@@ -32,6 +32,7 @@
+ */
+
+
++#include <sys/types.h>
+ #include <arpa/inet.h>
+ #include <ctype.h>
+ #include <netinet/in.h>
diff --git a/audio/gnump3d/pkg-comment b/audio/gnump3d/pkg-comment
new file mode 100644
index 00000000000..5797b04cc6c
--- /dev/null
+++ b/audio/gnump3d/pkg-comment
@@ -0,0 +1 @@
+A streaming server for MP3's, OGG vorbis, and other streamable audio files
diff --git a/audio/gnump3d/pkg-descr b/audio/gnump3d/pkg-descr
new file mode 100644
index 00000000000..f096c3299ba
--- /dev/null
+++ b/audio/gnump3d/pkg-descr
@@ -0,0 +1,4 @@
+GNUMP3d is a streaming server for MP3's, OGG vorbis, and other streamable
+audio files.
+
+WWW: http://gnump3d.sourceforge.net/
diff --git a/audio/gnump3d/pkg-plist b/audio/gnump3d/pkg-plist
new file mode 100644
index 00000000000..f45472040af
--- /dev/null
+++ b/audio/gnump3d/pkg-plist
@@ -0,0 +1,17 @@
+bin/mp3d
+bin/mp3d-top
+etc/mp3d.conf
+etc/mp3d/README
+etc/mp3d/default/error.html
+etc/mp3d/default/index.html
+etc/mp3d/default/search.html
+etc/mp3d/default/stats.html
+etc/mp3d/default/results.html
+etc/mp3d/simple/index.html
+etc/mp3d/simple/error.html
+etc/mp3d/simple/search.html
+etc/mp3d/simple/stats.html
+etc/mp3d/simple/results.html
+@dirrm etc/mp3d/default
+@dirrm etc/mp3d/simple
+@dirrm etc/mp3d