aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-02-11 22:21:38 +0800
committergahr <gahr@FreeBSD.org>2013-02-11 22:21:38 +0800
commite7f280a781d5d16a259d7a1029fff7e3a37e01c3 (patch)
treec295a0000e18d416d1e71e96d980704df0d0dfbb /audio
parent10b88b20bda3722dd5161f8793b568eebea0d3f5 (diff)
downloadfreebsd-ports-graphics-e7f280a781d5d16a259d7a1029fff7e3a37e01c3.tar.gz
freebsd-ports-graphics-e7f280a781d5d16a259d7a1029fff7e3a37e01c3.tar.zst
freebsd-ports-graphics-e7f280a781d5d16a259d7a1029fff7e3a37e01c3.zip
- Chase devel/ucommon shlib versbion bump
Diffstat (limited to 'audio')
-rw-r--r--audio/ccaudio2/Makefile14
-rw-r--r--audio/ccaudio2/files/patch-src_friends.cpp24
-rw-r--r--audio/ccaudio2/files/patch-utils_audiotool.cpp66
3 files changed, 90 insertions, 14 deletions
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index e443bff9bd6..8af68f94deb 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: ccaudio2
-# Date created: 13 February 2008
-# Whom: gahr
-#
+# Created by: gahr
# $FreeBSD$
-#
PORTNAME= ccaudio2
PORTVERSION= 2.0.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://www.gnutelephony.org/dist/tarballs/
@@ -15,9 +11,9 @@ MAINTAINER= gahr@FreeBSD.org
COMMENT= C++ class framework for manipulating audio files
LIB_DEPENDS= ccgnu2:${PORTSDIR}/devel/commoncpp \
- ucommon.5:${PORTSDIR}/devel/ucommon \
- gsm.1:${PORTSDIR}/audio/gsm \
- speex.1:${PORTSDIR}/audio/speex
+ ucommon:${PORTSDIR}/devel/ucommon \
+ gsm:${PORTSDIR}/audio/gsm \
+ speex:${PORTSDIR}/audio/speex
CONFLICTS= ccaudio-[0-9]*
diff --git a/audio/ccaudio2/files/patch-src_friends.cpp b/audio/ccaudio2/files/patch-src_friends.cpp
index 0ed79cd6b19..3296e00effe 100644
--- a/audio/ccaudio2/files/patch-src_friends.cpp
+++ b/audio/ccaudio2/files/patch-src_friends.cpp
@@ -1,5 +1,5 @@
---- src/friends.cpp.orig 2011-02-21 11:15:41.000000000 +0000
-+++ src/friends.cpp 2011-02-21 11:30:59.000000000 +0000
+--- src/friends.cpp.orig 2011-03-21 08:16:40.000000000 +0100
++++ src/friends.cpp 2013-02-11 15:09:54.000000000 +0100
@@ -22,6 +22,13 @@
#include <ctype.h>
#ifdef HAVE_ENDIAN_H
@@ -14,3 +14,23 @@
#endif
#include <ucommon/export.h>
#include <ccaudio2.h>
+@@ -1186,16 +1193,16 @@
+ if(!dp)
+ return;
+
+- fsys::open(dir, dp, fsys::ACCESS_DIRECTORY);
++ dir.open(dp, fsys::RDONLY);
+
+- while(is(dir) && fsys::read(dir, filename, sizeof(filename)) > 0) {
++ while(is(dir) && dir.read(filename, sizeof(filename)) > 0) {
+ if(filename[0] == '.')
+ continue;
+
+ snprintf(path, sizeof(path), "%s/%s", dp, filename);
+ fsys::load(path);
+ }
+- fsys::close(dir);
++ dir.close();
+ #endif
+ }
+
diff --git a/audio/ccaudio2/files/patch-utils_audiotool.cpp b/audio/ccaudio2/files/patch-utils_audiotool.cpp
index 5e1cf6f12a2..86ef1f1696c 100644
--- a/audio/ccaudio2/files/patch-utils_audiotool.cpp
+++ b/audio/ccaudio2/files/patch-utils_audiotool.cpp
@@ -1,5 +1,5 @@
---- utils/audiotool.cpp.orig 2011-02-21 11:30:44.000000000 +0000
-+++ utils/audiotool.cpp 2011-02-21 11:30:58.000000000 +0000
+--- utils/audiotool.cpp.orig 2011-03-21 08:16:40.000000000 +0100
++++ utils/audiotool.cpp 2013-02-11 15:13:11.000000000 +0100
@@ -20,6 +20,13 @@
#include <config.h>
#ifdef HAVE_ENDIAN_H
@@ -13,4 +13,64 @@
+#endif
#endif
- #if defined(_MSWINDOWS_) && !defined(__BIG_ENDIAN)
+ #if !defined(__BIG_ENDIAN)
+@@ -401,12 +408,12 @@
+ framing = 20;
+
+ while(*argv) {
+- if(!fsys::isfile(*argv)) {
++ if(!fsys::is_file(*argv)) {
+ printf("%s: %s\n",
+ fname(*(argv++)), _TEXT("invalid"));
+ continue;
+ }
+- if(fsys::access(*argv, R_OK)) {
++ if(!fsys::is_readable(*argv)) {
+ printf("%s: %s\n",
+ fname(*(argv++)), _TEXT("inaccessable"));
+ continue;
+@@ -530,12 +537,12 @@
+ }
+
+ while(*argv) {
+- if(!fsys::isfile(*argv)) {
++ if(!fsys::is_file(*argv)) {
+ printf("audiotool: %s: %s\n",
+ fname(*(argv++)), _TEXT("invalid"));
+ continue;
+ }
+- if(fsys::access(*argv, R_OK)) {
++ if(!fsys::is_readable(*argv)) {
+ printf("audiotool: %s: %s\n",
+ fname(*(argv++)), _TEXT("inaccessable"));
+ continue;
+@@ -682,12 +689,12 @@
+ framing = 20;
+
+ while(*argv) {
+- if(!fsys::isfile(*argv)) {
++ if(!fsys::is_file(*argv)) {
+ printf("%s: %s\n",
+ *(argv++), _TEXT("invalid"));
+ continue;
+ }
+- if(fsys::access(*argv, R_OK)) {
++ if(!fsys::is_readable(*argv)) {
+ printf("%s: %s\n",
+ *(argv++), _TEXT("inaccessable"));
+ continue;
+@@ -881,12 +888,12 @@
+ framing = 20;
+
+ while(*argv) {
+- if(!fsys::isfile(*argv)) {
++ if(!fsys::is_file(*argv)) {
+ printf("%s: %s\n",
+ *(argv++), _TEXT("invalid"));
+ continue;
+ }
+- if(fsys::access(*argv, R_OK)) {
++ if(!fsys::is_readable(*argv)) {
+ printf("%s: %s\n",
+ *(argv++), _TEXT("inaccessable"));
+ continue;