aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2013-12-19 00:04:49 +0800
committernaddy <naddy@FreeBSD.org>2013-12-19 00:04:49 +0800
commitec4b0c266d20c425e3ea609bba91d47d2b85249b (patch)
tree09f3a453c650c499b52275e28d2c37b44fa1abb6 /audio
parentd195055ee963ad376da19ed0d348af00e0afb64b (diff)
downloadfreebsd-ports-graphics-ec4b0c266d20c425e3ea609bba91d47d2b85249b.tar.gz
freebsd-ports-graphics-ec4b0c266d20c425e3ea609bba91d47d2b85249b.tar.zst
freebsd-ports-graphics-ec4b0c266d20c425e3ea609bba91d47d2b85249b.zip
Update opus to 1.1, which includes:
* new analysis code and tuning that significantly improves encoding quality, especially for variable-bitrate (VBR), * automatic detection of speech or music to decide which encoding mode to use, * surround with good quality at 128 kbps for 5.1 and usable down to 48 kbps, * and speed improvements on all architectures. Chase shared library bump. PR: 184956
Diffstat (limited to 'audio')
-rw-r--r--audio/gstreamer-plugins-opus/Makefile2
-rw-r--r--audio/gstreamer1-plugins-opus/Makefile2
-rw-r--r--audio/mumble/Makefile2
-rw-r--r--audio/opus/Makefile6
-rw-r--r--audio/opus/distinfo4
-rw-r--r--audio/opus/files/patch-configure20
-rw-r--r--audio/opus/pkg-plist2
7 files changed, 29 insertions, 9 deletions
diff --git a/audio/gstreamer-plugins-opus/Makefile b/audio/gstreamer-plugins-opus/Makefile
index 21385bbd767..c67f0734010 100644
--- a/audio/gstreamer-plugins-opus/Makefile
+++ b/audio/gstreamer-plugins-opus/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
COMMENT= Gstreamer Opus audio encoder/decoder plugin
diff --git a/audio/gstreamer1-plugins-opus/Makefile b/audio/gstreamer1-plugins-opus/Makefile
index f8080177e47..a08d9426eff 100644
--- a/audio/gstreamer1-plugins-opus/Makefile
+++ b/audio/gstreamer1-plugins-opus/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= audio
COMMENT= Gstreamer Opus audio encoder/decoder plugin
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index ecd02b0e59e..0fa90173ee3 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mumble
PORTVERSION= 1.2.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/Mumble/${PORTVERSION}
diff --git a/audio/opus/Makefile b/audio/opus/Makefile
index 2748d069ac3..7e0bff0efa7 100644
--- a/audio/opus/Makefile
+++ b/audio/opus/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= opus
-PORTVERSION= 1.0.3
+PORTVERSION= 1.1
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/opus/ \
https://ftp.mozilla.org/pub/mozilla.org/opus/
@@ -9,7 +9,7 @@ MASTER_SITES= http://downloads.xiph.org/releases/opus/ \
MAINTAINER= naddy@FreeBSD.org
COMMENT= IETF audio codec
-USES= pathfix
+USES= gmake pathfix
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
@@ -19,7 +19,7 @@ CONFIGURE_ARGS= --enable-custom-modes \
--disable-doc # requires doxygen
regression-test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
.include <bsd.port.options.mk>
diff --git a/audio/opus/distinfo b/audio/opus/distinfo
index c3339d47fd3..1fd102cd635 100644
--- a/audio/opus/distinfo
+++ b/audio/opus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opus-1.0.3.tar.gz) = 191a089c92dbc403de6980463dd3604b65beb12d283c607e246c8076363cb49c
-SIZE (opus-1.0.3.tar.gz) = 781049
+SHA256 (opus-1.1.tar.gz) = b9727015a58affcf3db527322bf8c4d2fcf39f5f6b8f15dbceca20206cbe1d95
+SIZE (opus-1.1.tar.gz) = 850208
diff --git a/audio/opus/files/patch-configure b/audio/opus/files/patch-configure
new file mode 100644
index 00000000000..4e78a15d5c7
--- /dev/null
+++ b/audio/opus/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2013-12-17 16:51:41.000000000 +0100
++++ configure 2013-12-17 16:52:02.000000000 +0100
+@@ -12807,7 +12807,7 @@ else
+ CPU_ARM_FALSE=
+ fi
+
+- if test x"${inline_optimization:0:3}" = x"ARM"; then
++ if expr x"${inline_optimization}" : x"ARM" >/dev/null; then
+ OPUS_ARM_INLINE_ASM_TRUE=
+ OPUS_ARM_INLINE_ASM_FALSE='#'
+ else
+@@ -12815,7 +12815,7 @@ else
+ OPUS_ARM_INLINE_ASM_FALSE=
+ fi
+
+- if test x"${asm_optimization:0:3}" = x"ARM"; then
++ if expr x"${asm_optimization}" : x"ARM" >/dev/null; then
+ OPUS_ARM_EXTERNAL_ASM_TRUE=
+ OPUS_ARM_EXTERNAL_ASM_FALSE='#'
+ else
diff --git a/audio/opus/pkg-plist b/audio/opus/pkg-plist
index 1dd881f2d92..d6df3ab3d1f 100644
--- a/audio/opus/pkg-plist
+++ b/audio/opus/pkg-plist
@@ -6,7 +6,7 @@ include/opus/opus_types.h
lib/libopus.a
lib/libopus.la
lib/libopus.so
-lib/libopus.so.4
+lib/libopus.so.5
libdata/pkgconfig/opus.pc
share/aclocal/opus.m4
@dirrm include/opus