aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-06-10 22:34:26 +0800
committercrees <crees@FreeBSD.org>2012-06-10 22:34:26 +0800
commitf0bb0f45adb1270656e78f6fa64500638c500a24 (patch)
tree13ac77c077ef7454d6297eb749067547d4b610e2 /audio
parentc10f4b8e0c3a019fa227fb9405b8f07e72cb6a0a (diff)
downloadfreebsd-ports-graphics-f0bb0f45adb1270656e78f6fa64500638c500a24.tar.gz
freebsd-ports-graphics-f0bb0f45adb1270656e78f6fa64500638c500a24.tar.zst
freebsd-ports-graphics-f0bb0f45adb1270656e78f6fa64500638c500a24.zip
Warn if user sets own value of MPDCONF-- potential for breakage is nonzero and
packages don't support it anyway.
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index eaf4feeca68..cdc8215a7f7 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -222,6 +222,16 @@ LIB_DEPENDS+= cue:${PORTSDIR}/textproc/libcue
CONFIGURE_ARGS+=--disable-cue
.endif
+.if ${MPDCONF} != musicpd.conf
+pre-everything::
+ @${ECHO_MSG} "Looks as though you're using a non-default value for MPDCONF."
+ @${ECHO_MSG} "This is deprecated, and some time in the near future the only value permissible"
+ @${ECHO_MSG} "for MPDCONF will be the default; musicpd.conf."
+ @${ECHO_MSG} -n "Continuing in "
+ @for s in 5 4 3 2 1 ; do ${ECHO_MSG} -n "$$s... " && sleep 1 ; done
+ @${ECHO_MSG} ""
+.endif
+
post-patch:
# Replace ~/ with MPDDIR and make musicpd run as mpd by default
@${REINPLACE_CMD} -e 's,^#\([^"]*"\)~/,\1${MPDDIR}/,g' \