aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2008-08-01 00:12:03 +0800
committerpgollucci <pgollucci@FreeBSD.org>2008-08-01 00:12:03 +0800
commitf107ece7e502cfa98e96e4e2e8ed4579429cc358 (patch)
tree372a3aed02a40a7f0639aac60b84795c79eb47ba /audio
parent5594ddcb6141b7bb06d1c572bc1d6dc5f792fa38 (diff)
downloadfreebsd-ports-graphics-f107ece7e502cfa98e96e4e2e8ed4579429cc358.tar.gz
freebsd-ports-graphics-f107ece7e502cfa98e96e4e2e8ed4579429cc358.tar.zst
freebsd-ports-graphics-f107ece7e502cfa98e96e4e2e8ed4579429cc358.zip
- fully utilize USE_RC_SUBR
itectu@: no more .sh dougb@: move load_config above variables checks - Bump PORTREVISION PR: ports/125623 Approved by: maintainer, gabor (mentor)
Diffstat (limited to 'audio')
-rw-r--r--audio/autocd/Makefile10
-rw-r--r--audio/autocd/files/autocd.in (renamed from audio/autocd/files/autocd.sh)6
2 files changed, 5 insertions, 11 deletions
diff --git a/audio/autocd/Makefile b/audio/autocd/Makefile
index 821c9eba0bc..eaa6161a19a 100644
--- a/audio/autocd/Makefile
+++ b/audio/autocd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autocd
PORTVERSION= 3.02.12b
+PORTREVISION= 1
CATEGORIES= audio sysutils
MASTER_SITES= ftp://kot.spb.ru/pub/src/projects/autocd/
@@ -21,16 +22,9 @@ MLINKS= cdctl.1 eject.1 cdctl.1 pause.1
PLIST_FILES= sbin/autocd bin/acdplay bin/cdctl bin/pause bin/eject
PORTDOCS= README.rus.html
-USE_RC_SUBR= yes
-RC_SUFX= .sh
-SED_SCRIPT+= -e '{ s,%%PREFIX%%,${PREFIX},g; s,%%RC_SUBR%%,${RC_SUBR},g; }'
-PLIST_FILES+= etc/rc.d/autocd${RC_SUFX}
-
-post-build:
- @${SED} ${SED_SCRIPT} ${FILESDIR}/autocd.sh >${WRKDIR}/autocd.sh
+USE_RC_SUBR= autocd
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/autocd.sh ${PREFIX}/etc/rc.d/autocd${RC_SUFX}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
diff --git a/audio/autocd/files/autocd.sh b/audio/autocd/files/autocd.in
index 152cc13cfde..12dc07a1378 100644
--- a/audio/autocd/files/autocd.sh
+++ b/audio/autocd/files/autocd.in
@@ -30,9 +30,9 @@ stop_cmd()
%%PREFIX%%/bin/cdctl die
}
+load_rc_config $name
+
# set defaults
-autocd_enable=${autocd_enable:-"NO"}
-autocd_flags=${autocd_flags:-""}
+autocd_flags=${autocd_flags-""}
-load_rc_config $name
run_rc_command "$1"