aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-07-09 19:17:56 +0800
committernaddy <naddy@FreeBSD.org>2009-07-09 19:17:56 +0800
commitf25c3b4f20005683cc6f9200e2c35bf0edc9c4d3 (patch)
treed40daa7bd5883254004841c6e8bc21d24d193e44 /audio
parentae9681265a55b7957150388b2c7d7a11d5cedbe4 (diff)
downloadfreebsd-ports-graphics-f25c3b4f20005683cc6f9200e2c35bf0edc9c4d3.tar.gz
freebsd-ports-graphics-f25c3b4f20005683cc6f9200e2c35bf0edc9c4d3.tar.zst
freebsd-ports-graphics-f25c3b4f20005683cc6f9200e2c35bf0edc9c4d3.zip
Alas, the assumption that /nonexistent does not exist is not reliable.
PR: 136447
Diffstat (limited to 'audio')
-rw-r--r--audio/flac/Makefile5
-rw-r--r--audio/xmms-flac/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 302afcbabf1..41910b4ff8b 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -34,7 +34,6 @@ CONFIGURE_ARGS+=--without-libiconv-prefix
.endif
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-MAKE_ENV= MAKEOBJDIR=/nonexistent # ignore ${WRKSRC}/obj
.if defined(NOPORTDOCS)
MAKE_ENV+= DOC=""
.else
@@ -54,6 +53,10 @@ pre-patch:
@${REINPLACE_CMD} 's:^docdir = $$(datadir)/doc/$$(PACKAGE)-$$(VERSION):docdir = $$(datadir)/doc/$$(PACKAGE):' \
`find ${WRKSRC}/doc -name Makefile.in`
+# "obj" is magic to our make(1)
+post-configure:
+ @${RM} -rf ${WRKSRC}/obj
+
post-build:
${REINPLACE_CMD} 's:%%PREFIX%%:${PREFIX}:' ${WRKSRC}/man/flac.1
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index 9775c974276..81b2e3ac62b 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -23,10 +23,13 @@ CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--with-xmms-prefix="${LOCALBASE}"
MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
-MAKE_ENV= MAKEOBJDIR=/nonexistent # ignore ${WRKSRC}/obj
MAKEFILE= ${FILESDIR}/Makefile
MAKE_JOBS_SAFE= yes
+# "obj" is magic to our make(1)
+post-configure:
+ @${RM} -rf ${WRKSRC}/obj
+
# XXX
post-install:
${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la