aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1994-11-22 23:56:30 +0800
committerjmz <jmz@FreeBSD.org>1994-11-22 23:56:30 +0800
commitf2805b14dbdd0ed2bf0f875267b4622b8fc654e0 (patch)
treefef3e7377983d6787587fa0b32c88708018b6eab /audio
parent79808db2ab0d0ab6a10639e6e258836147879a0c (diff)
downloadfreebsd-ports-graphics-f2805b14dbdd0ed2bf0f875267b4622b8fc654e0.tar.gz
freebsd-ports-graphics-f2805b14dbdd0ed2bf0f875267b4622b8fc654e0.tar.zst
freebsd-ports-graphics-f2805b14dbdd0ed2bf0f875267b4622b8fc654e0.zip
xcd - a Tcl/Tk CD player
Diffstat (limited to 'audio')
-rw-r--r--audio/xcd/Makefile4
-rw-r--r--audio/xcd/pkg-comment1
-rw-r--r--audio/xcd/pkg-descr10
-rw-r--r--audio/xcd/pkg-plist26
-rw-r--r--audio/xcd/scripts/configure13
5 files changed, 54 insertions, 0 deletions
diff --git a/audio/xcd/Makefile b/audio/xcd/Makefile
new file mode 100644
index 00000000000..9d0c2a05231
--- /dev/null
+++ b/audio/xcd/Makefile
@@ -0,0 +1,4 @@
+DISTNAME= xcd
+MASTER_SITES= ftp://ftp.obs-besancon.fr/pub/outgoing/
+
+.include <bsd.port.mk>
diff --git a/audio/xcd/pkg-comment b/audio/xcd/pkg-comment
new file mode 100644
index 00000000000..3430f76b68c
--- /dev/null
+++ b/audio/xcd/pkg-comment
@@ -0,0 +1 @@
+xcd - a Tcl/Tk CD player
diff --git a/audio/xcd/pkg-descr b/audio/xcd/pkg-descr
new file mode 100644
index 00000000000..a05075ed0f7
--- /dev/null
+++ b/audio/xcd/pkg-descr
@@ -0,0 +1,10 @@
+Xcd is a simple GUI to control a CD player. It requires Tcl/Tk to be
+installed on your system.
+Xcd has the usual buttons to control a CD player: "play",
+"pause/resume", "stop", "eject", "next track", "previous track",
+"rewind", "forward" and a volume slider. Xcd displays continuously the
+current track number and the elapsed time of the track. Pressing the
+left mouse button on the "track" label causes Xcd to display the total
+number of the tracks and the total duration of the disk. Pressing the
+left mouse button on the "time" label causes xcd to display the
+duration of the current track.
diff --git a/audio/xcd/pkg-plist b/audio/xcd/pkg-plist
new file mode 100644
index 00000000000..510d229c017
--- /dev/null
+++ b/audio/xcd/pkg-plist
@@ -0,0 +1,26 @@
+@cd /usr/local
+@owner bin
+@mode 755
+bin/cdplayer
+bin/xcd
+@mode 644
+lib/xcd/eject.xbm
+lib/xcd/eject_s.xbm
+lib/xcd/ff.xbm
+lib/xcd/ff_s.xbm
+lib/xcd/logo.xbm
+lib/xcd/next.xbm
+lib/xcd/next_s.xbm
+lib/xcd/pause.xbm
+lib/xcd/pause_s.xbm
+lib/xcd/play.xbm
+lib/xcd/play_s.xbm
+lib/xcd/prev.xbm
+lib/xcd/prev_s.xbm
+lib/xcd/rewind.xbm
+lib/xcd/rewind_s.xbm
+lib/xcd/stop.xbm
+lib/xcd/stop_s.xbm
+man/man1/cdplayer.1
+man/man1/xcd.1
+
diff --git a/audio/xcd/scripts/configure b/audio/xcd/scripts/configure
new file mode 100644
index 00000000000..e0b3b073ca9
--- /dev/null
+++ b/audio/xcd/scripts/configure
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+cd $WRKSRC || exit 1;
+
+cat >> Makefile << END
+
+BINDIR = $PREFIX/bin
+CDDIR = $PREFIX/lib/xcd
+MANDIR = $PREFIX/man/man1
+
+END
+
+exit 0;