aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2010-07-19 05:27:09 +0800
committeraraujo <araujo@FreeBSD.org>2010-07-19 05:27:09 +0800
commitf92e75ccb1d606e6f585eefd0b66c7b6769a0b85 (patch)
tree646159a6aea64246f666a5931cb4c49122eccb33 /audio
parent254f44d8936d70e770210444aca26a9a50d77156 (diff)
downloadfreebsd-ports-graphics-f92e75ccb1d606e6f585eefd0b66c7b6769a0b85.tar.gz
freebsd-ports-graphics-f92e75ccb1d606e6f585eefd0b66c7b6769a0b85.tar.zst
freebsd-ports-graphics-f92e75ccb1d606e6f585eefd0b66c7b6769a0b85.zip
- Update to 0.10.26.
- Optionify. - Remove useless GTK deps. - Unbashify. - Repects NLS. - Add license. - Pass maintainership to submitter. PR: ports/148582 Submitted by: Bapt <baptiste.daroussin@gmail.com> Approved by: Sascha Klauder <sklauder@trimind.de> (maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/gmm/Makefile51
-rw-r--r--audio/gmm/distinfo6
-rw-r--r--audio/gmm/pkg-plist21
-rw-r--r--audio/gogglesmm/Makefile51
-rw-r--r--audio/gogglesmm/distinfo6
-rw-r--r--audio/gogglesmm/pkg-plist21
6 files changed, 98 insertions, 58 deletions
diff --git a/audio/gmm/Makefile b/audio/gmm/Makefile
index ae1c7520dcd..97af3a958f6 100644
--- a/audio/gmm/Makefile
+++ b/audio/gmm/Makefile
@@ -6,45 +6,62 @@
#
PORTNAME= gmm
-PORTVERSION= 0.10.22
-PORTREVISION= 1
+PORTVERSION= 0.10.26
CATEGORIES= audio
MASTER_SITES= http://gogglesmm.googlecode.com/files/
-DISTNAME= musicmanager-${PORTVERSION}
+DISTNAME= gogglesmm-${PORTVERSION}
-MAINTAINER= sklauder@trimind.de
+MAINTAINER= baptiste.daroussin@gmail.com
COMMENT= Music collection manager and player
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16 \
xine.1:${PORTSDIR}/multimedia/libxine \
tag.1:${PORTSDIR}/audio/taglib \
- sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- dbus-1:${PORTSDIR}/devel/dbus \
- curl.6:${PORTSDIR}/ftp/curl
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+OPTIONS= DBUS "Add DBUS support" on \
+ CURL "Add Curl support" on \
+ NLS "Add support for nls" on \
+ NEWREMOTE "Use new remote player" on
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_GMAKE= yes
-USE_BZIP2= yes
-USE_GETTEXT= yes
-USE_GNOME= gtk20
+USE_XZ= yes
INSTALLS_ICONS= yes
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
PORTDOCS= README AUTHORS
CONFIGURE_ENV= OPT_CFLAGS=" "
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+.if defined(WITHOUT_DBUS)
+CONFIGURE_ARGS+= --without-dbus
+.else
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+.endif
+
+.if defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --without-curl
+.else
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB= NLS="@comment "
+.else
+PLIST_SUB= NLS=""
+USE_GETTEXT= yes
+.endif
.if defined(WITHOUT_NEWREMOTE)
CONFIGURE_ARGS+=--without-new-remote
.endif
-post-patch:
- @${REINPLACE_CMD} -i '' -e "s|/bin/bash|${LOCALBASE}/bin/bash|; \
- s|/usr/local|${LOCALBASE}|" ${WRKSRC}/configure
-
post-configure:
@${REINPLACE_CMD} -i '' -e 's| -[DT] | |g' \
${WRKSRC}/Makefile
@@ -57,4 +74,4 @@ post-install:
. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/gmm/distinfo b/audio/gmm/distinfo
index ccd469c57ac..57aa39edb0f 100644
--- a/audio/gmm/distinfo
+++ b/audio/gmm/distinfo
@@ -1,3 +1,3 @@
-MD5 (musicmanager-0.10.22.tar.bz2) = 0379054b9cf2a2d4074a0129d03b3763
-SHA256 (musicmanager-0.10.22.tar.bz2) = 8083dab95a483ba975873ce6bed1054752b2fdb207d2424383aa1d77593ee536
-SIZE (musicmanager-0.10.22.tar.bz2) = 422520
+MD5 (gogglesmm-0.10.26.tar.xz) = 0af437902dcc0b1da49b3d48df930d8e
+SHA256 (gogglesmm-0.10.26.tar.xz) = 1200b4a9fdc507a94e4ffd19a821418f0ec1df300a0deaef292141824035c2c3
+SIZE (gogglesmm-0.10.26.tar.xz) = 361804
diff --git a/audio/gmm/pkg-plist b/audio/gmm/pkg-plist
index 09ec879ea04..0cb7a59a704 100644
--- a/audio/gmm/pkg-plist
+++ b/audio/gmm/pkg-plist
@@ -1,10 +1,13 @@
-bin/gmm
-share/applications/gmm.desktop
-share/icons/hicolor/48x48/apps/gmm.png
-share/locale/de/LC_MESSAGES/gogglesmm.mo
-share/locale/es/LC_MESSAGES/gogglesmm.mo
-share/locale/fr/LC_MESSAGES/gogglesmm.mo
-share/locale/ru/LC_MESSAGES/gogglesmm.mo
-share/locale/hu/LC_MESSAGES/gogglesmm.mo
-share/locale/cs/LC_MESSAGES/gogglesmm.mo
+bin/gogglesmm
+share/applications/gogglesmm.desktop
+share/icons/hicolor/48x48/apps/gogglesmm.png
+%%NLS%%share/locale/de/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gogglesmm.mo
@dirrmtry share/applications
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index ae1c7520dcd..97af3a958f6 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -6,45 +6,62 @@
#
PORTNAME= gmm
-PORTVERSION= 0.10.22
-PORTREVISION= 1
+PORTVERSION= 0.10.26
CATEGORIES= audio
MASTER_SITES= http://gogglesmm.googlecode.com/files/
-DISTNAME= musicmanager-${PORTVERSION}
+DISTNAME= gogglesmm-${PORTVERSION}
-MAINTAINER= sklauder@trimind.de
+MAINTAINER= baptiste.daroussin@gmail.com
COMMENT= Music collection manager and player
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16 \
xine.1:${PORTSDIR}/multimedia/libxine \
tag.1:${PORTSDIR}/audio/taglib \
- sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- dbus-1:${PORTSDIR}/devel/dbus \
- curl.6:${PORTSDIR}/ftp/curl
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+OPTIONS= DBUS "Add DBUS support" on \
+ CURL "Add Curl support" on \
+ NLS "Add support for nls" on \
+ NEWREMOTE "Use new remote player" on
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_GMAKE= yes
-USE_BZIP2= yes
-USE_GETTEXT= yes
-USE_GNOME= gtk20
+USE_XZ= yes
INSTALLS_ICONS= yes
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
PORTDOCS= README AUTHORS
CONFIGURE_ENV= OPT_CFLAGS=" "
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+.if defined(WITHOUT_DBUS)
+CONFIGURE_ARGS+= --without-dbus
+.else
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+.endif
+
+.if defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --without-curl
+.else
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB= NLS="@comment "
+.else
+PLIST_SUB= NLS=""
+USE_GETTEXT= yes
+.endif
.if defined(WITHOUT_NEWREMOTE)
CONFIGURE_ARGS+=--without-new-remote
.endif
-post-patch:
- @${REINPLACE_CMD} -i '' -e "s|/bin/bash|${LOCALBASE}/bin/bash|; \
- s|/usr/local|${LOCALBASE}|" ${WRKSRC}/configure
-
post-configure:
@${REINPLACE_CMD} -i '' -e 's| -[DT] | |g' \
${WRKSRC}/Makefile
@@ -57,4 +74,4 @@ post-install:
. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/gogglesmm/distinfo b/audio/gogglesmm/distinfo
index ccd469c57ac..57aa39edb0f 100644
--- a/audio/gogglesmm/distinfo
+++ b/audio/gogglesmm/distinfo
@@ -1,3 +1,3 @@
-MD5 (musicmanager-0.10.22.tar.bz2) = 0379054b9cf2a2d4074a0129d03b3763
-SHA256 (musicmanager-0.10.22.tar.bz2) = 8083dab95a483ba975873ce6bed1054752b2fdb207d2424383aa1d77593ee536
-SIZE (musicmanager-0.10.22.tar.bz2) = 422520
+MD5 (gogglesmm-0.10.26.tar.xz) = 0af437902dcc0b1da49b3d48df930d8e
+SHA256 (gogglesmm-0.10.26.tar.xz) = 1200b4a9fdc507a94e4ffd19a821418f0ec1df300a0deaef292141824035c2c3
+SIZE (gogglesmm-0.10.26.tar.xz) = 361804
diff --git a/audio/gogglesmm/pkg-plist b/audio/gogglesmm/pkg-plist
index 09ec879ea04..0cb7a59a704 100644
--- a/audio/gogglesmm/pkg-plist
+++ b/audio/gogglesmm/pkg-plist
@@ -1,10 +1,13 @@
-bin/gmm
-share/applications/gmm.desktop
-share/icons/hicolor/48x48/apps/gmm.png
-share/locale/de/LC_MESSAGES/gogglesmm.mo
-share/locale/es/LC_MESSAGES/gogglesmm.mo
-share/locale/fr/LC_MESSAGES/gogglesmm.mo
-share/locale/ru/LC_MESSAGES/gogglesmm.mo
-share/locale/hu/LC_MESSAGES/gogglesmm.mo
-share/locale/cs/LC_MESSAGES/gogglesmm.mo
+bin/gogglesmm
+share/applications/gogglesmm.desktop
+share/icons/hicolor/48x48/apps/gogglesmm.png
+%%NLS%%share/locale/de/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gogglesmm.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gogglesmm.mo
@dirrmtry share/applications
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor