aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-10-21 03:32:15 +0800
committersem <sem@FreeBSD.org>2005-10-21 03:32:15 +0800
commit41524f59b45749b757f2abd0cbe7d97c0ad9550a (patch)
tree85d96db37fdcad730302173fd8c6957f4ba1c065 /benchmarks
parent32b6ba8b9b7f69364a24b70ddcf7419b45cc5bd0 (diff)
downloadfreebsd-ports-graphics-41524f59b45749b757f2abd0cbe7d97c0ad9550a.tar.gz
freebsd-ports-graphics-41524f59b45749b757f2abd0cbe7d97c0ad9550a.tar.zst
freebsd-ports-graphics-41524f59b45749b757f2abd0cbe7d97c0ad9550a.zip
The program thrulay is used to measure the capacity, delay, and
other performance metrics of a network by sending a bulk TCP or UDP stream over it. Special features of thrulay include: * For TCP, ability to measure round-trip delay along with throughput * For UDP, ability to measure - one-way delay, with quantiles - packet loss - packet duplication - reordering * For UDP, the ability to send precisely positioned true Poisson streams (microsecond errors in sending times) * Human- and machine-readable output (ready to be fed to gnuplot) WWW: http://www.internet2.edu/~shalunov/thrulay/ PR: ports/87683 Submitted by: Stanislav Shalunov <shalunov@internet2.edu>
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/thrulay/Makefile31
-rw-r--r--benchmarks/thrulay/distinfo1
-rw-r--r--benchmarks/thrulay/files/thrulayd.sh.sample14
-rw-r--r--benchmarks/thrulay/pkg-descr16
-rw-r--r--benchmarks/thrulay/pkg-message4
-rw-r--r--benchmarks/thrulay/pkg-plist5
7 files changed, 72 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 0788bac369c..4b086c1b876 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -43,6 +43,7 @@
SUBDIR += siege
SUBDIR += stream
SUBDIR += tcpblast
+ SUBDIR += thrulay
SUBDIR += tmetric
SUBDIR += ttcp
SUBDIR += ubench
diff --git a/benchmarks/thrulay/Makefile b/benchmarks/thrulay/Makefile
new file mode 100644
index 00000000000..216db123b34
--- /dev/null
+++ b/benchmarks/thrulay/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: thrulay
+# Date created: 2005-10-19
+# Whom: shalunov
+#
+# $FreeBSD$
+
+PORTNAME= thrulay
+PORTVERSION= 0.8
+CATEGORIES= benchmarks net ipv6
+MASTER_SITES= http://unc.dl.sourceforge.net/sourceforge/thrulay/ \
+ http://internap.dl.sourceforge.net/sourceforge/thrulay/ \
+ http://www.internet2.edu/~shalunov/thrulay/
+
+MAINTAINER= shalunov@internet2.edu
+COMMENT= Network capacity tester
+
+MAN1= thrulay.1
+MAN8= thrulayd.8
+MANCOMPRESSED= no
+USE_GCC= 3.2+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/thrulayd.sh.sample ${PREFIX}/etc/rc.d/
+ @if [ ! -f ${PREFIX}/etc/rc.d/thrulayd.sh ]; then \
+ ${CP} -p ${PREFIX}/etc/rc.d/thrulayd.sh.sample \
+ ${PREFIX}/etc/rc.d/thrulayd.sh ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/benchmarks/thrulay/distinfo b/benchmarks/thrulay/distinfo
new file mode 100644
index 00000000000..b71225b3f6f
--- /dev/null
+++ b/benchmarks/thrulay/distinfo
@@ -0,0 +1 @@
+MD5 (thrulay-0.8.tar.gz) = 725fb13344608a652e818bcd16fe9ef6
diff --git a/benchmarks/thrulay/files/thrulayd.sh.sample b/benchmarks/thrulay/files/thrulayd.sh.sample
new file mode 100644
index 00000000000..a571253778a
--- /dev/null
+++ b/benchmarks/thrulay/files/thrulayd.sh.sample
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+thrulayd=/usr/local/sbin/thrulayd
+
+case "$1" in
+start)
+ [ -x $thrulayd ] && $thrulayd && echo -n ' thrulayd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/benchmarks/thrulay/pkg-descr b/benchmarks/thrulay/pkg-descr
new file mode 100644
index 00000000000..9b5c6ab6295
--- /dev/null
+++ b/benchmarks/thrulay/pkg-descr
@@ -0,0 +1,16 @@
+The program thrulay is used to measure the capacity, delay, and
+other performance metrics of a network by sending a bulk TCP or UDP
+stream over it.
+
+Special features of thrulay include:
+* For TCP, ability to measure round-trip delay along with throughput
+* For UDP, ability to measure
+ - one-way delay, with quantiles
+ - packet loss
+ - packet duplication
+ - reordering
+* For UDP, the ability to send precisely positioned true Poisson streams
+ (microsecond errors in sending times)
+* Human- and machine-readable output (ready to be fed to gnuplot)
+
+WWW: http://www.internet2.edu/~shalunov/thrulay/
diff --git a/benchmarks/thrulay/pkg-message b/benchmarks/thrulay/pkg-message
new file mode 100644
index 00000000000..c2ab049263d
--- /dev/null
+++ b/benchmarks/thrulay/pkg-message
@@ -0,0 +1,4 @@
+The package consists of a client (thrulay) and a daemon (thrulayd).
+The thrulay client is usable immediately. The thrulayd deamon needs to be
+started, which will happen automatically in the next boot cycle. You may
+also start it manually by entering thrulayd as root.
diff --git a/benchmarks/thrulay/pkg-plist b/benchmarks/thrulay/pkg-plist
new file mode 100644
index 00000000000..f18066c04ea
--- /dev/null
+++ b/benchmarks/thrulay/pkg-plist
@@ -0,0 +1,5 @@
+bin/thrulay
+sbin/thrulayd
+@unexec if cmp -s %D/etc/rc.d/thrulayd.sh.sample %D/etc/rc.d/thrulayd.sh; then rm -f %D/etc/rc.d/thrulayd.sh; fi
+etc/rc.d/thrulayd.sh.sample
+@exec if [ ! -f %D/etc/rc.d/thrulayd.sh ] ; then cp -p %D/%F %B/thrulayd.sh; fi