aboutsummaryrefslogtreecommitdiffstats
path: root/biology/boinc-simap/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-20 04:32:08 +0800
committerpav <pav@FreeBSD.org>2006-06-20 04:32:08 +0800
commit0589b6426d724b719018894087d0e6e2965c709e (patch)
tree6cef55cf71d0cacaf1ef450a091f6a87cc23d49f /biology/boinc-simap/Makefile
parente11c6fb2821d0f772f331dcf9d13e4496a19e46e (diff)
downloadfreebsd-ports-graphics-0589b6426d724b719018894087d0e6e2965c709e.tar.gz
freebsd-ports-graphics-0589b6426d724b719018894087d0e6e2965c709e.tar.zst
freebsd-ports-graphics-0589b6426d724b719018894087d0e6e2965c709e.zip
SIMAP (Similarity Matrix of Proteins) is a public database of pre-calculated
protein similarities that plays a key role in many bioinformatics methods. It contains about all currently published protein sequences and is continuously updated. The computational effort for keeping SIMAP up-to-date is constantly increasing. Please help to update SIMAP by calculating protein similarities on your computer. WWW: http://boinc.bio.wzw.tum.de/boincsimap/
Diffstat (limited to 'biology/boinc-simap/Makefile')
-rw-r--r--biology/boinc-simap/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/biology/boinc-simap/Makefile b/biology/boinc-simap/Makefile
new file mode 100644
index 00000000000..813490ac596
--- /dev/null
+++ b/biology/boinc-simap/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: boinc-simap
+# Date created: 29 May 2006
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+# $FreeBSD$
+#
+
+PORTNAME= boinc-simap
+PORTVERSION= 5.08
+CATEGORIES= biology
+MASTER_SITES= http://boinc.bio.wzw.tum.de/boincsimap/download/
+DISTNAME= simap_${PORTVERSION}_i386-pc-freebsd_dyn
+EXTRACT_SUFX= #
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Similarity Matrix of Proteins project for BOINC
+
+RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+STRIP= #
+
+# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
+BOINC_USER?= boinc
+BOINC_GROUP?= nobody
+BOINC_HOME?= /var/db/boinc
+
+SIMAP_SITE= boinc.bio.wzw.tum.de_boincsimap
+SIMAP_URL= boinc.bio.wzw.tum.de/boincsimap
+SIMAP_BINARY= ${DISTNAME}
+
+PLIST_SUB= SIMAP_BINARY=${SIMAP_BINARY} SIMAP_SITE=${SIMAP_SITE} \
+ BOINC_HOME=${BOINC_HOME}
+
+SUB_FILES= app_info.xml
+SUB_LIST= DISTNAME=${DISTNAME} APPVERSION=${PORTVERSION:S/.//}
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386 amd64
+
+.if ${OSVERSION} < 600000
+IGNORE= only supports FreeBSD 6.X and newer
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKDIR}
+
+do-install:
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${SIMAP_SITE}
+ ${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SIMAP_SITE}
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/${SIMAP_BINARY} ${BOINC_HOME}/projects/${SIMAP_SITE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>