aboutsummaryrefslogtreecommitdiffstats
path: root/biology/htslib
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2015-03-06 20:45:22 +0800
committerrobak <robak@FreeBSD.org>2015-03-06 20:45:22 +0800
commite940b3be493452fa1fd3c253fc838f360902bed4 (patch)
tree72b0c0f72bc275bcd3738ba0126c280809fcd30a /biology/htslib
parentf0556e1b7590a6488972734cc309e4696bd61800 (diff)
downloadfreebsd-ports-graphics-e940b3be493452fa1fd3c253fc838f360902bed4.tar.gz
freebsd-ports-graphics-e940b3be493452fa1fd3c253fc838f360902bed4.tar.zst
freebsd-ports-graphics-e940b3be493452fa1fd3c253fc838f360902bed4.zip
biology/htslib: update 1.1 -> 1.2.1
PR: 198291 Submitted by: Reed Cartwright <cartwright@asu.edu>
Diffstat (limited to 'biology/htslib')
-rw-r--r--biology/htslib/Makefile9
-rw-r--r--biology/htslib/distinfo4
-rw-r--r--biology/htslib/files/patch-Makefile31
-rw-r--r--biology/htslib/files/patch-configure.ac11
-rw-r--r--biology/htslib/files/patch-cram_cram__io.c10
-rw-r--r--biology/htslib/pkg-plist3
6 files changed, 45 insertions, 23 deletions
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
index b5abcfaecaa..f03f87f6eae 100644
--- a/biology/htslib/Makefile
+++ b/biology/htslib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= htslib
-PORTVERSION= 1.1
+PORTVERSION= 1.2.1
CATEGORIES= biology devel
MAINTAINER= cartwright@asu.edu
@@ -14,10 +14,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= samtools
-GH_COMMIT= a65fba2
+GH_COMMIT= 6042ece
USES= gmake
USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf
+GNU_CONFIGURE=yes
MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
INSTALL_DATA="${INSTALL_DATA}" \
@@ -26,4 +28,7 @@ MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
PLIST_SUB= PORTVERSION="${PORTVERSION}"
+post-patch:
+ @${REINPLACE_CMD} -e 's|@PORTVERSION@|${PORTVERSION}|g' ${WRKSRC}/configure.ac
+
.include <bsd.port.mk>
diff --git a/biology/htslib/distinfo b/biology/htslib/distinfo
index ca1b3fd93d6..9f6c8e9679f 100644
--- a/biology/htslib/distinfo
+++ b/biology/htslib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (htslib-1.1.tar.gz) = 0614de1795284181675dd0178fb00f0aca176064b6263e3c7e21b53f34710631
-SIZE (htslib-1.1.tar.gz) = 957434
+SHA256 (htslib-1.2.1.tar.gz) = 6403e84e31d3a8179405c4587118144d337b29fa215c0d2948c1c0a6099c5e58
+SIZE (htslib-1.2.1.tar.gz) = 997746
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
index 5a1b1e3300a..83da01f7e5e 100644
--- a/biology/htslib/files/patch-Makefile
+++ b/biology/htslib/files/patch-Makefile
@@ -1,35 +1,28 @@
---- Makefile.orig 2014-09-23 14:39:41 UTC
+--- Makefile.orig 2015-02-03 16:22:23 UTC
+++ Makefile
-@@ -22,33 +22,27 @@
+@@ -22,16 +22,9 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
# DEALINGS IN THE SOFTWARE.
-CC = gcc
-AR = ar
-RANLIB = ranlib
-+CC ?= cc
-+AR = /usr/bin/ar
-+RANLIB = /usr/bin/ranlib
-
- # TODO: edit cram code to remove need for -DSAMTOOLS
--CPPFLAGS = -I. -DSAMTOOLS=1
-+CPPFLAGS += -I. -DSAMTOOLS=1 -Wno-unused-function -Wno-implicit-function-declaration
+-
+-CPPFLAGS = -I.
++CPPFLAGS += -I.
# TODO: probably update cram code to make it compile cleanly with -Wc++-compat
-CFLAGS = -g -Wall -O2
-+CFLAGS += -Wall
EXTRA_CFLAGS_PIC = -fpic
-LDFLAGS =
-LDLIBS =
-+LDFLAGS +=
-+LDLIBS +=
--prefix = /usr/local
-+prefix = ${STAGEDIR}${PREFIX}
- exec_prefix = $(prefix)
- bindir = $(exec_prefix)/bin
+ # For now these don't work too well as samtools also needs to know to
+ # add -lbz2 and -llzma if linking against the static libhts.a library.
+@@ -57,16 +50,10 @@ bindir = $(exec_prefix)/bin
includedir = $(prefix)/include
libdir = $(exec_prefix)/lib
--mandir = $(prefix)/share/man
+ datarootdir = $(prefix)/share
+-mandir = $(datarootdir)/man
+mandir = $(prefix)/man
man1dir = $(mandir)/man1
man5dir = $(mandir)/man5
@@ -44,7 +37,7 @@
BUILT_PROGRAMS = \
bgzip \
-@@ -62,7 +56,7 @@ BUILT_TEST_PROGRAMS = \
+@@ -82,7 +69,7 @@ BUILT_TEST_PROGRAMS = \
test/test-vcf-api \
test/test-vcf-sweep
@@ -53,7 +46,7 @@
HTSPREFIX =
include htslib_vars.mk
-@@ -284,7 +278,7 @@ installdirs:
+@@ -332,7 +319,7 @@ installdirs:
# and libhts.so.NN (used by client executables at runtime).
install-so: libhts.so installdirs
diff --git a/biology/htslib/files/patch-configure.ac b/biology/htslib/files/patch-configure.ac
new file mode 100644
index 00000000000..7e5a1a6363b
--- /dev/null
+++ b/biology/htslib/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2015-02-03 16:22:23 UTC
++++ configure.ac
+@@ -23,7 +23,7 @@
+ # DEALINGS IN THE SOFTWARE.
+
+ dnl Process this file with autoconf to produce a configure script
+-AC_INIT([HTSlib], m4_esyscmd_s([make print-version]),
++AC_INIT([HTSlib], [@PORTVERSION@],
+ [samtools-help@lists.sourceforge.net], [], [http://www.htslib.org/])
+ AC_PREREQ(2.63) dnl This version introduced 4-argument AC_CHECK_HEADER
+ AC_CONFIG_SRCDIR(hts.c)
diff --git a/biology/htslib/files/patch-cram_cram__io.c b/biology/htslib/files/patch-cram_cram__io.c
new file mode 100644
index 00000000000..68121b22c41
--- /dev/null
+++ b/biology/htslib/files/patch-cram_cram__io.c
@@ -0,0 +1,10 @@
+--- cram/cram_io.c.orig 2015-02-03 16:22:23 UTC
++++ cram/cram_io.c
+@@ -53,6 +53,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ #include <assert.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #include <zlib.h>
+ #ifdef HAVE_LIBBZ2
+ #include <bzlib.h>
diff --git a/biology/htslib/pkg-plist b/biology/htslib/pkg-plist
index 74ec1c18ac7..6168f521bc8 100644
--- a/biology/htslib/pkg-plist
+++ b/biology/htslib/pkg-plist
@@ -1,4 +1,5 @@
bin/bgzip
+bin/htsfile
bin/tabix
include/htslib/bgzf.h
include/htslib/faidx.h
@@ -13,6 +14,7 @@ include/htslib/knetfile.h
include/htslib/kseq.h
include/htslib/ksort.h
include/htslib/kstring.h
+include/htslib/regidx.h
include/htslib/sam.h
include/htslib/synced_bcf_reader.h
include/htslib/tbx.h
@@ -24,6 +26,7 @@ lib/libhts.so
lib/libhts.so.1
lib/libhts.so.%%PORTVERSION%%
libdata/pkgconfig/htslib.pc
+man/man1/htsfile.1.gz
man/man1/tabix.1.gz
man/man5/faidx.5.gz
man/man5/sam.5.gz