aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-03-18 14:50:12 +0800
committerjgh <jgh@FreeBSD.org>2013-03-18 14:50:12 +0800
commit15dd3e85a94affd38ababb54635d09cc0960711a (patch)
tree0a7df103fc38449c80dc482039841eb3244564d8 /biology
parentfa21bac47805001f8f9d332f113ef441392c6b29 (diff)
downloadfreebsd-ports-graphics-15dd3e85a94affd38ababb54635d09cc0960711a.tar.gz
freebsd-ports-graphics-15dd3e85a94affd38ababb54635d09cc0960711a.tar.zst
freebsd-ports-graphics-15dd3e85a94affd38ababb54635d09cc0960711a.zip
- adoption of optionsNG
- trim historical header - tighten COMMENT Approved by: portmgr (miwi)
Diffstat (limited to 'biology')
-rw-r--r--biology/libsbml/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index 099e3e757a1..ea6926109c3 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libsbml
-# Date created: 29 May, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= libsbml
PORTVERSION= 4.2.0
@@ -13,12 +9,11 @@ MASTER_SITE_SUBDIR= sbml/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= wen@FreeBSD.org
-COMMENT= An API Library for Working with SBML File
+COMMENT= API Library for Working with SBML File
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-OPTIONS= PYTHON "Support for Python" off \
- RUBY "Support for Ruby" off
+OPTIONS_DEFINE= PYTHON RUBY
USE_GMAKE= yes
USE_ZIP= yes
@@ -28,7 +23,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_PYTHON)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPYTHON}
.include "../../Mk/bsd.python.mk"
BUILD_DEPENDS+= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python
CONFIGURE_ARGS+= --with-python
@@ -38,7 +35,7 @@ PLIST_SUB+= WITH_PYTHON="" \
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.if defined(WITH_RUBY)
+.if ${PORT_OPTIONS:MRUBY}
.include "../../Mk/bsd.ruby.mk"
BUILD_DEPENDS+= ${LOCALBASE}/bin/ruby:${PORTSDIR}/lang/ruby18
CONFIGURE_ARGS+= --with-ruby
@@ -52,7 +49,7 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples \
&& ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/\{} \; \