aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-01-13 03:07:28 +0800
committerriggs <riggs@FreeBSD.org>2014-01-13 03:07:28 +0800
commit5127b0becbeca8231fbf88bae26500981f6fa6e2 (patch)
tree5a5cef7a03b8622bc3f1291f93adf333f0877509 /biology
parent0865290735dfaab37a8c884733f75f795e8e2749 (diff)
downloadfreebsd-ports-graphics-5127b0becbeca8231fbf88bae26500981f6fa6e2.tar.gz
freebsd-ports-graphics-5127b0becbeca8231fbf88bae26500981f6fa6e2.tar.zst
freebsd-ports-graphics-5127b0becbeca8231fbf88bae26500981f6fa6e2.zip
- Fix build with clang
- Stage support PR: ports/185655 Submitted by: Tassilo Philipp <tphilipp@potion-studios.com> (maintainer) Approved by: thierry (mentor)
Diffstat (limited to 'biology')
-rw-r--r--biology/mapm3/Makefile6
-rw-r--r--biology/mapm3/files/patch-Makefile15
2 files changed, 8 insertions, 13 deletions
diff --git a/biology/mapm3/Makefile b/biology/mapm3/Makefile
index bfcacc0a341..6eb6b74187a 100644
--- a/biology/mapm3/Makefile
+++ b/biology/mapm3/Makefile
@@ -14,11 +14,15 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= tphilipp@potion-studios.com
COMMENT= Constructs linkage maps of markers segregating in experimental crosses
+USE_CSTD= gnu89
+CFLAGS+= -Wno-return-type
NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
post-patch:
${CP} ${WRKSRC}/sun/* ${WRKSRC}
+pre-install:
+ @${REINPLACE_CMD} -e 's|/usr/local|${STAGEDIR}${PREFIX}|' ${WRKSRC}/Makefile
+
.include <bsd.port.mk>
diff --git a/biology/mapm3/files/patch-Makefile b/biology/mapm3/files/patch-Makefile
index 0b1a8f1454d..35bf5e83a6c 100644
--- a/biology/mapm3/files/patch-Makefile
+++ b/biology/mapm3/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2008-04-04 20:05:29.000000000 +0000
-+++ Makefile 2008-04-04 19:51:04.000000000 +0000
+--- Makefile.orig 1993-02-10 07:12:59.000000000 +0100
++++ Makefile 2014-01-12 18:47:03.605582463 +0100
@@ -16,6 +16,7 @@
####
#### For Macs with A/UX, use: SYS= -D_SYS_AUX
@@ -17,15 +17,6 @@
#### Next define the system libraries to link with Mapmaker. On SunOS, Ultrix
#### and other vanilla-ish BSD systems, the correct setting is:
-@@ -46,7 +47,7 @@
- #### Be sure that you have write permission to this directory (e.g. you may
- #### need to be logged in as "root" to install MAPMAKER in some directories).
-
--DIR= /usr/local/bin
-+DIR= ${PREFIX}/bin
-
- #### RDLN below refers to the GNU Readline library, which can (optionally) be
- #### used by MAPMAKER to provide interactive command line editing. See the
@@ -70,9 +71,11 @@
#### (see the end of readline/readline.c). Readline will not compile on
#### A/UX without using GCC instead of A/UX's cc (because it needs alloca).
@@ -47,7 +38,7 @@
-COMPILE= cc
-LINKALL= cc
-+COMPILE= ${CC}
++COMPILE= ${CC} ${CFLAGS}
+LINKALL= ${CC}
LINKLIB= ld -r
DELETE= rm -f