aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2010-04-01 13:16:19 +0800
committerlinimon <linimon@FreeBSD.org>2010-04-01 13:16:19 +0800
commitda8f0853adae8aab3297cf3b94ab0872013558e2 (patch)
treee379b79fc9599ab2ffed8b3205c51b8669e842fb /biology
parentbb38fa1017be9dbd2be5987793912f413376ed2b (diff)
downloadfreebsd-ports-graphics-da8f0853adae8aab3297cf3b94ab0872013558e2.tar.gz
freebsd-ports-graphics-da8f0853adae8aab3297cf3b94ab0872013558e2.tar.zst
freebsd-ports-graphics-da8f0853adae8aab3297cf3b94ab0872013558e2.zip
Mark various ports as broken or ignore on powerpc.
While here, remove remnants of alpha.
Diffstat (limited to 'biology')
-rw-r--r--biology/avida/Makefile8
-rw-r--r--biology/babel/Makefile8
-rw-r--r--biology/fasta/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index 637e8a3af5c..d81dcfd8f55 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -35,4 +35,10 @@ post-install:
cd ${WRKSRC}/documentation && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc: invokes i386 asm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/biology/babel/Makefile b/biology/babel/Makefile
index 88fe4c860ae..742db1c47d0 100644
--- a/biology/babel/Makefile
+++ b/biology/babel/Makefile
@@ -32,4 +32,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README.1ST ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/biology/fasta/Makefile b/biology/fasta/Makefile
index cd15d20c8b8..cf6389f61ed 100644
--- a/biology/fasta/Makefile
+++ b/biology/fasta/Makefile
@@ -45,4 +45,10 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+IGNORE= does not build: runs out of space on powerpc
+.endif
+
+.include <bsd.port.post.mk>