aboutsummaryrefslogtreecommitdiffstats
path: root/cad/atlc/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-11-14 04:21:29 +0800
committerlioux <lioux@FreeBSD.org>2002-11-14 04:21:29 +0800
commit4804470620d4eda512f1d4885309b2bcf408dc71 (patch)
tree4256f8ec3c2c38a8c56084ea17b462f223852da6 /cad/atlc/Makefile
parent67d3465504ab8eb6e134ef6745ea5f2e66a1f86e (diff)
downloadfreebsd-ports-graphics-4804470620d4eda512f1d4885309b2bcf408dc71.tar.gz
freebsd-ports-graphics-4804470620d4eda512f1d4885309b2bcf408dc71.tar.zst
freebsd-ports-graphics-4804470620d4eda512f1d4885309b2bcf408dc71.zip
New port atlc version 4.0.1: A tool to calculate the impedance of
transmission lines Submitted by: blackend
Diffstat (limited to 'cad/atlc/Makefile')
-rw-r--r--cad/atlc/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/cad/atlc/Makefile b/cad/atlc/Makefile
new file mode 100644
index 00000000000..2cbe7bc963b
--- /dev/null
+++ b/cad/atlc/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: atlc
+# Date created: 9 November 2002
+# Whom: Marc Fonvieille <blackend@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= atlc
+PORTVERSION= 4.0.1
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/atlc/}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= blackend@FreeBSD.org
+
+USE_REINPLACE= YES
+GNU_CONFIGURE= YES
+
+MAN1= atlc.1 rect_in_rect.1 circ_in_circ.1 \
+ circ_in_rect.1 rect_cen_in_rect.1 readbin.1 sym_strip.1
+
+pre-everything::
+ @${ECHO_MSG}
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "You can enable additional compilation optimizations"
+ @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.endif
+ @${ECHO_MSG}
+
+post-patch:
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -E -e 's,-O(2|3),,' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/examples/atlc
+ @${CP} ${WRKDIR}/${DISTNAME}/examples/*.bmp \
+ ${PREFIX}/share/examples/atlc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/atlc
+ @${INSTALL_DATA} \
+ ${WRKDIR}/${DISTNAME}/docs/html-docs/*.html \
+ ${PREFIX}/share/doc/atlc
+ @${MKDIR} ${PREFIX}/share/doc/atlc/jpgs
+ @${INSTALL_DATA} \
+ ${WRKDIR}/${DISTNAME}/docs/html-docs/jpgs/*.jpg \
+ ${PREFIX}/share/doc/atlc/jpgs
+.endif
+
+.include <bsd.port.mk>