aboutsummaryrefslogtreecommitdiffstats
path: root/cad/sp2sp
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2016-11-07 05:48:54 +0800
committerhrs <hrs@FreeBSD.org>2016-11-07 05:48:54 +0800
commit0ec32a761774cd3d28ab42a8cfcf9d7fa9b5bd82 (patch)
tree3dd1a48ed3aefd09554f62ac558c621d49bf41de /cad/sp2sp
parent29f0ce21dae53dd7f55ef5a01979308593ecbfca (diff)
downloadfreebsd-ports-graphics-0ec32a761774cd3d28ab42a8cfcf9d7fa9b5bd82.tar.gz
freebsd-ports-graphics-0ec32a761774cd3d28ab42a8cfcf9d7fa9b5bd82.tar.zst
freebsd-ports-graphics-0ec32a761774cd3d28ab42a8cfcf9d7fa9b5bd82.zip
Fix broken dependencies.
Diffstat (limited to 'cad/sp2sp')
-rw-r--r--cad/sp2sp/Makefile2
-rw-r--r--cad/sp2sp/files/patch-configure.ac18
2 files changed, 11 insertions, 9 deletions
diff --git a/cad/sp2sp/Makefile b/cad/sp2sp/Makefile
index 2bd4b58a713..53065419a55 100644
--- a/cad/sp2sp/Makefile
+++ b/cad/sp2sp/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= autoreconf gettext-runtime
+USES= autoreconf gettext-runtime pkgconfig
USE_GNOME= gtk20 pango atk cairo gdkpixbuf2 glib20
GNU_CONFIGURE= yes
PLIST_FILES= bin/sp2sp
diff --git a/cad/sp2sp/files/patch-configure.ac b/cad/sp2sp/files/patch-configure.ac
index 4039a84ddf7..94d79ec8f39 100644
--- a/cad/sp2sp/files/patch-configure.ac
+++ b/cad/sp2sp/files/patch-configure.ac
@@ -1,9 +1,12 @@
--- configure.ac.orig 2009-02-13 14:00:57.000000000 +0900
-+++ configure.ac 2016-11-06 03:36:13.237251000 +0900
-@@ -16,20 +16,6 @@
- AC_PATH_PROGS(PERL, perl perl5, no)
- AC_SUBST(PERL)
-
++++ configure.ac 2016-11-07 06:46:23.065992000 +0900
+@@ -13,22 +13,6 @@
+ AC_PROG_CC
+ AC_PROG_RANLIB
+ AC_PROG_LN_S
+-AC_PATH_PROGS(PERL, perl perl5, no)
+-AC_SUBST(PERL)
+-
-# this tries to find GNU graph only, not traditional berkeley/sysv graph,
-# so we do the right thing on solaris, where an unusable one is in /usr/bin
-# and the graph we want is usually in /usr/local/bin or some such.
@@ -17,11 +20,10 @@
- AC_DEFINE_UNQUOTED(PROG_GRAPH, "$GRAPH", [If present, the pathname of graph, from GNU plotutils.])
- fi
-fi
--
+
dnl do we need libtool?
dnl even though we aren't building shared libraries, it seemed to help on HP-UX
- dnl AM_PROG_LIBTOOL
-@@ -51,62 +37,8 @@
+@@ -51,62 +35,8 @@
dnl check for gtk/glib features
AC_CHECK_LIB(c, g_slice_set_config, AC_DEFINE(HAVE_G_SLICE_SET_CONFIG,1,[Define this if your version of glib2 has the slice allocator and g_slice_set_config]),,[$GTK_LIBS])